cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
224
Views
0
Helpful
0
Replies

Troubleshooting Port Authentication with NPS Error code 22

jasinkadrioski
Level 1
Level 1

Hello everyone,

I have little expertise in network security and work for a small company. I need to configure port authentication for a SF550X-24P 24-Port 10/100 PoE Stackable Managed Switch with firmware version 2.5.9.54.

What I learned is that I need to configure a RADIUS server for which I used our Active Directory Domain Controller and installed NPS server role. After setting up the configuration and enabling "Auto" and "Web authentication" for a specific port I tested the connectivity by logging in with credentials from a test AD User. After not getting permitted into the network, I looked into the event logs on my windows server and saw error code 22: "The provided EAP Type couldn't be processed by the server".

I tried the following things, since I was made to believe this had to do something with a faulty TLS Handshake between Switch and Server. I made sure to create a certificate for the purpose of clientauthentication for my NPS and also installed the same certificate on my switch. After doing that, I unfortunately got the same error log telling me that the wrong EAP type was used. On the NPS I have configured every possible option for authentication methods just so I can debug the problem. Do I need to configure anything else on my switch? Because if so, I have not found a method to do so yet, because even in the documentation, there is only mentioning of "EAP" and nowhere anything according to other EAP types or methods.

I also got told that the "client" chooses EAP type so I have to configure my own computer? I tried configuring EAP but Windows 10 does not let me do that through GUI options that easily for LAN connection.

Does anyone have any idea what the issue could be here?

0 Replies 0
Review Cisco Networking for a $25 gift card