cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2434
Views
0
Helpful
16
Replies
Navindar Singh
Beginner

VPN pool cannot ping inside interface

Hello Guys,

I am setting up a cisco asa 5505 FW. I can get interent on the FW and i can connect to the vpn client fine and get a address from the vpn pool i created. The only issue is that i cannot reach the inside interface from the VPN pool. Can someone please assist asap.

Below is my current config....

ASA Version 8.2(5)

!

hostname LCCVPN

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

switchport access vlan 2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

<--- More --->

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.0.0.4 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

pppoe client vpdn group lccvpn

ip address pppoe

!

ftp mode passive

clock timezone FJST 12

object-group network LAN

network-object 10.0.0.0 255.255.255.0

object-group network VPNpool

network-object 10.20.12.0 255.255.255.0

access-list Network-List standard permit 10.0.0.0 255.255.255.0

access-list Network-List1 standard permit 10.0.0.0 255.255.255.0

access-list inside_access_in extended permit ip any any

pager lines 24

logging enable

<--- More --->

logging timestamp

logging trap informational

logging asdm informational

logging permit-hostdown

mtu inside 1500

mtu outside 1500

ip local pool VPNPool 10.20.12.1-10.20.12.254 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-613.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

route inside 10.0.0.0 255.0.0.0 10.0.0.4 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

<--- More --->

aaa authentication telnet console LOCAL

aaa authorization command LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

http 192.168.252.0 255.255.255.128 inside

http 10.2.2.0 255.255.255.0 inside

http 10.0.0.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community *****

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

<--- More --->

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000

crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto isakmp enable outside

crypto isakmp policy 5

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

crypto isakmp policy 10

authentication pre-share

encryption des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh 10.0.0.0 255.255.255.0 inside

ssh timeout 5

console timeout 5

vpdn group lccvpn request dialout pppoe

vpdn group lccvpn localname navinisp

vpdn group lccvpn ppp authentication pap

vpdn username navinisp password *****

<--- More --->

dhcpd auto_config outside

!

dhcpd address 10.0.0.10-10.0.0.30 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

enable outside

svc image disk0:/anyconnect-win-2.3.0254-k9.pkg 1 regex "Windows NT"

svc enable

group-policy SSLVPN internal

group-policy SSLVPN attributes

banner value This is a private system

banner value Access to this computer system is limited to authorised users only.

banner value This authorization must be obtained in writing from the system owner

banner value Unauthorised users may be subject to prosecution under the Crimes

banner value Act or State legislation

banner value

banner value All accesses to this service are logged

banner value All information and details on this system are private,

banner value confidential and must not be disclosed

<--- More --->

vpn-tunnel-protocol svc

split-tunnel-policy tunnelspecified

split-tunnel-network-list value Network-List1

default-domain value tfl.internal

address-pools value VPNPool

group-policy TechM_VPN_SSL internal

group-policy TechM_VPN_SSL attributes

vpn-tunnel-protocol svc

split-tunnel-policy tunnelspecified

split-tunnel-network-list value Network-List1

address-pools value VPNPool

group-policy DfltGrpPolicy attributes

vpn-tunnel-protocol webvpn

group-policy VPN-Client internal

group-policy VPN-Client attributes

vpn-tunnel-protocol IPSec

ip-comp enable

split-tunnel-policy tunnelspecified

split-tunnel-network-list value Network-List1

default-domain value tfl.internal

user-authentication-idle-timeout 30

address-pools value VPNPool

webvpn

  svc compression deflate

<--- More --->

username AutikoL password 5lj6NPIi/MYVQYVN encrypted

username AutikoL attributes

vpn-group-policy VPN-Client

vpn-tunnel-protocol IPSec

group-lock value Client-VPN

service-type remote-access

username admin password f3UhLvUj1QsXsuK7 encrypted

username infra password /l3N1ysL5h1bzNBn encrypted privilege 15

username Shoebh password 9MMH3XLR8ARsN5Cf encrypted

username Shoebh attributes

vpn-group-policy SSLVPN

service-type remote-access

username navindars password hKEmegKvbMayue/0 encrypted privilege 15

username navindars attributes

vpn-group-policy SSLVPN

username LCCVPN password KKr3nUkVs/K4GsoE encrypted

username LCCVPN attributes

vpn-group-policy SSLVPN

service-type remote-access

tunnel-group VPN-SSL type remote-access

tunnel-group VPN-SSL general-attributes

address-pool VPNPool

default-group-policy SSLVPN

tunnel-group Client-VPN type remote-access

<--- More --->

tunnel-group Client-VPN general-attributes

address-pool VPNPool

default-group-policy VPN-Client

tunnel-group Client-VPN ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect netbios

  inspect rsh

  inspect rtsp

  inspect skinny 

  inspect esmtp

<--- More --->

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip 

  inspect xdmcp

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:c6f5f803a4a33a27bf2ddc912aa8966a

: end

1 ACCEPTED SOLUTION

Accepted Solutions

Hey

Also modify your NAT statement

access-list NONAT permit ip 10.0.0.0 255.255.255.0 10.20.12.0 255.255.255.0

nat (inside) 0 access-list NONAT

Hope this gona solve your problem

Thanks


View solution in original post

16 REPLIES 16
vishaw jasrotia
Beginner

Hey ,

Apply the access-group policy for the access from the outside interface.

access-list 110 extended permit ip object-group VPNpool any

access-group 110 in interface outside

Thanks


Thanks a lot for  the reply Vishwa, i tried that but it still did not work. Anything else i can try?

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

switchport access vlan 2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

<--- More --->

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.0.0.4 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

pppoe client vpdn group lccvpn

ip address pppoe

!

ftp mode passive

clock timezone FJST 12

object-group network LAN

network-object 10.0.0.0 255.255.255.0

object-group network VPNpool

network-object 10.20.12.0 255.255.255.0

access-list Network-List standard permit 10.0.0.0 255.255.255.0

access-list Network-List1 standard permit 10.0.0.0 255.255.255.0

access-list inside_access_in extended permit ip any any

access-list 110 extended permit ip object-group VPNpool any

pager lines 24

<--- More --->

logging enable

logging timestamp

logging trap informational

logging asdm informational

logging permit-hostdown

mtu inside 1500

mtu outside 1500

ip local pool VPNPool 10.20.12.1-10.20.12.254 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-613.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

access-group 110 in interface outside

route outside 0.0.0.0 0.0.0.0 x.x.x.x 1

route inside 10.0.0.0 255.0.0.0 10.0.0.4 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

<--- More --->

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

aaa authentication telnet console LOCAL

aaa authorization command LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

http 192.168.252.0 255.255.255.128 inside

http 10.2.2.0 255.255.255.0 inside

http 10.0.0.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community *****

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec security-association lifetime seconds 28800

<--- More --->

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000

crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto isakmp enable outside

crypto isakmp policy 5

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

crypto isakmp policy 10

authentication pre-share

encryption des

hash sha

group 2

lifetime 86400

crypto isakmp nat-traversal 30

telnet timeout 5

ssh 10.0.0.0 255.255.255.0 inside

ssh timeout 5

console timeout 5

vpdn group lccvpn request dialout pppoe

<--- More --->

vpdn group lccvpn localname navinisp

vpdn group lccvpn ppp authentication pap

vpdn username navinisp password *****

dhcpd auto_config outside

!

dhcpd address 10.0.0.10-10.0.0.30 inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

enable outside

svc image disk0:/anyconnect-win-2.3.0254-k9.pkg 1 regex "Windows NT"

svc enable

group-policy SSLVPN internal

group-policy SSLVPN attributes

banner value This is a private system

banner value Access to this computer system is limited to authorised users only.

banner value This authorization must be obtained in writing from the system owner

banner value Unauthorised users may be subject to prosecution under the Crimes

banner value Act or State legislation

banner value

<--- More --->

banner value All accesses to this service are logged

banner value All information and details on this system are private,

banner value confidential and must not be disclosed

vpn-tunnel-protocol svc

split-tunnel-policy tunnelspecified

split-tunnel-network-list value Network-List1

default-domain value tfl.internal

address-pools value VPNPool

group-policy TechM_VPN_SSL internal

group-policy TechM_VPN_SSL attributes

vpn-tunnel-protocol svc

split-tunnel-policy tunnelspecified

split-tunnel-network-list value Network-List1

address-pools value VPNPool

group-policy DfltGrpPolicy attributes

vpn-tunnel-protocol webvpn

group-policy VPN-Client internal

group-policy VPN-Client attributes

vpn-tunnel-protocol IPSec

ip-comp enable

split-tunnel-policy tunnelspecified

split-tunnel-network-list value Network-List1

default-domain value tfl.internal

user-authentication-idle-timeout 30

<--- More --->

address-pools value VPNPool

webvpn

  svc compression deflate

username AutikoL password 5lj6NPIi/MYVQYVN encrypted

username AutikoL attributes

vpn-group-policy VPN-Client

vpn-tunnel-protocol IPSec

group-lock value Client-VPN

service-type remote-access

username admin password f3UhLvUj1QsXsuK7 encrypted

username infra password /l3N1ysL5h1bzNBn encrypted privilege 15

username Shoebh password 9MMH3XLR8ARsN5Cf encrypted

username Shoebh attributes

vpn-group-policy SSLVPN

service-type remote-access

username navindars password hKEmegKvbMayue/0 encrypted privilege 15

username navindars attributes

vpn-group-policy SSLVPN

username LCCVPN password KKr3nUkVs/K4GsoE encrypted

username LCCVPN attributes

vpn-group-policy SSLVPN

service-type remote-access

tunnel-group VPN-SSL type remote-access

tunnel-group VPN-SSL general-attributes

<--- More --->

address-pool VPNPool

default-group-policy SSLVPN

tunnel-group Client-VPN type remote-access

tunnel-group Client-VPN general-attributes

address-pool VPNPool

default-group-policy VPN-Client

tunnel-group Client-VPN ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect netbios

  inspect rsh

<--- More --->

  inspect rtsp

  inspect skinny 

  inspect esmtp

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip 

  inspect xdmcp

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:52035bac4531ee82f99fadaa87730d95

: end

Hey

Please take the packet trace output

packet-tracer input outside tcp

Thanks

LCCVPN# packet-tracer input outside tcp 10.20.12.2 echo 10.0.0.12 echo

Phase: 1

Type: ACCESS-LIST

Subtype:

Result: ALLOW

Config:

Implicit Rule

Additional Information:

MAC Access list

Phase: 2

Type: ROUTE-LOOKUP

Subtype: input

Result: ALLOW

Config:

Additional Information:

in   10.0.0.0        255.255.255.0   inside

Phase: 3

Type: ACCESS-LIST

Subtype: log

Result: ALLOW

Config:

access-group 110 in interface outside

access-list 110 extended permit ip object-group VPNpool any

object-group network VPNpool

network-object 10.20.12.0 255.255.255.0

Additional Information:

Phase: 4

Type: IP-OPTIONS

Subtype:

Result: ALLOW

Config:

Additional Information:

Phase: 5

Type: CP-PUNT

Subtype:

Result: ALLOW

Config:

Additional Information:

Phase: 6

Type: WEBVPN-SVC

Subtype: in

Result: DROP

Config:

Additional Information:

Result:

input-interface: outside

input-status: up

input-line-status: up

output-interface: inside

output-status: up

output-line-status: up

Action: drop

Drop-reason: (acl-drop) Flow is denied by configured rule

Hey ,

Try this

no access-list 110 extended permit ip object-group VPNpool any

no access-group 110 in interface outside

access-list 110 extended permit ip oany any

access-group 110 in interface outside

Thanks

I tried that too and it still doesnt work....

Hey

Also modify your NAT statement

access-list NONAT permit ip 10.0.0.0 255.255.255.0 10.20.12.0 255.255.255.0

nat (inside) 0 access-list NONAT

Hope this gona solve your problem

Thanks


View solution in original post

Yes that finally made it work...thanks a lot for the help bro much appreciated....

Always welcome...:)

sorry to disturb u again bro but just 1 more thing....i can ping the equipment on the inside interface but i cannot ping the gateway 10.0.0.4....any idea why i cannot do that?

C:\Users\navindar.singh>ping 10.0.0.12

Pinging 10.0.0.12 with 32 bytes of data:

Reply from 10.0.0.12: bytes=32 time=18ms TTL=128

Reply from 10.0.0.12: bytes=32 time=20ms TTL=128

Reply from 10.0.0.12: bytes=32 time=20ms TTL=128

Reply from 10.0.0.12: bytes=32 time=16ms TTL=128

Ping statistics for 10.0.0.12:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 16ms, Maximum = 20ms, Average = 18ms

C:\Users\navindar.singh>ping 10.0.0.4

Pinging 10.0.0.4 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 10.0.0.4:

    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Phase: 1

Type: ROUTE-LOOKUP

Subtype: input

Result: ALLOW

Config:

Additional Information:

in   10.0.0.4        255.255.255.255 identity

Phase: 2

Type: ACCESS-LIST

Subtype:

Result: DROP

Config:

Implicit Rule

Additional Information:

Result:

input-interface: outside

input-status: up

input-line-status: up

output-interface: NP Identity Ifc

output-status: up

output-line-status: up

Action: drop

Drop-reason: (acl-drop) Flow is denied by configured rule

Hey

In ASA there is default policy that , you can't ping the gateway (ASA interface ip) from the different interface subnet.

In sumup you can ping the ASA interface IP from  respective  pool only.

Thanks

oh ok....thanks a lot bro..have a great day....

Create
Recognize Your Peers
Content for Community-Ad