Now viewing draft 14.
on 12-29-2023 06:24 AM
Cisco IP Helper-Address helps to lease IP addresses to Remote office via Serial WAN network.
The solution for Remote office client machines need to have access to a DNS server, Web Server at Cooperative office. Cisco “IP Helper-Address" command supports leasing an IP address for their clients at remote office through WAN serial connection that communication establish with a DHCP server at a Cooperative office and get access of their resources which allowed by Cooperative office.
Step by Step implementation shows below:
Left side of network topology is Remote Office; Right side of network topology is Cooperative Office
Routers:
Cooperative office router: "MAIN"
Remote office router: "REMOTE-1"
Local office-1 router: "LOCAL-OFF-1" (VLAN10)
Local office-2 router: "LOCAL-OFF-2" (VLAN20)
Switches:
Cooperative office switches: "L2SW-MAIN-1" and "L2SW-MAIN-2"
Local office switches: "L2SW-OFF-1" and "L2SW-OFF-2"
Configuration of "MAIN" router at Cooperative office:
MAIN>
MAIN>enable
MAIN#config t
MAIN(config-if)#
MAIN(config)#interface GigabitEthernet0/0
MAIN(config-if)# description LAN DHCP Server Connection
MAIN(config-if)# ip address 10.68.1.2 255.255.255.0
MAIN(config-if)# ip helper-address 10.68.10.2
MAIN(config-if)# duplex auto
MAIN(config-if)# speed auto
MAIN(config-if)#
MAIN(config-if)#interface Serial0/3/0
MAIN(config-if)# description Serial WAN connection to REMOTE_1 router
MAIN(config-if)# ip address 172.16.80.1 255.255.255.252
MAIN(config-if)#
MAIN(config-if)#router eigrp 10
MAIN(config-router)# network 10.0.0.0
MAIN(config-router)# network 172.16.0.0
MAIN(config-router)#
MAIN(config-router)#ip route 10.68.10.0 255.255.255.0 172.16.80.2
MAIN(config)#ip route 192.168.100.0 255.255.255.252 172.16.80.2
MAIN(config)#ip route 10.68.20.0 255.255.255.0 172.16.80.2
MAIN(config)#ip route 192.168.200.0 255.255.255.0 172.16.80.2
MAIN(config)#ip route 0.0.0.0 0.0.0.0 Serial0/3/0
MAIN(config)#
Show run command MAIN router:
MAIN>
MAIN>enable
MAIN#sh run
Building configuration...
!
interface GigabitEthernet0/0
description LAN DHCP Server Connection
ip address 10.68.1.2 255.255.255.0
ip helper-address 10.68.10.2
duplex auto
speed auto
!
interface Serial0/3/0
description Serial WAN connection to REMOTE_1 router
ip address 172.16.80.1 255.255.255.252
!
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
network 172.16.0.0
!
ip classless
ip route 10.68.10.0 255.255.255.0 172.16.80.2
ip route 192.168.100.0 255.255.255.252 172.16.80.2
ip route 10.68.20.0 255.255.255.0 172.16.80.2
ip route 192.168.200.0 255.255.255.0 172.16.80.2
ip route 0.0.0.0 0.0.0.0 Serial0/3/0
!
Cooperative office DHCP Server configuration:
Assign static IP to DHCP Server:
Configure DHCP Server:
Remote Office Routers configurations:
REMOTE-1 Router:
REMOTE-1>enable
REMOTE-1#conf t
REMOTE-1(config)#interface GigabitEthernet0/0
REMOTE-1(config-if)# description Connection to LOCAL_OFF_1 router
REMOTE-1(config-if)# ip address 192.168.100.2 255.255.255.252
REMOTE-1(config-if)# ip helper-address 10.68.1.1
REMOTE-1(config-if)# duplex auto
REMOTE-1(config-if)# speed auto
REMOTE-1(config-if)#
REMOTE-1(config-if)#interface GigabitEthernet0/1
REMOTE-1(config-if)# description Connection to LOCAL-OFF-2 router
REMOTE-1(config-if)# ip address 192.168.200.2 255.255.255.252
REMOTE-1(config-if)# ip helper-address 10.68.1.1
REMOTE-1(config-if)# duplex auto
REMOTE-1(config-if)# speed auto
REMOTE-1(config-if)#
REMOTE-1(config-if)#interface Serial0/3/0
REMOTE-1(config-if)# description Serial WAN connection to MAIN router
REMOTE-1(config-if)# ip address 172.16.80.2 255.255.255.252
REMOTE-1(config-if)# clock rate 2000000
REMOTE-1(config-if)#
REMOTE-1(config-if)#
REMOTE-1(config-if)#interface Vlan1
REMOTE-1(config-if)# no ip address
REMOTE-1(config-if)# shutdown
REMOTE-1(config-if)#
REMOTE-1(config-if)#router eigrp 10
REMOTE-1(config-router)# network 172.16.0.0
REMOTE-1(config-router)# network 192.168.0.0
REMOTE-1(config-router)# network 192.168.200.0
REMOTE-1(config-router)#
REMOTE-1(config-router)#ip route 10.68.10.0 255.255.255.0 192.168.100.1
REMOTE-1(config)#ip route 10.68.1.0 255.255.255.0 172.16.80.1
REMOTE-1(config)#ip route 10.68.20.0 255.255.255.0 192.168.200.1
REMOTE-1(config)#
REMOTE-1(config)#
Show run command REMOTE-1 router:
REMOTE-1>
REMOTE-1>enable
REMOTE-1#sh run
!
hostname REMOTE-1
!
!
interface GigabitEthernet0/0
description Connection to LOCAL_OFF_1 router
ip address 192.168.100.2 255.255.255.252
ip helper-address 10.68.1.1
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Connection to LOCAL-OFF-2 router
ip address 192.168.200.2 255.255.255.252
ip helper-address 10.68.1.1
duplex auto
speed auto
!
interface Serial0/3/0
description Serial WAN connection to MAIN router
ip address 172.16.80.2 255.255.255.252
clock rate 2000000
!
!
router eigrp 10
network 172.16.0.0
network 192.168.0.0
network 192.168.200.0
!
ip classless
ip route 10.68.10.0 255.255.255.0 192.168.100.1
ip route 10.68.1.0 255.255.255.0 172.16.80.1
ip route 10.68.20.0 255.255.255.0 192.168.200.1
!
Local Office Router-1 Configuratons:
LOCAL-OFF-1>
LOCAL-OFF-1>enable
LOCAL-OFF-1#
LOCAL-OFF-1#
LOCAL-OFF-1#conf t
LOCAL-OFF-1(config)#
LOCAL-OFF-1(config)#
LOCAL-OFF-1(config)#interface GigabitEthernet0/0
LOCAL-OFF-1(config-if)# description connection to Local OFFICE-1 VALN-10
LOCAL-OFF-1(config-if)# ip address 10.68.10.1 255.255.255.0
LOCAL-OFF-1(config-if)# ip helper-address 10.68.1.1
LOCAL-OFF-1(config-if)# duplex auto
LOCAL-OFF-1(config-if)# speed auto
LOCAL-OFF-1(config-if)#
LOCAL-OFF-1(config-if)#interface GigabitEthernet0/1
LOCAL-OFF-1(config-if)# description WAN connection to REMOTE-1 router
LOCAL-OFF-1(config-if)# ip address 192.168.100.1 255.255.255.252
LOCAL-OFF-1(config-if)# duplex auto
LOCAL-OFF-1(config-if)# speed auto
LOCAL-OFF-1(config-if)#
LOCAL-OFF-1(config-if)#interface Vlan1
LOCAL-OFF-1(config-if)# no ip address
LOCAL-OFF-1(config-if)# shutdown
LOCAL-OFF-1(config-if)#
LOCAL-OFF-1(config-if)#router eigrp 10
LOCAL-OFF-1(config-router)# network 10.0.0.0
LOCAL-OFF-1(config-router)# network 192.168.100.0
LOCAL-OFF-1(config-router)#
LOCAL-OFF-1(config-router)#ip route 172.16.80.0 255.255.255.252 192.168.100.2
LOCAL-OFF-1(config)#ip route 10.68.1.0 255.255.255.0 192.168.100.2
LOCAL-OFF-1(config)#ip route 10.68.20.0 255.255.255.0 192.168.100.2
LOCAL-OFF-1(config)#!
LOCAL-OFF-1(config)#
LOCAL-OFF-1(config)#
Show run command LOCAL-OFF-1 router:
LOCAL-OFF-1>
LOCAL-OFF-1>enable
LOCAL-OFF-1#sh run
!
hostname LOCAL-OFF-1
!
interface GigabitEthernet0/0
description connection to Local OFFICE-1 VALN-10
ip address 10.68.10.1 255.255.255.0
ip helper-address 10.68.1.1
duplex auto
speed auto
!
interface GigabitEthernet0/1
description WAN connection to REMOTE-1 router
ip address 192.168.100.1 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
network 192.168.100.0
!
ip classless
ip route 172.16.80.0 255.255.255.252 192.168.100.2
ip route 10.68.1.0 255.255.255.0 192.168.100.2
ip route 10.68.20.0 255.255.255.0 192.168.100.2
!
!
line con 0
!
Local Office Router-2 Configuratons:
LOCAL-OFF-2>
LOCAL-OFF-2>enable
LOCAL-OFF-2#conf t
LOCAL-OFF-2(config)#
LOCAL-OFF-2(config)#interface GigabitEthernet0/0
LOCAL-OFF-2(config-if)# description Connection to Local Office-2 VLAN-20
LOCAL-OFF-2(config-if)# ip address 10.68.20.1 255.255.255.0
LOCAL-OFF-2(config-if)# ip helper-address 10.68.1.1
LOCAL-OFF-2(config-if)# duplex auto
LOCAL-OFF-2(config-if)# speed auto
LOCAL-OFF-2(config-if)#
LOCAL-OFF-2(config-if)#interface GigabitEthernet0/1
LOCAL-OFF-2(config-if)# description WAN connection to REMOTE-1 router
LOCAL-OFF-2(config-if)# ip address 192.168.200.1 255.255.255.252
LOCAL-OFF-2(config-if)# duplex auto
LOCAL-OFF-2(config-if)# speed auto
LOCAL-OFF-2(config-if)#
LOCAL-OFF-2(config-if)#interface Vlan1
LOCAL-OFF-2(config-if)# no ip address
LOCAL-OFF-2(config-if)# shutdown
LOCAL-OFF-2(config-if)#
LOCAL-OFF-2(config-if)#router eigrp 10
LOCAL-OFF-2(config-router)# network 10.0.0.0
LOCAL-OFF-2(config-router)# network 172.168.0.0
LOCAL-OFF-2(config-router)# network 192.168.200.0
LOCAL-OFF-2(config-router)#
LOCAL-OFF-2(config-router)#ip route 10.68.1.0 255.255.255.0 192.168.200.2
LOCAL-OFF-2(config)#ip route 192.168.100.0 255.255.255.252 192.168.200.2
LOCAL-OFF-2(config)#ip route 172.16.80.0 255.255.255.252 192.168.200.2
LOCAL-OFF-2(config)#
Show Run command LOCAL-OFF-2 router:
LOCAL-OFF-2>
LOCAL-OFF-2>enable
LOCAL-OFF-2#sh run
!
hostname LOCAL-OFF-2
!
interface GigabitEthernet0/0
description Connection to Local Office-2 VLAN-20
ip address 10.68.20.1 255.255.255.0
ip helper-address 10.68.1.1
duplex auto
speed auto
!
interface GigabitEthernet0/1
description WAN connection to REMOTE-1 router
ip address 192.168.200.1 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
network 172.168.0.0
network 192.168.200.0
!
ip classless
ip route 10.68.1.0 255.255.255.0 192.168.200.2
ip route 192.168.100.0 255.255.255.252 192.168.200.2
ip route 172.16.80.0 255.255.255.252 192.168.200.2
!
line con 0
!
line aux 0
LOCAL OFFICE-1 VLAN-10 IP leasing using IP Helper-Address:
LOCAL OFFICE-2 VLAN-20 IP leasing using IP Helper-Address:
Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: