cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1668
Views
0
Helpful
1
Comments
abhijit379
Level 1
Level 1

OSPF.gif

I am trying to simulate a OSPF LAB using GNS3. I am using a router as a frame relay switch. In the design I have Hub router and a spoke router.

Problem is that, when I am using "neighbour 192.168.1.11" command under the "router ospf 1" command, frame relay switch interface start fluctuating.

I am watching the process on the hub router using "ip ospf neighbour". As soon the dead timer expires, Frame relay switch both or a single interface goes down. I dont understand why the interface on frame relay switch interface goes up and down.

Any idea?

Here is the configuration

Spoke 1 Router
=========================
R3#show running-config
Building configuration...

Current configuration : 1109 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
bandwidth 128
no ip address
encapsulation frame-relay
keepalive 2
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.1 multipoint
bandwidth 128
ip address 192.168.1.11 255.255.255.0
frame-relay map ip 192.168.1.10 201 broadcast
no frame-relay inverse-arp
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
no ip http server
ip classless
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

Hub Router
===================

R1#show running-config
Building configuration...

Current configuration : 1108 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
bandwidth 128
no ip address
encapsulation frame-relay
keepalive 2
no frame-relay inverse-arp
!
interface Serial0/0.1 multipoint
bandwidth 128
ip address 192.168.1.10 255.255.255.0
frame-relay map ip 192.168.1.11 102 broadcast
no frame-relay inverse-arp
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.11
!
no ip http server
ip classless
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end


Frame Relay Switch
=========================

R2#show run
Building configuration...

Current configuration : 971 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
!
frame-relay switching
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
keepalive 2
clock rate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
encapsulation frame-relay
keepalive 2
clock rate 64000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
!
no ip http server
ip classless
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

==================================================================================

Message from Hub Router


===================================================================================

*Mar  1 00:16:07.487: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0.1 from EXSTART to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:16:08.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
R3#
*Mar  1 00:16:42.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3#
*Mar  1 00:18:55.487: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0.1 from EXSTART to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:18:56.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
R3#
*Mar  1 00:19:30.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3#
*Mar  1 00:21:45.487: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0.1 from EXSTART to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:21:46.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
R3#
*Mar  1 00:22:20.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3#
*Mar  1 00:24:35.487: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0.1 from EXSTART to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:24:36.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
R3#
*Mar  1 00:25:10.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
R3#
*Mar  1 00:27:27.487: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0.1 from EXSTART to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:27:28.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
R3#
*Mar  1 00:28:02.479: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

=======================================================================================

Message from frame relay switch

=======================================================================================

*Mar  1 00:18:54.579: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down
R2#
*Mar  1 00:19:30.579: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R2#
*Mar  1 00:21:44.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down
R2#
*Mar  1 00:22:22.495: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R2#
*Mar  1 00:24:34.623: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down
R2#
*Mar  1 00:25:10.675: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
R2#
*Mar  1 00:27:26.675: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down
R2#
*Mar  1 00:28:02.755: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

Comments
samavedula_rama
Level 1
Level 1

Strange if it happens only when unicast hellos are enabled. How about using

ip ospf network point-to-multipoint

on the interface? Does the same thing happen. I think there possibly could be a Layer2 issue. Can you do a

debug frame lmi and/or debug frame events

and let us know what you see?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: