cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
450
Views
0
Helpful
0
Comments
Meddane
VIP
VIP

Meddane_0-1676928518135.png

Basic configuration of all routers:

R1:

ipv uni

!

interface FastEthernet0/0

 ip address 192.168.123.1 255.255.255.0

 ipv6 address 123::1/64

 ipv6 ospf 1 area 123

 no shut

!

interface FastEthernet0/1

 ip address 12.12.12.1 255.255.255.0

 ipv6 address 12::1/64

 ipv6 ospf 1 area 0

 no shut

!

interface FastEthernet1/0

 ip address 192.168.13.1 255.255.255.0

 ipv6 address 13::1/64

 ipv6 ospf 1 area 0

 no shut

!

router ospf 1

 router-id 1.1.1.1

 area 123 nssa

 network 12.12.12.0 0.0.0.255 area 0

 network 192.168.13.0 0.0.0.255 area 0

 network 192.168.123.0 0.0.0.255 area 123

!

ipv6 router ospf 1

 router-id 11.11.11.11

 area 123 nssa

 

R2:

ipv uni

!

interface FastEthernet0/0

 ip address 192.168.123.2 255.255.255.0

 ipv6 address 123::2/64

 ipv6 ospf 1 area 123

 no shut

!

interface FastEthernet0/1

 ip address 12.12.12.2 255.255.255.0

 ipv6 address 12::2/64

 ipv6 ospf 1 area 0

 no shut

!

router ospf 1

 router-id 2.2.2.2

 area 123 nssa

 network 12.12.12.0 0.0.0.255 area 0

 network 192.168.123.0 0.0.0.255 area 123

!

ipv6 router ospf 1

 router-id 22.22.22.22

 area 123 nssa

 

R3:

ipv uni

!

interface Loopback0

 ipv6 address 3::3/64

!

interface Loopback1

 ip address 3.3.3.3 255.255.255.0

!

interface FastEthernet0/0

 ip address 192.168.123.3 255.255.255.0

 ipv6 address 123::3/64

 ipv6 ospf 1 area 123

 no shut

!

interface FastEthernet1/0

 ip address 192.168.13.3 255.255.255.0

 ipv6 address 13::3/64

 ipv6 ospf 1 area 0

 no shut

!

router ospf 1

 router-id 3.3.3.3

 area 123 nssa

 redistribute connected subnets route-map CONNECTED-IPV4

 network 192.168.13.0 0.0.0.255 area 0

 network 192.168.123.0 0.0.0.255 area 123

!

ipv6 router ospf 1

 router-id 33.33.33.33

 area 123 nssa

 redistribute connected route-map CONNECTED-IPV6

!

!

route-map CONNECTED-IPV4 permit 10

 match interface Loopback1

!

route-map CONNECTED-IPV6 permit 10

 match interface Loopback0

 

AREA 123 is configured as NSSA

R1 and R2 should inject two LSAs Type 7 Default-Route in NSSA with the following commands in OSPFv2 and OSPFv3:

 

R1(config-rtr)#area 123 nssa default-information-originate

R2(config-router)#area 123 nssa default-information-originate

R1(config-rtr)#area 123 nssa default-information-originate

R2(config-router)#area 123 nssa default-information-originate

 

R3 advertises its external prefixes 3::3/64 and 3.3.3.3/24 in OSPFv3 OSPFv2 respectively.

Case with OSPFv3:

R3 receives two LSAs Type 7 default route :: from R2(22.22.22.22) and R1 (11.11.11.11) without P Bit (not set) as shown by the line "Options:None" ,also R3 generates an LSA Type 7 for the external prefix 3::/64 and inject it in NSSA but with P-Bit set to 1 in order to tell the ABRs R1 and R2 to translate that an LSA Type 7 into an LSA Type 5 as shown by the line " Options: P " meaning that the P-Bit is set to 1 :

 

R3#show ipv ospf data nssa-external

            OSPFv3 Router with ID (33.33.33.33) (Process ID 1)

                Type-7 AS External Link States (Area 123)

  Routing Bit Set on this LSA

  LS age: 1596

  LS Type: AS External Link

  Link State ID: 0

  Advertising Router: 11.11.11.11

  LS Seq Number: 80000001

  Checksum: 0x36D3

  Length: 28

  Prefix Address: ::

  Prefix Length: 0, Options: None

  Metric Type: 2 (Larger than any link state path)

  Metric: 1

 

  Routing Bit Set on this LSA

  LS age: 1618

  LS Type: AS External Link

  Link State ID: 0

  Advertising Router: 22.22.22.22

  LS Seq Number: 80000001

  Checksum: 0xEAF2

  Length: 28

  Prefix Address: ::

  Prefix Length: 0, Options: None

  Metric Type: 2 (Larger than any link state path)

  Metric: 1

 

  LS age: 1638

  LS Type: AS External Link

  Link State ID: 1

  Advertising Router: 33.33.33.33

  LS Seq Number: 80000001

  Checksum: 0x3E0C

  Length: 36

  Prefix Address: 3::

  Prefix Length: 64, Options: P

  Metric Type: 2 (Larger than any link state path)

  Metric: 20

 

Notice R3 installs two Default-route (load-balancing) :

 

R3#show ipv route ::

ON2  ::/0 [110/1]

     via FE80::C201:1DFF:FE04:0, FastEthernet0/0

     via FE80::C200:1DFF:FE04:0, FastEthernet0/0

 

Case with OSPFv2:

 

R3 receives two LSAs Type 7 default route 0.0.0.0 from R2(2.2.2.2) and R1 (1.1.1.1) without P Bit (not set) as shown by the line "No Type 7/5 translation" in the option field ,also R3 generates an LSA Type 7 for the external subnet 3.3.3.0/24 and inject it in NSSA but with P-Bit set to 1 in order to tell the ABRs R1 and R2 to translate that LSA Type 7 into an LSA Type 5 as shown by the line " Type 7/5 translation " in the option field meaning that the P-Bit is set to 1:

 

R3#show ip ospf data nssa-external

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Type-7 AS External Link States (Area 123)

  Routing Bit Set on this LSA

  LS age: 1787

  Options: (No TOS-capability, No Type 7/5 translation, DC)

  LS Type: AS External Link

  Link State ID: 0.0.0.0 (External Network Number )

  Advertising Router: 1.1.1.1

  LS Seq Number: 80000001

  Checksum: 0xEEBE

  Length: 36

  Network Mask: /0

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 1

        Forward Address: 0.0.0.0

        External Route Tag: 0

 

  Routing Bit Set on this LSA

  LS age: 1808

  Options: (No TOS-capability, No Type 7/5 translation, DC)

  LS Type: AS External Link

  Link State ID: 0.0.0.0 (External Network Number )

  Advertising Router: 2.2.2.2

  LS Seq Number: 80000001

  Checksum: 0xD0D8

  Length: 36

  Network Mask: /0

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 1

        Forward Address: 0.0.0.0

        External Route Tag: 0

 

  LS age: 1825

  Options: (No TOS-capability, Type 7/5 translation, DC)

  LS Type: AS External Link

  Link State ID: 3.3.3.0 (External Network Number )

  Advertising Router: 3.3.3.3

  LS Seq Number: 80000001

  Checksum: 0x2C6D

  Length: 36

  Network Mask: /24

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 20

        Forward Address: 192.168.123.3

        External Route Tag: 0

 

Notice R3 installs two Default-route (load-balancing) :

 

R3#show ip route | s 0.0.0.0

Gateway of last resort is 192.168.123.2 to network 0.0.0.0

O*N2 0.0.0.0/0 [110/1] via 192.168.123.2, 00:09:36, FastEthernet0/0

               [110/1] via 192.168.123.1, 00:09:36, FastEthernet0/0

 

Now we will add a link between R1 and R3 (fa1/0--fa1/0)and configure this link in area 0 with both IPv6 address and an IPv4 address,as a result R3 will become also an ABR:

 

Meddane_1-1676928518138.png

 

 

 

R1(config-router)#int fa1/0

R1(config-if)#ipv6 address 13::1/64

R1(config-if)#ip address 192.168.13.1 255.255.255.0

R1(config-if)#ipv ospf 1 area 0

R1(config-if)#router ospf 1

R1(config-router)#network 192.168.13.0 0.0.0.255 area 0

 

R3(config)#int fa1/0

R3(config-if)#ipv6 address 13::3/64

R3(config-if)#ip address 192.168.13.3 255.255.255.0

R3(config-if)#ipv ospf 1 area 0

R3(config-if)#exi

R3(config)#router ospf 1

R3(config-router)#network 192.168.13.0 0.0.0.255 area 0

 

Case with OSPFv3:

 

R3#show ipv route ::

% Route not found

 

Case with OSPFv2:

 

R3#show ip route 0.0.0.0

% Network not in table

 

Notice that R3 loses its default route, in OSPFv3 and OSPFv2.

Notice that R3 still receives the LSA Type 7 default route in OSPFv3 and OSPFv2 as shown by the show ipv6 ospf data nssa-external and the show ip ospf data nssa-external commands respectively:

 

R3#show ipv6 ospf data nssa-external

            OSPFv3 Router with ID (33.33.33.33) (Process ID 1)

                Type-7 AS External Link States (Area 123)

  LS age: 1325

  LS Type: AS External Link

  Link State ID: 0

  Advertising Router: 11.11.11.11

  LS Seq Number: 80000002

  Checksum: 0x34D4

  Length: 28

  Prefix Address: ::

  Prefix Length: 0, Options: None

  Metric Type: 2 (Larger than any link state path)

  Metric: 1

 

  LS age: 1308

  LS Type: AS External Link

  Link State ID: 0

  Advertising Router: 22.22.22.22

  LS Seq Number: 80000002

  Checksum: 0xE8F3

  Length: 28

  Prefix Address: ::

  Prefix Length: 0, Options: None

  Metric Type: 2 (Larger than any link state path)

  Metric: 1

 

  ...Output omitted for brevity

 

R3#show ip ospf data nssa-external

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Type-7 AS External Link States (Area 123)

  LS age: 1326

  Options: (No TOS-capability, No Type 7/5 translation, DC)

  LS Type: AS External Link

  Link State ID: 0.0.0.0 (External Network Number )

  Advertising Router: 1.1.1.1

  LS Seq Number: 80000002

  Checksum: 0xECBF

  Length: 36

  Network Mask: /0

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 1

        Forward Address: 0.0.0.0

        External Route Tag: 0

 

  LS age: 1417

  Options: (No TOS-capability, No Type 7/5 translation, DC)

  LS Type: AS External Link

  Link State ID: 0.0.0.0 (External Network Number )

  Advertising Router: 2.2.2.2

  LS Seq Number: 80000002

  Checksum: 0xCED9

  Length: 36

  Network Mask: /0

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 1

        Forward Address: 0.0.0.0

        External Route Tag: 0

 

  ...Output omitted for brevity

 

R3 installs the two LSAs Type 7 default route advertised by R1 and R2 in the OSPF database, but it does not install the Default routes into the routing table ,because When an ABR receives an LSA Type 7 default route from another ABR ,it looks the P bit and find that it is not set ,then it does not install the default route because the loop prevention mechanism.Remember that the P-bit is only used in the LSA Type 7 to tell the ABRs to translate this LSA into an LSA Type 5,but this P bit is also used as a routing loop prevention mechanism. In this case since R3 is an ABR after adding the link Fa1/0--fa1/0(R1--R3), it does not accept the LSA Type 7 without P-bit, in order to avoid routing loops.

 

The RFC 1587 Section 3.4 "Originating Type-7 LSAs

A type-7 default route (network 0.0.0.0) may be originated into the

   NSSA by an NSSA area border router or by an NSSA AS boundary router

   which is internal to the NSSA.  The type-7 default route originated

   by the NSSA area border router must have the P-bit reset so that the

   default route originated by the NSSA area border router will not find

   its way out of the NSSA into the rest of the AS system via another

   NSSA area border router.  The type-7 default route originated by an

   NSSA AS boundary router which is not an NSSA area border router may

   have the P-bit set.  Type-7 routes which are originated by the NSSA

   area border router will not get added to other NSSA area border

   router's routing table.

 

 

RFC 3101 The OSPF Not-So-Stubby Area (NSSA) Option

Appendix F: A Type-7 default route with the P-bit clear will not be

         installed on an NSSA border router.  This protects the default

         routing of other OSPF Areas.  (See Appendix E.)

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: