Virtual Routing and Forwarding (VRF)
VRF is the abbreviation of Virtual Routing and Forwarding. Basically, VRF is a technology with which we can create separate virtual routers on a physical router.
With these separate virtual routers, we can use router interfaces, routing and forwarding tables isolated with VRFs. The network traffic in a VRF is not forwarded to another VRF. In other words, forwarding process is done only between the interfaces on the same VRF.
VRFs are an essential component of the MPLS L3VPN architecture and provide increased router functionality through segmentation in lieu of using multiple devices.
As you know, service providers give services to different networks. And these different networks use overlapping IP addressing inside their network. So, how a service provider manage this without a conflict?
Service providers uses VRF for multiple routing instances. By doing this, they connect customer locations without any conflict. From the point of customer view, their locations are connected to the ports of a router.



ISP CONFIGURATION
ip vrf cust-a
!
ip vrf cust-b
!
interface FastEthernet1/0
ip vrf forwarding cust-a
ip address 10.0.12.1 255.255.255.0
no shutdown
!
interface FastEthernet1/1
ip vrf forwarding cust-a
ip address 10.0.13.1 255.255.255.0
no shutdown
!
interface FastEthernet2/0
ip vrf forwarding cust-b
ip address 10.0.14.1 255.255.255.0
no shutdown
!
interface FastEthernet2/1
ip vrf forwarding cust-b
ip address 10.0.15.1 255.255.255.0
no shutdown
!
router ospf 1 vrf cust-a
network 10.0.12.0 0.0.0.255 area 0
network 10.0.13.0 0.0.0.255 area 0
!
router ospf 2 vrf cust-b
network 10.0.14.0 0.0.0.255 area 0
network 10.0.15.0 0.0.0.255 area 0
!


Thank you very much...!!
-------------------------------------------- The End -----------------------------------------------------