VRF LITE
VRF Lite is a simplified version of VRF that uses only IP routing, while the full version of VRF can support multiple routing protocols like OSPF and BGP.
VRFs are an essential component of the MPLS L3VPN architecture and provide increased router functionality through segmentation in lieu of using multiple devices.
Both VRF and VRF-lite are built on the same premise: have a separate routing table or tables (i.e. VRFs) created on your router and unique interfaces associated with them. Here, you have VRF-lite.
If you couple VRFs with a technology such as MPLS or LISP to communicate with other routers having similar VRFs while allowing to carry all traffic via a single interface and being able to tell the packets apart, you have a full VRF.
By default, all router interfaces, the routing table, and any forwarding tables are associated with the Global VRF. So, what you’ve been calling your routing table is actually the routing table of the Global VRF. If you need to divide your router up into multiple virtual routers, do so by creating additional VRFs which also create additional routing and forwarding tables.
So, Virtual Routing and Forwarding (VRF) Lite is a technology for creating separate virtual routers on a single physical router. Router interfaces, routing tables, and forwarding tables are isolated on a VRF by VRF basis and therefore prevent traffic from one VRF interfering with another VRF. Which means VRF lite allow us to create multiple virtual networks on top single physical network.
Refer to following Figure which shows a single physical topology that is divided into three different logically isolated networks. For simplicity sakes call them the RED, GREEN, and BLUE networks. The RED network is using the 10.0.0.0/16 addressing space, the GREEN network is using the 172.16.0.0/16 addressing space, and the BLUE network is using the 192.168.0.0/24 addressing space.
With VRF-Lite you can isolate the traffic within the respective virtual networks and have multiple virtual routing tables on each router dedicated to the respective VRF.

If you check global routing tables of R1, R2 and R3…you can see routing table is empty…

Configure Routing Protocol…like Eigrp
R1 configuration
R1(config)# router eigrp vrf-example
R1(config-router)# address-family ipv4 vrf RED autonomous-system 100
R1(config-router-af)# network 10.0.1.0 0.0.0.255
R1(config-router-af)# network 10.0.12.0 0.0.0.255
R1(config-router-af)#exit
R1(config-router)# address-family ipv4 vrf GREEN autonomous-system 100
R1(config-router-af)# network 172.16.1.0 0.0.0.255
R1(config-router-af)# network 172.16.12.0 0.0.0.255
R1(config-router-af)#exit
R1(config-router)# address-family ipv4 vrf BLUE autonomous-system 100
R1(config-router-af)# network 192.168.1.0 0.0.0.255
R1(config-router-af)# network 192.168.12.0 0.0.0.255
R1(config-router-af)#end
R2 Configuration
R2(config)# router eigrp vrf-example
R2(config-router)# address-family ipv4 vrf RED autonomous-system 100
R2(config-router-af)# network 10.0.12.0 0.0.0.255
R2(config-router-af)# network 10.0.23.0 0.0.0.255
R2(config-router-af)#exit
R2(config-router)# address-family ipv4 vrf GREEN autonomous-system 100
R2(config-router-af)# network 172.16.12.0 0.0.0.255
R2(config-router-af)# network 172.16.23.0 0.0.0.255
R2(config-router-af)#exit
R2(config-router)# address-family ipv4 vrf BLUE autonomous-system 100
R2(config-router-af)# network 192.168.12.0 0.0.0.255
R2(config-router-af)# network 192.168.23.0 0.0.0.255
R2(config-router-af)#end
R3 Configuration
R3(config)# router eigrp vrf-example
R3(config-router)# address-family ipv4 vrf RED autonomous-system 100
R3(config-router-af)# network 10.0.23.0 0.0.0.255
R3(config-router-af)# network 10.0.3.0 0.0.0.255
R3(config-router-af)#exit
R3(config-router)# address-family ipv4 vrf GREEN autonomous-system 100
R3(config-router-af)# network 172.16.23.0 0.0.0.255
R3(config-router-af)# network 172.16.3.0 0.0.0.255
R3(config-router-af)#exit
R3(config-router)# address-family ipv4 vrf BLUE autonomous-system 100
R3(config-router-af)# network 192.168.23.0 0.0.0.255
R3(config-router-af)# network 192.168.3.0 0.0.0.255
R3(config-router-af)#end


Thank you very much...!!
--------------------------------------------- The End -----------------------------------------------