cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
688
Views
0
Helpful
6
Replies

Getting Error trying to install Cisco Prime Optical 9.6

sking1024
Beginner
Beginner

Good Morning all,

 

I am having no luck trying to install CPO 9.6.  I am trying to install on a Red Hat LINUX 5 machine.  Install get to the pre-install checklist then fails on the oracle check, then exits the install.  Here is what the error log shows.

 

Oracle Pre Installation Checks: for Linux


Check Minimum value of RAM allowed to install Oracle

  Actual size value of RAM is 48304932 Kb that is sufficient to Install Oracle

Check the correct tmp size for Linux to install Oracle

  Actual tmp size is 238785284 Kb that is sufficient to install Oracle

Check the correct oracle base disk size for Linux to install Oracle

  Actual disk size for oracle base is 238785292 Kb that is sufficient to install Oracle

Check the correct OS version for Linux to install Oracle

  Actual OS Version for Linux is Red Hat Enterprise Linux Server release 5 that is correct

Check the correct OS patches for Linux to install Oracle

    Patch list to check: none


End of Oracle Pre Installation Checks for Linux

Oracle Pre Installation Checks: packages for Linux

The package  kernel-headers is not installed
The package  sysstat is not installed
The package  libaio-devel is not installed
CRITICAL: The package  gcc is essential
The package  gcc-c++ is not installed
The package  unixODBC-devel is not installed
The package  libstdc++-devel is not installed
The package  elfutils-libelf-devel is not installed
The package  unixODBC is not installed
The package  elfutils-libelf-devel-static is not installed
The package  glibc-headers is not installed


End Oracle Pre Installation check of packagesLinux

 

I have no idea what to do next, any help would be appreciated.

 

Thanks,

Steve

 

1 Accepted Solution

Accepted Solutions

Also disable selunix in red hat:

- vi /etc/selunix/config

- press 'i'

- change line 'selunix=enabled' to 'selunix=disabled'

- press 'esc' 'shift+:+w+q' 'Enter'

- 'init 6' - this is reboot

View solution in original post

6 Replies 6

kayukovvalera
Beginner
Beginner

- Insert dvd with red hat 5.2 in cdrom

- cd /media/

- execute 'ls' to see cd

- go to / (root directory)

- make directory with name 'dvd-rh' by executing command 'mkdir dvd-rh'

- mount cd by executing command 'mount -t iso9660 /dev/cdrom /dvd-rh'

- go to dir /etc/yum.repos.d/, command cd /etc/yum.repos.d/

- execute 'ls', it will show files like ****.repo, may be local.****.repo

- edit file, command 'vi local.****.repo'

- change mode to edit, press bottom 'i'

- add in file:

[dvd-rh]

name =rh-dvd

baseurl='file:///dvd-rh/'

gpgcheck=0

- exit vi editor, press 'esc' then 'shift+:+w+q+Enter'

- execute 'yum-config-manager --enable dvd-rh'

- install all not installed pakages like:

yum install kernel-headers

and so on

, Valery

Also disable selunix in red hat:

- vi /etc/selunix/config

- press 'i'

- change line 'selunix=enabled' to 'selunix=disabled'

- press 'esc' 'shift+:+w+q' 'Enter'

- 'init 6' - this is reboot

These instructions were adapted from
http://www.confignotes.com/2011/01/how-to-add-a-repository-manually-in-rhel6/

1. Log in as root.
2. Disable SELinux from the top menu bar at System | Administration | Security Level & Firewall
3. Attach the RHEL load DVD either from the DVD drive or by attaching the iso.
4. Open a terminal.
a. # mkdir /srv/RHEL5_8
b. # cp -rpf /media/RHEL_5.8\ x86_64\ DVD/Server/* /srv/RHEL5_8
  /* this takes a while.  be patient. */
c. # cp /media/RHEL_5.8\ x86_64\ DVD/RPM-GPG-KEY-redhat-release /srv

/* Remember to eject the DVD, otherwise the system will try to reload RHEL at the next reboot */

5. Create “/etc/yum.repos.d/RHEL_5_8.repo” with the following contents:
———————————————–
[baseOS]
name=Red Hat Enterprise Linux $releasever – $basearch baseOS
baseurl=file:///srv/RHEL5_8
gpgkey= file:///srv/RPM-GPG-KEY-redhat-release
enabled=1
gpgcheck=1

[ScalableFileSystem]
name=Red Hat Enterprise Linux $releasever – $basearch ScalableFileSystem
baseurl=file:///srv/RHEL5_8
gpgkey= file:///srv/RPM-GPG-KEY-redhat-release
enabled=1
gpgcheck=1

 [Workstation]
name=Red Hat Enterprise Linux $releasever – $basearch Workstation
baseurl=file:///srv/RHEL5_8
gpgkey= file:///srv/RPM-GPG-KEY-redhat-release
enabled=1
gpgcheck=1

———————————————–

6. Verify it works
a. # yum update
b. should be no errors

7. Update RHEL where <package name> is the name of the desired package.
a. # yum install <package name>

Before CPO can be installed, RHEL must have several packages added.  See separate instructions for creating a local update repository on RHEL, then install the packages below.
+ kernel-headers
+ sysstat
+ libaio-devel
+ gcc-c++
- glibc-headers
- libstdc++-develk
+ unixODBC-devel
- unixODBC
+ elfutils-libelf-devel-static
- elfutils-libelf-devel

sking1024
Beginner
Beginner

Thanks to Cliff and Valery,

 

OK, that worked, install now completes.  However, I can't get a login screen from any remote location. I get the login errors in the attached files. I can log in to SysAdmin using Hyper-V Manager on the Reed Hat server. I know it is some type of security issue, but i just can't figure it out.  I do have the Firewall turned off and selinux disabled. I can provide files as needed, but there is no outside access allowed. it is a closed Gov't system.  Any help would be great.

 

Thanks again,

Steve.

Got a Call From Cliff McCullough. he is local, turns out I had a Missing DNS entry on my Active Directory list.

 

Thanks Cliff.

 

 

Helpfull:

pre-installation requirements for hostname:

  • Do not use Upper Letter for hostname
  • Do not use Upper Letter for hostname in configuration file /etc/hosts
  • Insert hostname of ODG interface in configuration file /etc/hosts (HA installation only)
  • Insert hostname of Red Hat Cluster Heartbeat interface in configuration file /etc/hosts (HA installation only)
  • Check your DNS server response, it MUST response hostname with lover letters only.
  • If you haven't got local DNS use etc local file

 

If you will use Upper Letters will never authenticate in brouser. This is documentation bug, in future Cisco will inprove it.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers