cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1796
Views
0
Helpful
11
Replies
Highlighted
Beginner

Go to (URL) not working in Play in future

Hi,

I've deployed content to DMP(4310) via DMM but I am unable to schedule a go to (URL).  This command works fine if I  use the Play Now or Run Task. 

I've followed the advice on the thread here:

https://supportforums.cisco.com/thread/2147803

but haven't had any success in solving this issue.

Thanks

Shannon

11 REPLIES 11
Highlighted
Beginner

Shannon,

Please attach the screenshot from the "Emergencies" tab under your Digital Signs Modules.

Thanks,

Sagar

Highlighted

Hi Sagar,

I've taken a screen shot of the tab.  I haven't used this section yet as I'm still learning the system.

thanks

Shannon

Highlighted

Shannon,

Can you give me more details about the issue : -

1) Do all the "Play in Future" task fail (Digital Signage, Advanced Task etc) or only "Goto URL" (Advanced task) fail ?

2) Have you checked the "Date and Time" on the DMM server - May be the timezone set on the DMM server is not the same as the local timezone.

3) Can you copy-paste here the Goto URL you are trying to send to the DMP ?

4) What is the code version on the DMM and DMP ?

5) Does this happen on all the DMPs are few DMPs ?

Thanks,

Sagar

Highlighted

Hi Sagar,

1) Do all the "Play in Future" task fail (Digital Signage, Advanced Task etc) or only "Goto URL" (Advanced task) fail ?

     It only seems like the Goto URL task fails - Advanced (Video/Audio, System ect) seem to be working OK.  I haven't checked other digital signage tasks yet. 

2) Have you checked the "Date and Time" on the DMM server - May be the timezone set on the DMM server is not the same as the local timezone.

     The time stamp on the DMM reflects the local time as shown in the Play in Future tab

3) Can you copy-paste here the Goto URL you are trying to send to the DMP ?

     file:///tmp/ftproot/usb_1/deployment/xTAS-core/api/xml/app/playlist/http_pull_231_start_playlist_219_.htm

     this is not quite the same as what is appearing in the DMP Startup Flash --> Data_Url=file:///tmp/ftproot/usb_1/deployment/xTAS-core/api/xml/app/playlist/http_pull_231_start_playlist_xml_219_.

4) What is the code version on the DMM and DMP ?

DMM: 5.2.2

DMP: 5.2.2.3

5) Does this happen on all the DMPs are few DMPs ?

I'm currently testing the system on 2 DMP.  Currently 52 DMP in deployment  at this location all are 4310 and running code version 5.2.2.3

Highlighted

Hi Shannon,

Have you tried re-deploying the package under consideration ?

If not, please re-deploy, check the deployment status, verify if the package is successfully deployed. Then do a scheduled "Play in Future" event.

Also are the DMP under test showing as green in the DMM ?

Thanks,

Sagar Dhanrale

Highlighted

Hi Sagar,

I've created a new deployment package and have deployed the playlist successfully to the 2 DMPs being used for testing.

Firstly I deployed a different playlist to ensure the content was being deleted from the DMP and then deployed the new deployement package via the Play in Future screen. Content was successfully deployed as i can see it an play playlist items via FTP login to the DMP.

I've since used the play in future command for Goto URL command with a Start time 9:59am and Finish time of 10:00am which did not display playlist on the screen.  Subsequently tried a start time of 10.05am and Finish time of 10:10am and had success.

I don't understand why this has suddently started working - I havent been doing anything differently since before I contacted this forum.

I am now testing the 1 minute command time again...

This now operates but the content stopped after about 1 minute or so. 

Does the goto URL command need to show in the play in future timeline for the lenght that the go to URL content needs to be shown?

i.e. I want to run the playlist from 9am - 5pm does this correspond to a Play in Future go to URL command start time of 9am and a Stop time of 5pm?

Oh and the DMP have always shown as green in the DMM.

Thanks

Shannon

Highlighted

I'm seeing the same thing. I'd like to reboot our DMPs about twice a week to ensure optium performance and no random memory issues. But, to do that and have the least amount of downtime, I scheduled a Go to URL event in the Play in Future area and it only lasts as long as that event is scheduled.

I tested this buy sending the URL and then stoping that event 1 minute later. The content displayed for only one minute and when I logged into the DMP, the default browser URL was blank.

I'd like to know if there's a work around for this or if all events have to stretch over the entire timeline.

MJ

Highlighted

For rebooting, try setting up your "Play in Future" event in the DMM as an advanced task. Select system task then reboot. That will reboot the DMP.

Highlighted

No issues on the reboot at all...got that working fine. The problem is resubmitting the content once the reboot has completed - the event has to span the entire day. Not a huge deal but a bit wierd to have it run the entire time - in my mind, it makes more sense to just submit the command to the DMP and, unless there's a new command, it should carry out that previous command. Or at least make it optional....

Highlighted

Oh, yeah, it's kinda strange to have to run the event the whole time, but I don't think there is any other way, unless you use the DMD. In that case, when rebooting, the content will not need to be pushed again. If you have a source Web page, you can always put that in a presentation template, and not have to bother with the whole timeline thing except for your reboot event.

Highlighted

Good tip...I might just try that.

Thanks,

MJ

Content for Community-Ad