cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
672
Views
0
Helpful
0
Replies
Highlighted
Beginner

Errors at POAP deployment

Hello,

i am trying to configure my n9kv with POAP but after some time i see this one:

2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %USER-1-SYSTEM_MSG: S/N[9ELHDHZ9H4R]-MAC[00:0C:29:6F:E3:27] - Exception: <type 'exceptions.TypeError'> [priority,] message string - script.sh
2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %USER-1-SYSTEM_MSG: S/N[9ELHDHZ9H4R]-MAC[00:0C:29:6F:E3:27] - Stack - File: script.sh Line: 1782 - script.sh
2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %USER-1-SYSTEM_MSG: S/N[9ELHDHZ9H4R]-MAC[00:0C:29:6F:E3:27] - Stack - File: script.sh Line: 1745 - script.sh
2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %USER-1-SYSTEM_MSG: S/N[9ELHDHZ9H4R]-MAC[00:0C:29:6F:E3:27] - Stack - File: script.sh Line: 994 - script.sh
2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %USER-1-SYSTEM_MSG: S/N[9ELHDHZ9H4R]-MAC[00:0C:29:6F:E3:27] - Stack - File: script.sh Line: 778 - script.sh
2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %USER-1-SYSTEM_MSG: S/N[9ELHDHZ9H4R]-MAC[00:0C:29:6F:E3:27] - Stack - File: script.sh Line: 418 - script.sh
2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %USER-1-SYSTEM_MSG: S/N[9ELHDHZ9H4R]-MAC[00:0C:29:6F:E3:27] - Cleanup all files - script.sh
2018 Jan 23 01:42:48 switch %$ VDC-1 %$ %POAP-2-POAP_FAILURE: [9ELHDHZ9H4R-00:0C:29:6F:E3:2E] - POAP Script execution failed

in this case i use default poap.py script from here - https://github.com/datacenter/nexus9000/blob/master/nx-os/poap/poap.py with my  credentials:

options = {
   "username": "bob",
   "password": "cisco",
   "hostname": "192.168.120.3",
   "transfer_protocol": "scp",
   "mode": "serial_number",
   "target_system_image": "nxos.7.0.3.I5.2.bin",
}

one more thing - i have made md5 like here - https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/7-x/fundamentals/configuration/guide/b_Cisco_Nexus_9000_Series_NX-OS_Fundamentals_Configuration_Guide_7x/b_Cisco_Nexus_9000_Series_NX-OS_Fundamentals_Configuration_Guide_7x_chapte...

and my configurations is:

switchname SW1

nv overlay evpn
feature ospf
feature bgp
feature pim
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature vpc
feature lldp
feature bfd
clock timezone MOS 3 0
feature nv overlay

username admin password cisco  role network-admin
interface Ethernet1/1
  description Server 
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 2279-2299,2379-2399
  no shutdown

interface Ethernet1/2
  description Server 
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 2279-2299,2379-2399
  no shutdown



interface mgmt0
  vrf member management
  ip address 192.168.120.130/24

Very basic config.

So please if you have any ideas - let me know.

thank you!

 

P.S. I use NX-OS-9000v nxosv-final.7.0.3.I6.1 version.

 

0 REPLIES 0