04-07-2006 11:55 AM - edited 03-03-2019 02:43 AM
I have some 1841 routers in a network, each has a 2 port E1 WAN module and a 4 port Ethernet Switch module. If I create VLANs on the switch module - what do I do for a trunk port. I want my VLAns to go out on the WAN port to another router. Can the E1 WAN port be a trunk port between 2 routers that have switching modules in them. I have read the config guide but it doent help
many thanks
Bob
04-07-2006 04:06 PM
Hi Bob,
Are you running frame-relay on that WAN link ? If so, one option you could have is to bridge each VLAN over a separate DLCI on that WAN link.
The following link describes how you can bridge using IOS:
http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hbrn_c/part05/ch05/index.htm
Pls do remember to rate posts.
Paresh
04-07-2006 11:38 PM
Its a real E1 transmission link. The switch module book shows how to set up the VLAns but doesnt indicate how the router will then process them, and which port can be the trunk.
04-08-2006 12:43 AM
You could try something like the following:
router 1
--------
bridge irb
!
int fast0/0
switchport access vlan 10
!
int fast0/1
switchport access vlan 20
!
int fast0/2
switchport access vlan 30
!
interface vlan10
ip address ....
bridge-group 10
!
interface vlan20
ip address ....
bridge-group 20
!
interface vlan30
ip address ....
bridge-group 30
!
interface serial1/0
encapsulation frame-relay
frame-relay intf-type dce
frame-relay lmi-type q933a
!
interface serial1/0.16 point-to-point
frame-relay interface-dlci 16
bridge-group 10
!
interface serial1/0.17 point-to-point
frame-relay interface-dlci 17
bridge-group 20
!
interface serial1/0.18 point-to-point
frame-relay interface-dlci 18
bridge-group 30
!
bridge 10 protocol ieee
bridge 10 route ip
!
bridge 20 protocol ieee
bridge 20 route ip
!
bridge 30 protocol ieee
bridge 30 route ip
router 2
--------
bridge irb
!
int fast0/0
switchport access vlan 10
!
int fast0/1
switchport access vlan 20
!
int fast0/2
switchport access vlan 30
!
interface vlan10
ip address ....
bridge-group 10
!
interface vlan20
ip address ....
bridge-group 20
!
interface vlan30
ip address ....
bridge-group 30
!
interface serial1/0
encapsulation frame-relay
!
interface serial1/0.16 point-to-point
frame-relay interface-dlci 16
bridge-group 10
!
interface serial1/0.17 point-to-point
frame-relay interface-dlci 17
bridge-group 20
!
interface serial1/0.18 point-to-point
frame-relay interface-dlci 18
bridge-group 30
!
bridge 10 protocol ieee
bridge 10 route ip
!
bridge 20 protocol ieee
bridge 20 route ip
!
bridge 30 protocol ieee
bridge 30 route ip
Explanation:
- interfaces Fast0/0, 0/1 and 0/2 are placed in VLANS 10, 20 and 30 respectively.
- each of those VLANs has an SVI interface (i.e. interface vlan) created on each router
- VLAN 10 is bridged over the WAN link using DLCI 16
- VLAN 20 is bridged over the WAN link using DLCI 17
- VLAN 30 is bridged over the WAN link using DLCI 18
Pls do remember to rate the posts ...
Paresh
04-08-2006 04:14 AM
Many thanks - this is looking very close to what I need. Each of the Switchport module ports needs to have an Ip address, and I need to get these networks to the second router over the E1 WAN link. What I do not see in the manual, is how the VLans are trunked - and to which Router port
thanks
Bob
04-08-2006 04:18 AM
Bob,
The E1 interface is effectively acting as an ethernet trunk to the other router. Is that what you question was ?
Pls do rate the posts to show your appreciation for people who take the time to help you solve your issues.
Paresh
04-08-2006 04:31 AM
Yes - I'm not sure if I need the bridge port. What I'm trying to do is route the different VLAns on each of the 4 switchport modules, via the E1 WAN link.Normally on a switch I would have to have a trunk port, but this is a routerwith a switch built in, so I'm not sure if the same rules apply. Do I still need the bridge setup you described.
Many thanks - I will rate all posts, I did not mean to show any lack of appreciation
Bob
04-08-2006 04:50 AM
Oh ok, so you mean that you want to configure each of the FasEthernet ports as a trunk, do you ? If so, you should be able to configure them as trunks as you would do on a 'real' switch. Have I understood you correctly ? Is it these FastEth ports you want to configure as a trunk ?
You certainly do need the bridge setup since there is no other way of passing Ethernet traffic over an E1 link...
Re: rating - that was not directed at you specifically. I am a frequent poster and I tend to put in requests for people to rate posts since there are a lot of people out there who benefit from our replies but don't bother to go back and rate the posts. In any case, thanks for rating :-)
Paresh
04-08-2006 06:06 AM
I'm explaining myself badly. I have an 1841 which has an E1 WAN module, a 4 port Fast Ethernet switch module, and 2 built in Fast Ethernet ports. The WAN port is connected to another router over an E1 link. I want to put equipment on each of the Ethernet ports, each with an IP address (so thats 6 ports in total). There is a server attached to the second router which has to be able to access each of the 6 IP addresses.
Now I can handle the 2 built in Ethernet ports, but its the 4 ports on the Switch module that are confusing me as I can only give them IP addesses if each port is in a VLAN - but how do I make them visible to the upstream router.Do I make the WAN port on the router a trunk link for the switch ports. The manula is not much help
Hope that has explained it better. I really appreciate your input
regards
Bob
04-08-2006 02:35 PM
Ok, Bob. Now that's made things a lot clearer !
There are two options, the solution of each of which depends on your exact requirements. The two possiblities that I see are:
1. The 6 devices you have at your first site are all part of the same IP network, 192.168.1.0/24 e.g. 192.168.1.1, 192.168.1.2, 192.168.1.3 and so on till 192.168.1.6.
Secondly, the server at the other site is on a different network e.g 192.168.10.1
2. All your devices including your server, are on the same network: 192.168.1.0/24 e.g. 192.168.1.1, 192.168.1.2, 192.168.1.3 and so on till 192.168.1.7 (server's IP)
From your posts, it appears that you are familiar with LAN switching but not routing, but I could be wrong on this. The better solution here is to use routing so that the "trunk", as you call it, is a routed trunk, not a switched trunk. Given that, I would say that option 1 from above is better suited to your environment.
Let me know whuch way you wanna go and I can help you with the config...
Paresh
04-09-2006 02:01 AM
Hi Paresh,
The scenario (designed by someone else) is more likely to have a different network at the server end, and this will expanded with more router combinations - I just have to get it to work !! So I would be grateful for some tips on how to get the VLAns trunked. Its the combination of a switch within a router that is confusing me - I could cope with all routers or all switches. Thanks for your help
regards
Bob
04-09-2006 02:07 AM
Hey Bob,
Yeah, ths switch within a router is not such an easy concept to grasp !
What about your requirements at the client end ? Do all of the devices plugging into the 1841 need to be on the same network as each other ?
Better still, give me an example with IP addresses, VLAN numbers etc so we can out a bit more context around it and come up with a sample config...
Paresh.
04-09-2006 02:21 AM
I'm expecting each client port to be on a different network, to allow for expansion (as there will be multiple clients on each port)So for example if I put the first port on the switch module in VLAN 10, in network 192.168.1.0, and the second port in VLAN 20, with Ip address 192.168.2.0, I have the routers running EIGRP, and they can see each other. Its the bit concerning getting the VLANs to the WAN port and visible to the second router that is confusing me
regards
Bob
04-09-2006 02:37 AM
Alright, that makes it a lot clearer, Bob.
Let us say we have the following networks at the site with the 1841:
192.168.1.0/24 - Fast1/0 - Switch port 0 - VLAN 10
192.168.2.0/24 - Fast1/1 - Switch port 1 - VLAN 20
192.168.3.0/24 - Fast1/2 - Switch port 2 - VLAN 30
192.168.4.0/24 - Fast1/3 - Switch port 3 - VLAN 40
192.168.10.0/24 - Fast0/0 - Built-in port
192.168.11.0/24 - Fast0/1 - Built-in port
Also, let us say you configure the E1 for PPP with the 192.168.250.0/24 network
The config you could use would then look like this:
vlan database
vlan 10
vlan 20
vlan 30
vlan 40
!
interface fast0/0
ip address 192.168.10.1 255.255.255.0
!
interface fast0/1
ip address 192.168.11.1 255.255.255.0
!
interface fast1/0
switchport access vlan 10
!
interface fast1/1
switchport access vlan 20
!
interface fast1/2
switchport access vlan 30
!
interface fast1/3
switchport access vlan 40
!
interface vlan 10
ip address 192.168.1.1 255.255.255.0
!
interface vlan 20
ip address 192.168.2.1 255.255.255.0
!
interface vlan 30
ip address 192.168.3.1 255.255.255.0
!
interface vlan 40
ip address 192.168.4.1 255.255.255.0
!
interface serial2/0:1
ip address 192.168.250.1 255.255.255.0
encapsulation ppp
!
router eigrp 10
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255
network 192.168.3.0 0.0.0.255
network 192.168.4.0 0.0.0.255
network 192.168.10.0 0.0.0.255
network 192.168.11.0 0.0.0.255
network 192.168.250.0 0.0.0.255
The 'interface vlan' interfaces are switched virtual interfaces that you can use to provide inter-vlan routing. Since we run EIGRP over all these interfaces, it will announce all of these networks to the router at the other end. That is how you will get connectivity between the server and the clients at this site. You could plug in a hub or a switch into each of the switch ports on the router and give the devices addresses out of the appropriate range for that port.
Hopefully that is starting to get a bit clearer....
Pls do remember to rate the posts....
Paresh
04-09-2006 02:51 AM
So I dont actually need to "trunk" the VLans at all
I assumed I did because of the 4 port switch within the router
thats brilliant thanks
Bob
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide