cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
340
Views
0
Helpful
1
Replies

Analogue dilaup - wrong modem lines answers

a-larkins
Level 1
Level 1

Hi all,

I am battling with a RAS issue here. We have a PRI with 30 digital modems in a cisco 3620 chassis. This is used for a business application that does a RAW telnet dialup and the config automatically telnets to a server on a given port number. We have this working 100%.

The issue comes in now with the client wanting to add normal dialup for support staff as well. ISDN dialup is a breeze and works great. What we have seen with the analogue dialup is that any modem randomly answers the incoming call and based on this, the dialup does not go to the correct line and further get the correct config. I have separated the lines in the config to have 5 lines for support analogue dialup and 25 for the business app - still no luck.

I know my configs are correct as I have analogue dialup with the same hardware working elsewhere.

Is there a way to force a specific range of modems to answer when a certain ISDN number is dialled?? What I am thinking is that the service provider do some config where there can be a specific number (other than the normal trigger number) for the analogue users. From my search on CCO the closest I can come to is something called "modem pooling"> There is a big note there that says "not supported on the 3600 platform".

When you dial the trigger number, the channel that answers is entirely random and hands over to a random modem. This is the issue.

I have pasted the working config below followed by the NOT working line commands for dialup.

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname <unknown>

!

logging buffered 4096 debugging

!

username <blank> password xxxxxxxxxxxx

modem country mica south-africa

ip subnet-zero

!

!

no ip domain-lookup

ip domain-name <whatever>

ip name-server <whatever+1>

!

async-bootp dns-server x.x.x.x

isdn switch-type primary-net5

chat-script AT TIMEOUT 30 OK atdt\T TIMEOUT 30 CONNECT \C !

!

controller E1 1/0

pri-group timeslots 1-31

description Link for Async Clients

!

controller E1 1/1

!

!

!

interface FastEthernet1/0

ip address x.x.x.x

duplex auto

speed auto

!

interface Serial1/0:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

ppp auth chap pap ms-chap

!

interface Group-Async1

no ip address

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer pool-member 1

async mode interactive

peer default ip address pool local

ppp authentication chap pap

group-range 1 30

!

interface Dialer1

ip unnumbered FastEthernet1/0

encapsulation ppp

dialer pool 1

dialer remote-name <blank>

dialer-group 1

peer default ip address pool local

ppp authentication chap pap

ppp multilink

!

interface Dialer3

ip unnumbered FastEthernet1/0

encapsulation ppp

dialer pool 1

dialer remote-name <blank>

dialer-group 1

peer default ip address pool local

ppp authentication chap pap

ppp multilink

!

ip local pool local x.x.x.x y.y.y.y

ip default-gateway x.x.x.x

ip classless

ip route 0.0.0.0 0.0.0.0 x.x.x.x

ip http server

ip pim bidir-enable

!

access-list 100 deny eigrp any any

access-list 100 deny ip any host 224.0.0.10

access-list 100 deny udp any any eq snmp

access-list 100 permit ip any any

dialer-list 1 protocol ip list 100

!

line con 0

exec-timeout 0 0

password 7 094D

logging synchronous

login

line 1 30

no motd-banner

no exec-banner

exec-timeout 0 0

flush-at-activation

no vacant-message

modem InOut

modem autoconfigure discovery

autocommand telnet 192.168..x.x 5000 /quiet /stream

transport input all

autoselect during-login

autoselect ppp

flowcontrol hardware

line aux 0

line vty 0 4

exec-timeout 20 0

password 7 0112

logging synchronous

login

!

NOT working line commands:

interface Group-Async1

no ip address

encapsulation slip

no ip mroute-cache

async mode interactive

no peer default ip address

group-range 6 30

!

interface Group-Async2

ip unnumbered FastEthernet1/0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer pool-member 1

async mode interactive

peer default ip address pool local

ppp authentication chap pap ms-chap

group-range 1 5

line 1 5

exec-timeout 0 0

flush-at-activation

modem InOut

modem autoconfigure discovery

transport input all

autoselect during-login

autoselect ppp

flowcontrol hardware

line 6 30

no motd-banner

no exec-banner

exec-timeout 0 0

flush-at-activation

no vacant-message

modem InOut

modem autoconfigure discovery

autocommand telnet x.x.x.x 5000 /quiet /stream

transport input all

flowcontrol hardware

1 Reply 1

rjackson
Level 5
Level 5

I'm doing with modem pooling. I ahve 48 modems and two PRIs (US). The modem pools select a range of modems based on called number.

!

modem-pool credit

pool-range 25-48

called-number 8378 max-conn 24

!

modem-pool ras

pool-range 1-24

called-number 7907 max-conn 24

called-number rsvp-sync max-conn 24