cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
409
Views
0
Helpful
1
Replies

Cat 3560 and QoS

rrfield
Level 1
Level 1

I have a handfull of Cat 3560 switches in wireclosets and I would like to

implement some basic QoS for limited VoIP (it's an add-on to an older PBX we

have, not a full blown implementation) and some video conferencing

equipment. Basically, I want to mark VoIP traffic to DSCP 46, video to DSCP

34, normal data traffic to DSCP 0 and "scavenger" traffic to DSCP 8. That

part is pretty straight foward. It's the queuing I'm not 100% on. Take a

look, all suggestions are welcome.

version 12.1

!

mls qos map policed-dscp 0 34 46 to 8

mls qos map cos-dscp 0 18 16 24 32 46 48 56

mls qos srr-queue output cos-map queue 2 threshold 1 4

mls qos srr-queue output cos-map queue 3 threshold 1 0 6 7

mls qos srr-queue output cos-map queue 4 threshold 1 1

mls qos srr-queue output dscp-map queue 2 threshold 1 34

mls qos srr-queue output dscp-map queue 3 threshold 1 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos

!

class-map match-all VIDEO

match access-group name VIDEO

class-map match-all VOICE

match access-group name VOICE

!

!

policy-map VOICE-VIDEO-PC-SCAV

class VOICE

set ip dscp 46

police 128000 8000 exceed-action drop

class VIDEO

set ip dscp 34

police 5000000 8000 exceed-action policed-dscp-transmit

class class-default

set ip dscp 0

police 5000000 8000 exceed-action policed-dscp-transmit

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

srr-queue bandwidth share 1 60 40 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mdix auto

spanning-tree portfast

!

...

!

interface FastEthernet0/24

no ip address

srr-queue bandwidth share 1 60 40 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mdix auto

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

srr-queue bandwidth share 1 60 40 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust dscp

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

srr-queue bandwidth share 1 60 40 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust dscp

!

ip access-list extended VIDEO

permit <video traffic>

ip access-list extended VOICE

permit <voice traffic>

!

1 Reply 1

beth-martin
Level 5
Level 5

This below chapter describes how to configure quality of service (QoS) by using automatic QoS (auto-QoS) commands or by using standard QoS commands. With QoS, you can give preferential treatment to certain traffic at the expense of others. Without QoS, the Catalyst 3550 switch offers best-effort service to each packet, regardless of the packet contents or size. It sends the packets without any assurance of reliability, delay bounds, or throughput.

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a008014f36e.html

Review Cisco Networking for a $25 gift card