cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
428
Views
0
Helpful
2
Replies

Complicated Config? PRI-to-BRI and DialOut/EZ

tscarola
Level 1
Level 1

Hello. I have a customer that has a Cisco 3620 with T1/ISDN PRI module and 24 digital modem module at the main site. The customer needs to a) connect outbound from the main site to two remote Cisco 802r ISDN BRI routers (sometimes simultaneously), and b) connect from servers on the main site LAN via DialOut EZ software (modem sharing) to up to eight (8) remote-site PCs. The customer has one PRI ISDN circuit installed at the main site. The remote sites will not be dialing the main site, only the reverse (main site to remote). There is no dial-up requirement to the main site. I have not been able to find similar configurations, however have developed my own using Dialer Profiles. This config is not known to work. If anyone has anything similar, or would be willing to review my work, I would really appreciate it.

Thank you,

Tony

*~*~*

!

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname AccessSvr

!

aaa new-model

aaa authentication login default local

aaa authentication login NO_AUTHEN none

aaa authentication ppp default local

aaa authorization network default local

!

logging rate-limit console 10 except errors

enable secret 5 <deleted>

enable password <deleted>

!

username remoteisdn1 password 7 <deleted>

username remoteisdn2 password 7 <deleted>

username admin password 7 <deleted>

!

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

!

isdn switch-type primary-5ess

!

!

controller T1 1/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

!

interface FastEthernet1/0

ip address 10.10.10.1 255.255.255.0

speed auto

full-duplex

!

!

interface Serial1/0:23

no ip address

encapsulation ppp

dialer pool-member 10 max-link 2

dialer pool-member 20 max-link 2

isdn switch-type primary-5ess

isdn bchan-number-order ascending (or descending - contact telco)

no cdp enable

ppp authentication chap

ppp multilink

!

!

interface Dialer1

description For Dialout Client - REMOTEISDN1

ip unnumbered FastEthernet1/0

encapsulation ppp

dialer pool 10

dialer remote-name remoteisdn1

dialer idle-timeout 900

dialer string 0000000 class 56k

dialer load-threshold 1 outbound

dialer-group 1

ppp authentication chap

ppp multilink

!

!

interface Dialer2

description For Dialout Client - REMOTEISDN2

ip unnumbered FastEthernet1/0

encapsulation ppp

dialer pool 20

dialer remote-name remoteisdn2

dialer idle-timeout 900

dialer string 1111111 class 56k

dialer load-threshold 1 outbound

dialer-group 2

ppp authentication chap

ppp multilink

!

router eigrp 1

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.2

ip route y.y.y.y 255.255.255.0 Dialer1

ip route z.z.z.z 255.255.255.0 Dialer2

!

no ip http server

!

map-class dialer 56k

dialer isdn speed 56

!

access-list 101 remark Interesting traffic definition for link remoteisdn1

access-list 101 deny eigrp any any (example)

access-list 101 deny udp any any eq ntp (example)

access-list 101 permit ip any any

!

access-list 102 remark Interesting traffic definition for link remoteisdn1

access-list 102 deny eigrp any any (example)

access-list 102 deny udp any any eq ntp (example)

access-list 102 permit ip any any

!

dialer-list 1 protocol ip list 101

no dialer-list 1 protocol ipx permit

dialer-list 2 protocol ip list 102

no dialer-list 2 protocol ipx permit

!

line con 0

exec-timeout 0 0

login authentication NO_AUTHEN

line 1 8

modem dtr-active

transport input telnet

escape-character NONE

modem autoconfigure type mica

rotary 1

line aux 0

line vty 0 4

!

2 Replies 2

john.gudmann
Level 1
Level 1

Hi,

It looks fine.

We are use sing a cisco 3660 for ISDN/PSTN/Frame-Relay connection. The Dial (Dial Out and In) part looks like this. version 12.1

no parser cache

service single-slot-reload-enable

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

no service dhcp

clock timezone GMT+1 1

clock summer-time GMT+2 recurring last Sun Mar 2:00 last Sun Oct 3:00

modem country mica denmark

ip subnet-zero

!

!

no ip finger

no ip domain-lookup

!

no ip dhcp-client network-discovery

no mgcp timer receive-rtcp

isdn switch-type primary-net5

isdn voice-call-failure 0

call rsvp-sync

!

!

fax interface-type modem

mta receive maximum-recipients 0

!

!

controller E1 2/0

pri-group timeslots 1-31

!

controller E1 2/1

pri-group timeslots 1-31

!

!

interface FastEthernet0/0

ip address 10.254.0.1 255.255.255.0

speed 100

full-duplex

no mop enabled

!

interface Serial2/0:15

no ip address

encapsulation ppp

no logging event link-status

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

compress stac

no cdp enable

!

interface Serial2/1:15

no ip address

encapsulation ppp

no logging event link-status

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

compress stac

no cdp enable

!

interface Group-Async1

ip unnumbered Loopback1

encapsulation ppp

ip tcp header-compression

no ip mroute-cache

no logging event link-status

dialer in-band

dialer idle-timeout 3600

dialer-group 1

async default routing

async dynamic address

async mode dedicated

peer default ip address pool PSTN

ppp callback accept

ppp authentication chap pap

group-range 97 108

!

interface Dialer1

description *** ISDN Dial-In Stjerne nr: xxxxxx ***

ip address 10.10.0.1 255.255.0.0

encapsulation ppp

no ip mroute-cache

no logging event link-status

dialer in-band

dialer fast-idle 10

dialer enable-timeout 2

dialer map ip 10.10.10.1 name host1 12345677

dialer map ip 10.10.20.1 name host2 98765432

dialer hold-queue 100

dialer-group 1

no snmp trap link-status

no peer default ip address

no fair-queue

compress stac

no cdp enable

ppp callback request

ppp authentication chap

ppp multilink

!

router eigrp xx

redistribute static

passive-interface Serial2/0:15

passive-interface Serial2/1:15

passive-interface Group-Async1

passive-interface Dialer1

network 10.0.0.0

no auto-summary

eigrp log-neighbor-changes

!

ip local pool PSTN 10.254.0.200 10.254.0.254

ip classless

ip route 0.0.0.0 0.0.0.0 10.254.0.1

ip route 10.100.0.1 255.255.255.0 10.10.10.1

ip route 10.200.0.1 255.255.255.0 10.10.20.1

no ip http server

!

!

access-list 150 remark *** Trafik control of ISDN ***

access-list 150 deny udp any any eq netbios-ns

access-list 150 deny udp any any eq netbios-dgm

access-list 150 deny udp any any eq netbios-ss

access-list 150 deny igrp any any

access-list 150 deny eigrp any any

access-list 150 permit ip any any

!

dialer-list 1 protocol ip list 150

!

dial-peer cor custom

!

banner motd ^

**************************************

* bla bla *

**************************************

^

!

line con 0

length 60

transport input none

line 97 108

autoselect during-login

autoselect ppp

modem InOut

modem autoconfigure discovery

transport input all

flowcontrol hardware

line aux 0

line vty 0 4

exec-timeout 15 0

password

length 100

!

ntp clock-period 17180607

ntp server 192.38.7.240

end

This works fine for me!

Thank you very much for the response and confidence. :)

Have a great day.

Tony