cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
362
Views
0
Helpful
3
Replies

Configure 2 T-1's to load balance in cisco 2620

leungr
Level 1
Level 1

I have two Cisco 2620 routers with 2-T1 cards. It uses point to point T1's. Originally it was configured as a bridge, but we are changing it to work as a router. I have reconfigured it, but do not know how to load balance, or if this configuration is the best.

I have a 2nd problem in which the systems using the new ip addresses that need to see the server across the router, has a problem when they use their dialup for internet. It loses the network connection to the server until the dialup session is disconnected.

We did not have thie 2nd problem when it was configured as a bridge.

Any help would be greatly appreciated. Thanks.

Here is my running configuration for both routers:

Router-W1

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router-W1

!

enable secret xxxx

enable password xxxxx

!

no ip subnet-zero

!

!

!

!

interface FastEthernet0/0

ip address 10.40.100.253 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

!

--More--

interface Serial0/0

ip address 10.40.101.1 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

no fair-queue

!

interface Serial0/1

ip address 10.40.101.3 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.40.100.250

ip route 10.40.200.0 255.255.255.0 10.40.101.4 10

ip route 10.40.200.0 255.255.255.0 10.40.101.2 10

no ip http server

!

snmp-server engineID local xxxxx

snmp-server community public RO

!

line con 0

transport input none

line aux 0

line vty 0 4

--More--

password xxxxxxxxx

login

!

end

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Router-W2

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router-W2

!

enable secret xxxx

enable password xxxxxxxx

!

no ip subnet-zero

!

!

!

!

interface FastEthernet0/0

ip address 10.40.200.253 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

!

--More--

interface Serial0/0

ip address 10.40.101.2 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

no fair-queue

!

interface Serial0/1

ip address 10.40.101.4 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.40.100.250

ip route 10.40.100.0 255.255.255.0 10.40.101.3 10

ip route 10.40.100.0 255.255.255.0 10.40.101.1 10

no ip http server

!

snmp-server engineID local xxxx

snmp-server community public RO

!

line con 0

password xxxxxx

transport input none

line aux 0

--More--

line vty 0 4

password xxxxxxx

login

!

no scheduler allocate

end

3 Replies 3

Hello,

you could try and turn on CEF on your serial interfaces, this would enable load balancing.

Or configure all interfaces with encapsulation ppp and then add the command 'ppp multilink' to all interfaces.

Regarding your second problem, your systems probably have a default route once they are connected to the Internet, you might want to try and add a specific route on your systems with the 'route add' command (for Windows machines)...

HTH,

GP

Thanks for your reply, I have had to temporarily reconfigure the routers as a bridge, as one network program would pretty much time out when trying to run the program accessing the data across the network. I will try to reconfigure the routers again, late next week. I will let you know the results.

Thanks

DANIEL WANG
Level 1
Level 1

As the first reply points out, this is a typical MS implementation -- they thought once you dialed out you must be connecting to the Internet, which would require a default route. The new default route becomes the active default route overriding your default gateway which is set to the 2600 router.

You didn't have the problem with the 2600 being a bridge because your whole network is just one subnet, which didn't need a default gateway anywhere within this "big" network.

Like the first reply says, use "route add" with "-p" to insert a permanant static route to "10.40.0.0".

We had this happened to us all the time when Comm. Techs dial into equipment at substations.