cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
505
Views
0
Helpful
3
Replies

DSL, QoS, and FTP Server

shimebaugh
Level 1
Level 1

I have a client with an ADSL connection using Cisco 1720 IOS V:12.3.5a with the WIC-1ADSL card. They have normal traffic requirements for a small business site; mail server in, web traffic out, FTP server in & out. My questions is how to implement QoS so the FTP server does starve the upstream pipe.

The FTP server that is causing problems. According to MRTG, there are continuous upstream traffic (client site to the Internet) of approx 60 kbytes/s that fill up the pipe going out. I see max traffic outbound steady for 24 hours at a time. I'm also seeing a steadily increasing number of output drops on the ATM0 interface.

The DSL connection is PPPoE with an ATM interface. Here's a snapshot of the interfaces with load. These loads are typical.

DSL# sho int | include is up|xload

ATM0 is up, line protocol is up

reliability 255/255, txload 219/255, rxload 41/255

ATM0.1 is up, line protocol is up

reliability 255/255, txload 219/255, rxload 41/255

Dialer0 is up, line protocol is up (spoofing)

reliability 255/255, txload 1/255, rxload 1/255

Virtual-Access1 is up, line protocol is up

reliability 255/255, txload 247/255, rxload 126/255

FastEthernet0 is up, line protocol is up

reliability 255/255, txload 1/255, rxload 1/255

I enabled RED on the ATM0 PVC interface. I only have one PVC so it must be the DSL. Here's the queueing:

DSL# sho queueing

Current fair queue configuration:

Interface Discard Dynamic Reserved Link Priority

threshold queues queues queues queues

Dialer0 64 16 0 8 1

Current DLCI priority queue configuration:

Current priority queue configuration:

Current custom queue configuration:

Current random-detect configuration:

VC 0/35 -

random-detect group default:

exponential weight 9

class min-threshold max-threshold mark-probablity

----------------------------------------------------------

0 - - 1/10

1 - - 1/10

2 - - 1/10

3 - - 1/10

4 - - 1/10

5 - - 1/10

6 - - 1/10

7 - - 1/10

rsvp - - 1/10

Current per-SID queue configuration:

I thought I would be seeing drops if RED is working properly. I can't put fair-queue on an ATM interface. Don't know why fair-queue is showing up for the Dialer0.

Any suggestions on what QoS strategy to use?

3 Replies 3

Hello,

can you post your configuration ?

Regards,

Georg

Here's the configuration:

version 12.3

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname DSL-ROUTER

!

boot-start-marker

boot-end-marker

!

logging buffered 8192 debugging

enable secret 5

!

user password

memory-size iomem 20

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

aaa new-model

!

!

aaa authentication login userpswd local

aaa session-id common

ip subnet-zero

!

!

no ip domain lookup

!

ip cef

prompt %h%p%s

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

interface ATM0

no ip address

ip route-cache flow

no ip mroute-cache

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0.1 point-to-point

pvc 0/35

random-detect

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

ip address

ip route-cache flow

speed auto

!

interface Dialer0

ip unnumbered FastEthernet0

ip mtu 1492

encapsulation ppp

dialer pool 1

dialer-group 1

ppp pap sent-username @ password 7

!

ip classless

ip route 0.0.0.0 0.0.0.0

no ip http server

!

!

dialer-list 1 protocol ip permit

!

snmp-server community

!

line con 0

line aux 0

line vty 0 4

exec-timeout 15 0

login authentication userpswd

!

end

Hello,

you could try a class-map and limit the bandwidth assigned to FTP, it would look like this:

class-map match-all FTP

match access-group 101

!

policy-map LIMIT_FTP

class FTP

bandwidth percentage 20

!

interface FastEthernet0

service-policy input LIMIT_FTP

!

access-list 101 permit tcp any any eq FTP

!

This would limit the bandwidth available for FTP to 20%, in case of congestion.

Regards,

Georg