cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1080
Views
0
Helpful
1
Replies

[Issue] Airprint cross VLAN by ISR 1100

Bunny Akasaru
Level 1
Level 1

Hi 

 

I want to get help for Air print. I configured the ISR 1100, VLAN 3 for Print and VLAN 7 for a Wireless client (iPad).

Now the issue is the iPad (VLAN7) cannot find the printer (VLAN3) by AirPrint.

 

===========================================================================================

Here is the configure

interface Vlan 3
ip address 10.148.190.65 255.255.255.224
ip tcp adjust-mss 1452

!
interface Vlan 7
description Wireless
ip address 10.148.190.193 255.255.255.224
ip tcp adjust-mss 1452
!

ip access-list extended ENCRYPTED_TRAFFIC
permit ip 10.148.190.0 0.0.0.255 any
!
access-list 1 permit 10.148.190.0 0.0.0.255
!
ip access-list extended ADMIN-ACL
permit ip 10.0.0.0 0.255.255.255 any

===============================================================================================

 

Many Thanks

Bunny.A

1 Reply 1

brselzer
Cisco Employee
Cisco Employee

Hello,

 

Airprint uses Bonjour protocol which is TTL 1 multicast. This means devices in different subnets can not discover each other. Apples instructions say that they need to be in the same subnet:

 

https://support.apple.com/en-us/HT201387

 

"Make sure that your iOS device and your printer are connected to the same Wi-Fi network"

 

However, we do have a Bonjour gateway solution on certain wireless lan controllers:

 

https://www.cisco.com/c/en/us/td/docs/wireless/controller/5500/white-paper/apple_bonjour/apple_bonjour_services/apple_bonjour_services_chapter_01.html

 

This would allow the wireless lan controller to listen for mDNS traffic and move it from one subnet to another. I believe some switches support this technology as well. You will have to decide if this will work for you depending on your network setup, otherwise the two devices will need to be in the same subnet.

 

Hope that helps!

-Bradley Selzer
CCIE# 60833