08-10-2004 05:43 AM - edited 03-02-2019 05:39 PM
New to Router config. Wondering how this config looks so far if there are any problems with it?
I'll get into ACLs next but I'm wondering before that if this configuration looks okay. The router serial port is connected to ISP and the Ethernet Port will be connected to a Firewall. Both interfaces will have Public IPs.
!
version 12.1
no service single-slot-reload-enable
no service pad
no service finger
no logging console
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname router15
!
banner login * UNAUTHORIZED USE IS PROHIBITED. *
logging rate-limit console 10 except errors
enable secret
!
memory-size iomem 25
ip subnet-zero
no ip source-route
no ip gratuitous-arps
no ip finger
no ip domain-lookup
!
no ip bootp server
ip audit attack action alarm drop reset
ip audit notify log
ip audit po max-events 100
ip audit smtp spam 100
!
!
cns event-service server
!
!
!
interface FastEthernet0
description connected to EthernetLAN
ip address 1.2.3.193 255.255.255.248
speed auto
full-duplex
no cdp enable
no ip proxy-arp
no ip redirects
no ip unreachables
!
interface Serial0
description connected to Internet
ip address 1.2.3.242 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation ppp
service-module t1 clock source internal
service-module t1 timeslots 13-24
service-module t1 remote-alarm-enable
no cdp enable
!
no router rip
version 2
passive-interface Serial0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
!
no cdp run
banner motd
WARNING: You are connected to a
Incorporated network. Unauthorized access and use of this
network will be vigorously prosecuted.
!
line con 0
exec-timeout 0 5
password
login
transport input none
line aux 0
no exec
exec-timeout 0 5
login
transport input none
line vty 0
exec-timeout 0 5
password
login
!
line vty 1 4
no exec
exec-timeout 0 5
login
transport input none
!
no scheduler allocate
!
end
08-10-2004 06:29 AM
Hello,
I guess your firewall is handling the NAT ? Also, what is the RIP used for ? You do not advertise any networks. Other than that, your config looks ok...
Regards,
Georg
08-10-2004 06:44 AM
Firewall will be handling hte NAT. RIP I don't think it is used? Advertise networks, not sure I know what you mean? It will be connecting to the firewall which the external interface will also have a public IP in the same address block as the ethernet port on the router.
08-10-2004 10:17 AM
under serial you may want to use the 'service-module t1 fdl both ' command , this gives the provider the ability to loop your internal CSU
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide