cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2428
Views
0
Helpful
2
Replies

Why show ip bgp output shows no output

aananda
Cisco Employee
Cisco Employee

Hi,

i have two routers R1 and R2 connected by EBGP.

The configurations in R1 is

R1#sh run

Building configuration...

Current configuration : 589 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R1

!

!

ip subnet-zero

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

!

interface Ethernet1/0

no ip address

shutdown

!

interface Serial2/0

ip address 10.1.1.1 255.255.255.0

!

interface Serial3/0

no ip address

shutdown

!

router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 10.1.1.2 remote-as 200

!

ip classless

no ip http server

ip pim bidir-enable

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

login

!

end

R1#

The configuration in R2 is

R2#sh ip bgp

R2#sh run

Building configuration...

Current configuration : 607 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R2

!

!

ip subnet-zero

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

!

interface Ethernet1/0

no ip address

shutdown

!

interface Serial2/0

ip address 10.1.1.2 255.255.255.0

!

interface Serial3/0

ip address 20.1.1.1 255.255.255.0

!

router bgp 200

no synchronization

bgp log-neighbor-changes

neighbor 10.1.1.1 remote-as 100

!

ip classless

no ip http server

ip pim bidir-enable

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

!

end

R2#

The routers are in established state and show ip bgp summary is as given below

R1#sh ip bgp su

BGP router identifier 10.1.1.1, local AS number 100

BGP table version is 11, main routing table version 11

1 network entries and 0 paths using 97 bytes of memory

0 BGP path attribute entries using 0 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP activity 1/2 prefixes, 5/5 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

10.1.1.2 4 200 8 8 11 0 0 00:04:46 0

R1#

R2#sh ip bgp su

BGP router identifier 20.1.1.1, local AS number 200

BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

10.1.1.1 4 100 4 4 1 0 0 00:00:13 0

20.1.1.2 4 200 4 4 1 0 0 00:00:25 0

R2#

Problem is if we see show ip bgp no output will be generared.

R1#sh ip bgp

R1#

R2#sh ip bgp

R2#

Anybody know this so?

2 Replies 2

Hello,

you are not announcing any routes which the EBGP peer could see. There are various ways to announce networks, you might want to check this document:

Troubleshooting When BGP Routes Are Not Advertised

http://www.cisco.com/en/US/partner/tech/tk365/tk80/technologies_tech_note09186a00800945ff.shtml

HTH,

Georg

ahmadalnajjar
Level 1
Level 1

Hello aananda,

There are currently no routes to show.  You can inject routes by either a network statement inside your bgp configuration such as "network 10.1.1.2 mask 255.255.255.255" or by using a "redistribute connected" command

Regards,

Ahmad Al-Najjar