cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1066
Views
0
Helpful
3
Replies
Highlighted
Beginner

Cisco 1720 console port problem

Hello all,

I have recently aquired a Cisco 1720 router with two modules installed (one ISDN modem and the other one a console module). It also has a 8MB flash card installed in it.

The problem is that I don't know the password, so I tried to reset it.

I'm using Minicom on a GNU/Linux machine. When I try to send a brake command (right after I power it on), minicom stalls (I think that this is a minicom issue).

But, even if I let minicom still, without sending anything, I don't get any info from the router (not even the POST data or anything).

I have the router's IP address and I can ping it or even connect to it via the terminal, so I guess that the router (well... most of it) works, the problem is only the console port (which I think is bad or there is something wrong with it).

I tried removin all the modules and still no go. When I remove the flash card, the OK LED blinks non-stop.

With my setup (the cables and minicom) I can access my other Cisco 805 router with no problems at all.

I have several questions,

Has anyone encourted with this kind of a issue and maybe share a way to fix it ?

Is it possible for me to remove the flash card, put it in my Cisco 805 router and reset the password (secret) via the Cisco 805 ?

Is it possible (assuming that the console port is fried) to reset the 1720 via the console addon card installed on it ?

Regards,

Aleks

3 REPLIES 3
Highlighted
Cisco Employee

Re: Cisco 1720 console port problem

Hi Aleks,

I believe either your console port is broken, either you minicom parameter are not set to the same values as the 1720 (as configured with the config register). I would first try to change all the possible speed in minicom, then all other possible combination, and hit "enter" once the device is booted to see if some characters are seen. If weird chars are seen that probably means that the port is fine but you still need to change the speed to a correct value. If nothing works, then the console is probably broken and there is little you can do without knowing the password and telnet the device (if it was configured for that).

One other trick is to set your minicom speed to the lowest value, reload the router and keep the space bar pushed. This may simulate the break sequence and worked in some occasion to break in rommon.

You can not tweak the flash card as the router will boot the startup-config file, containing the enable password, which is stored in nvram (not removable). This is why for password recovery we need to break in rommon to avoid the router to parse that file and start with a blank config.

As for the additional console module, I've never head of this, we should have only one built-in console port on any router, do you have the part number written on it?

Thanks,

Raphael

Highlighted
Advisor

Re: Cisco 1720 console port problem

Hi,

I have the router's IP address and I can ping it or even connect to it via the terminal

So you can telnet to it? if so then you can verify the config-register setting with the sh version command and verify

the console port with the sh run | be line command.

Regards.

Alain.

Don't forget to rate helpful posts.
Highlighted
Beginner

Re: Cisco 1720 console port problem

Thanks for the reply.

I've tried with all the possible combinations for the baud speed in minicom, even the "hold space" technique, nothing worked.

For the other console module, I will post info about it (even a picture) as soon as I get home.

I will try however to debug the serial console/port/driver on a hardware level, but I don't think that I can do much.

@cadetalain

I can connect to it via telnet but I can't enter because I don't know the password, thats why I'm trying to reset it.

Regrads,

Aleks