12-30-2004 09:06 AM - edited 03-02-2019 08:50 PM
I am relatively new to network configuration and I am having some difficulty configuring my Cisco 3640 router. At Work we have a wireless Internet connection, which provides strictly access to the Internet and is not connected to the internal network. We have a lab also not connected to the internal network used strictly for testing purposes. I purchased a Netgear wireless Ethernet Bridge to give the lab Internet capabilities. In our current setup the bridge is connected to our Cisco 3640 router through the Fast ethernet2/0, which is then connected to a hub through the Ethernet 0/0 port. From there the hub should supposedly distribute the Internet connection to our servers. We have tried configuring the router many different ways and even tried Ciscos ConfigMaker with no luck. Do we have this set up right? Is this possible to do with a wireless bridge? Are there any special configurations on the router we need to implement for this to work? Any suggestions will be greatly appreciated. Thanks!!
12-30-2004 09:26 AM
Is it
Netgear bridge-----fa2/0(3640)fa0/0---hub---network
Need a lot more information as far as,
a. exact topology,
b. what other equipment is inline with the above mentioned layout.
c. How IP addressing is handled from the ISP.
d. Who will do NAT translation to translate your internal IPs to external IPs...
Sankar.
12-30-2004 10:23 AM
a) Topology: Netgear bridge----fa2/0(3640)ethernet0/0---hub---network
b) the other equipment that are connected to the hub are:
-Dell PowerEdge 400SC running Redhat linux 9.0
-Dell PowerEdge 600SC running Win 2003 Server (Domain controller)
-multiple other pcs running variations of windows.
c) The bridge receives a dynamic IP address from an access point
d) NAT translation will be done on the 3640 router.
12-30-2004 11:48 AM
You can setup a dynamic address on fa2/0 as follows
int fa2/0
ip address dhcp
You will most probably have a default route also set via DHCP on your route table.
Set int fa2/0 as NAT outside interface. Set int fa0/0 as NAT inside interface.
int fa2/0
ip nat outside
ip add dhcp
int fa0/0
ip nat inside
ip add x.x.x.x
ip nat inside source list 1 interface fa2/0 overload
access-list 1 permit x.x.x.x
x.x.x.x is the internal lab subnet (Dells will have static IPs from this subnet)
Hope that helps!
12-30-2004 01:08 PM
I tried to implement all the changes that you suggested, but it would not accept the ip address dhcp command. It might be easier if you can just point out our errors. Thanks again!!
Current configuration : 1939 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname LAB
!
enable secret xxxxx
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip dhcp excluded-address 192.168.0.202 192.168.0.208
!
ip dhcp pool 1
network 192.168.0.0 255.255.255.0
default-router 192.168.0.201
!
!
!
!
!
!
interface Ethernet0/0
description connected to lan
ip address 10.0.0.1 255.0.0.0
ip nat outside
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Serial1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface FastEthernet2/0
description connected to bridge
ip address 192.168.0.201 255.255.255.0
ip nat inside
speed auto
full-duplex
!
router rip
version 2
passive-interface Ethernet0/0
network 192.168.0.0
no auto-summary
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip nat inside source route-map outbound interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password xxxx
login
transport input none
speed 115200
line aux 0
line vty 0 4
password xxxx
login
!
end
12-30-2004 02:27 PM
In your config there is no public IP to which ip addresses are NAT ed, so I dont know if your Internet router (device) does the final private IP to public IP translation to Internet.
fa2/0 has IP of 192.168.0.0 network and is the inside interface. e0/0 is 10.0.0.0 network and is the outside interface. Access-list 1 matches 192.168.0.0 network. Are the Dell servers in 192.168.0.0 network ?
If this is the case your internet connection (netgear bridge) should be connected on e0/0 as its the outside interface.
Netgear =====e0/0(3640)-fa2/0-----network.
01-07-2005 12:06 PM
the internet router is doing the natting!! so do i need to set up dhcp?
12-31-2004 08:04 AM
Hi Dear
I m still not clear with ur setup,
1 Whether the Bridge doing the Natting ?
2.To confirm jut connect the Bridge on the Lan Switch and configure one of ur m/c with the 192.168.0.201 255.255.255.0 ip and mask and gateway as Bridge IP and try to ping any DNS server on the internet. If u r through then the Bridge is doing the Nating and no need to NAT on the router.
3.If ur not able to ping the Internet DNS ip then u should assign a Valid/Public IP to the routers F0/0 int. IP pool given by the service provider
4. Let me know which Model of Netgear bridge u r using I suppose the Bridge itself is doing the NATing.
5.If it so the put the default gateway of the router as the IP of the Bridge and for all the m/c on the network put the router's E0/0 ip as gateway. Aslo remove the nating configruration from the router.
Please let me know if u clear with this.
My email id is ephraim_mani@vsnl.net
01-04-2005 07:14 AM
Ephraim,
The bridge is doing the Natting. If I were to take my laptop and plug it directly into the bridge, I can access the Internet. In our lab, the current setup is bridge-->Fa2/0--Eth0/0àa computer. I have the bridge setup to have a static IP of 192.168.0.201. I configured the Fastethernet2/0 interface to have the same IP as the bridge. The Ethernet0/0 Interface has an IP address of 10.0.0.1 and connects to all the other computers that have IPs of 10.0.0.2, 10.0.0.3, etc...If you took the bridge and plugged your computer directly into it without the router, and you try to access the Internet, you are redirected to 192.168.0.1 where it notifies you to click a button to connect to the Internet (this page was setup by our network guys). Occasionally when going through the router I am able to ping the 192.168.0.1 IP. When connected through the router, I am not redirected to the 192.168.0.1 page, but occasionally if I type in the IP address in the URL it will give me the page that asks me to connect. After clicking the connect button, even though it says I am connected I am not able to access any Internet pages. Even though I mention I am occasionally able to do things, I am not sure if the connection just goes in and out or if it is due to some configuration changes that I have made. I dont know if the wireless signal is too weak? If I dont have the bridge configured properly? If this is even possible? Any more information/tips you can provide would be greatly appreciated. Thanks,
Milwbr821
12-31-2004 08:05 AM
Hi Dear
I m still not clear with ur setup,
1 Whether the Bridge doing the Natting ?
2.To confirm jut connect the Bridge on the Lan Switch and configure one of ur m/c with the 192.168.0.201 255.255.255.0 ip and mask and gateway as Bridge IP and try to ping any DNS server on the internet. If u r through then the Bridge is doing the Nating and no need to NAT on the router.
3.If ur not able to ping the Internet DNS ip then u should assign a Valid/Public IP to the routers F0/0 int. IP pool given by the service provider
4. Let me know which Model of Netgear bridge u r using I suppose the Bridge itself is doing the NATing.
5.If it so the put the default gateway of the router as the IP of the Bridge and for all the m/c on the network put the router's E0/0 ip as gateway. Aslo remove the nating configruration from the router.
Please let me know if u clear with this.
My email id is ephraim_mani@vsnl.net
12-31-2004 03:39 PM
I also am having problem with the Configmaker on a 3640. It does not want to recongize the 1FE2W in Auto detect mode and when i put in the configes and try to "deliver" it bombs out and say's that there is no Ethernet port , I can manually put in the address and ping the 1FE.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide