cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

2496
Views
0
Helpful
3
Replies
Beginner

Error DHCPD: no option 125

Hi everybody,

I have one problem with DHCP:

I configurate interface on Firewall Fortinet and I set it is DHCP server but when I connect to PC via Cisco Switch so my PC don't get IP address

port on Switch I configurate is:

 

interface GigabitEthernet0/23
description *connect to FW*
switchport trunk native vlan 32
switchport trunk allowed vlan 32,50
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active

 

interface GigabitEthernet0/9
switchport access vlan 32
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
ip dhcp snooping limit rate 100

 

and show logging debug DHCP it notice is:

Aug 24 03:02:55.244: DHCPD: interface GigabitEthernet0/9 coming up
Aug 24 03:02:56.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/9, changed state to up
Aug 24 03:03:33.304: DHCPD: checking for expired leases.
Aug 24 03:04:35.544: DHCPD: no option 125
Aug 24 03:05:03.447: DHCPD: no option 125
Aug 24 03:05:11.458: DHCPD: no option 125
Aug 24 03:05:13.747: DHCPD: no option 125
Aug 24 03:05:17.449: DHCPD: no option 125
Aug 24 03:05:33.307: DHCPD: checking for expired leases.
Aug 24 03:05:54.383: DHCPD: no option 125
Aug 24 03:06:37.444: DHCPD: no option 125
Aug 24 03:06:37.448: DHCPD: no option 125
Aug 24 03:06:42.254: DHCPD: no option 125
Aug 24 03:06:56.675: DHCPD: no option 125
Aug 24 03:06:59.922: DHCPD: no option 125

 

 

Please help me check this problem 

Thanks!

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Error DHCPD: no option 125

Hi Eric,

Thank for reply soon.

But when I plug PC into FW fortinet, it get IP address normal

Now I configurate 

interface GigabitEthernet0/23
description *connect to FW*
switchport trunk native vlan 32
switchport trunk allowed vlan 32,50
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
ip dhcp snooping trust
end

 

interface GigabitEthernet0/9
switchport access vlan 32
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
ip dhcp snooping limit rate 100
ip dhcp snooping trust
end

 

so My PC still can't get IP

Have you other menthod to fix this problem

3 REPLIES 3
Highlighted

Re: Error DHCPD: no option 125

Hi,

 

As I understand your Fortinet is the DHCP Server and your Cisco switch is used only for layer 2, if this is the case then there's not much info you can get by doing a debug dhcp on the switch, you only need to have layer 2 connectivity between client and DHCP server so the DHCP process can be completed (client sends a broadcast DHCPDiscover, server responds with a DHCPOffer, and so on...).

 

I noticed you have DHCP Snooping configured, if that's the case and you have DHCP Snooping enabled then you probably need to trust the interface connected to the DHCP Server, can you try configuring this:

 

interface GigabitEthernet0/23

ip dhcp snooping trust

 

If you have DHCP snooping enabled it will drop DHCP packets from untrusted sources

Beginner

Re: Error DHCPD: no option 125

Hi Eric,

Thank for reply soon.

But when I plug PC into FW fortinet, it get IP address normal

Now I configurate 

interface GigabitEthernet0/23
description *connect to FW*
switchport trunk native vlan 32
switchport trunk allowed vlan 32,50
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
ip dhcp snooping trust
end

 

interface GigabitEthernet0/9
switchport access vlan 32
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
ip dhcp snooping limit rate 100
ip dhcp snooping trust
end

 

so My PC still can't get IP

Have you other menthod to fix this problem

Beginner

Re: Error DHCPD: no option 125

Please, have anybody support for me this problem?

this is my log

ug 25 02:33:35.180: DHCPD: checking for expired leases.
Aug 25 02:33:35.991: DHCPD: no option 125
Aug 25 02:34:03.512: DHCPD: no option 125
Aug 25 02:34:03.516: DHCPD: no option 125
Aug 25 02:34:04.729: DHCPD: no option 125
Aug 25 02:34:04.750: DHCPD: no option 125
Aug 25 02:34:07.469: DHCPD: no option 125
Aug 25 02:35:10.894: DHCPD: no option 125
Aug 25 02:35:10.894: DHCPD: no option 125
Aug 25 02:35:35.186: DHCPD: checking for expired leases.
Aug 25 02:35:39.908: DHCPD: no option 125
Aug 25 02:35:39.908: DHCPD: no option 125
Aug 25 02:35:39.929: DHCPD: no option 125
Aug 25 02:35:46.633: DHCPD: no option 125
Aug 25 02:35:46.633: DHCPD: no option 125
Aug 25 02:35:47.643: DHCPD: no option 125
Aug 25 02:36:25.556: DHCPD: no option 125
Aug 25 02:36:25.559: DHCPD: no option 125
Aug 25 02:36:37.632: DHCPD: no option 125
Aug 25 02:36:52.162: DHCPD: no option 125
Aug 25 02:37:06.933: DHCPD: no option 125
Aug 25 02:37:23.455: DHCPD: no option 125
Aug 25 02:37:35.188: DHCPD: checking for expired leases.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards