cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
352
Views
0
Helpful
1
Replies
Highlighted
Beginner

Setting up a server behind NAT on 871W

Hello all, I have been searching for quite some time and every command I try just doesn't seem to work. I will post the config below for review. I am trying to open port 25565 to the outside so people can join a server I am hosting. NAT line in bold below

If I have done something wrong in the post or am in the wrong section I apologize.

PandaRTR(config)#do sh run

Building configuration...

Current configuration : 2948 bytes

!

! Last configuration change at 06:27:30 UTC Thu Feb 20 2014 by pcrowley

! NVRAM config last updated at 23:55:33 UTC Sun Jan 26 2014

!

version 12.4

service config

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname PandaRTR

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

logging buffered 4096

enable secret 5

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid Panda1

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7

!

no ip source-route

no ip gratuitous-arps

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.5

!

ip dhcp pool Internal

   import all

   network 192.168.1.0 255.255.255.0

   domain-name Panda

   dns-server 8.8.4.4

   default-router 192.168.1.1

!

!

ip cef

no ip bootp server

ip domain name Panda

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username pcrowley password 7!

!

!

archive

log config

  hidekeys

!

!

ip ssh time-out 60

ip ssh authentication-retries 2

ip ssh version 2

!

bridge irb

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address dhcp

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

speed auto

full-duplex

!

interface Dot11Radio0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

!

encryption mode ciphers aes-ccm

!

ssid Panda1

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

bridge-group 1

!

interface Vlan2

no ip address

!

interface BVI1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip dns server

ip nat inside source list 101 interface FastEthernet4 overload

ip nat inside source static tcp 192.168.1.4 25565 interface FastEthernet4 25565

!

logging trap debugging

access-list 100 permit udp any any eq bootpc

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

access-list 102 permit tcp any any eq 25565

access-list 103 permit tcp any eq 25565 any eq 25565

access-list 104 permit udp any any eq 25565

no cdp run

!

!

!

!

!

control-plane

!

bridge 1 protocol dec

bridge 1 route ip

banner motd ^C Unauthorised access is prohibited^C

!

line con 0

no modem enable

line aux 0

line vty 0 3

password

login local

transport input ssh

line vty 4

login

!

scheduler max-task-time 5000

ntp server pool.ntp.org

end

1 REPLY 1
Highlighted
Beginner

Please change the nat for server access list above the default nat acl and it should work fine

Sent from Cisco Technical Support iPad App