cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
192
Views
0
Helpful
5
Replies
joseph.hamilton
Beginner

Disabling cached query responses?

Here's the problem I have...

Whenever I go to our SharePoint site to upload a document, CSA will flag whatever file I click on in the "Open file" window (before I go to upload) and query me if I want to give access to iexplore.exe to read the file. If a normal user is in this situation, they'd probably click no. Then, when you go to upload that file, the access is automatically blocked by the remembered query answer.

The query I've made (I made a specific one for this) DISABLES the "Don't Ask Me Again" option. My question is how can I disable all cached responses so that users can deny access in a certain situation, then grant access in another? Or is there a way to force the Agent to clear it's cached responses every couple minutes?

5 REPLIES 5
amritpatek
Frequent Contributor

It is the Don't ask again checkbox available from the Query Settings page in the MC that controls whether the end user has the ability to have a query response remembered permanently. As the administrator, you decide whether or not users have the option to choose Don't ask again. If user queries do not include a Don't ask again option and responses are only cached temporarily (for approximately an hour) users can click the Clear button in the agent Query User Responses window to delete all temporarily cached responses.

Look at the URL for more information

http://www.cisco.com/en/US/products/sw/secursw/ps5057/products_configuration_guide_chapter09186a0080424780.html#wp962337

Thanks for the response. We're trying to limit our end user's interaction with the Agent, so I'll keep searching for another solution, but if we can't find anything, we may just have to educate them (or our Helpdesk) how to guide users through clearing the cached responses.

Couldn't you just change all of your rules so they don't Query?

yes, but therein lies the problem...

If I set the rule to Allow, it's opening a huge security hole (IEXPLORE.EXE will always be able to read any MS Word documents)

If I set the rule to Deny, uploads will not work, since IEXPLORE.EXE needs to read the file before it can upload.

I'm working with Cisco TAC and they may be able to design a solution...

Has TAC been any help with this? I recently setup a SharePoint server and am having the same dilemma.

Thanks.

Content for Community-Ad