Dear all,
I have webserver and email server hosted on one machine with private ip address and i have received one public ip address from the ISP.
I have attached the setup diagram for our network, please post the command for internet devices to access my websever and email server on cisco 881-K9. (Also the router is also setup to allow internet access to internal devices.)
below is the configuration for reference
Current configuration : 2674 bytes
!
! Last configuration change at 10:37:47 UTC Mon Jul 18 2016
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
enable password xyz
!
no aaa new-model
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.1.2 192.168.1.10
ip dhcp excluded-address 192.168.1.253
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.253
dns-server 84.235.57.230 84.235.6.55
lease 0 2
!
!
!
ip domain list net.sa
ip domain name net.sa
ip host youtube.com 192.168.0.254
ip host facebook.com 192.168.0.254
ip name-server y.y.y.y
ip name-server y.y.y.y
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
license
!
!
username xyz password 0 xyz
!
!
!
!
!
!
class-map match-any url-block-class
match protocol http host "*youtube*"
match protocol http host "*dailymotion*"
match protocol http host "*facebook*"
match protocol http host "*metacafe*"
match protocol http host "*netflix*"
match protocol facebook
match protocol bittorrent-networking
match protocol bittorrent
match protocol youtube
match protocol video-over-http
!
policy-map url-block-policy
class url-block-class
drop
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
description internet
no ip address
!
interface FastEthernet1
description Outside World
no ip address
!
interface FastEthernet2
description lan
switchport access vlan 100
no ip address
!
interface FastEthernet3
description outside world
no ip address
!
interface FastEthernet4
description external interface
ip address x.x.x.x 255.255.255.254
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 192.168.1.253 255.255.255.0
ip nat inside
ip virtual-reassembly in
service-policy input url-block-policy
!
ip default-gateway 192.168.1.253
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip nat inside source list 1 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
!
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 23 permit any
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
password xyz
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end