10-05-2017 01:05 AM - edited 03-21-2019 10:56 AM
Hi, I created a network with a multilayer sg300-28P in layer 3 with the following vlan:
vlan 10
interface vlan 10
ip address 192.168.10.1 255.255.255.0
vlan 100
interface vlan 100
ip address 192.168.100.1 255.255.255.0
vlan 110
interface vlan 110
ip address 192.168.110.1 255.255.255.0
vlan 4 as a link to rv320
interface vlan 4
ip address 192.168.1.2 255.255.255.0
I set a static route on the SG300 as the default route:
ip route 0.0.0.0 0.0.0.0 192.168.1.1 <---- ip of rv320
I have configured rv320 with vlan 4 not tagged on port 1 by assigning this vlan to ip address 192.168.1.1.
I configured advanced routing on rv320 by entering as ip address 192.168.0.0 and as subnet 255.255.0.0 and gateway 192.168.1.2 <--- ip of the SG300.
The result is that from the console of the SG300 I can ping IP address 192.168.1.1 via interface 192.168.1.2 but I can not ping 192.168.1.1 from any of the other vlan.
What could be the problem?
thank you
10-05-2017 01:38 AM
Hi there,
Can you attach the full running config of the SG300?
cheers,
Seb.
10-05-2017 01:52 AM
hi,
thank you for help.
This is a configuration of sg300:
v1.4.8.6 / R800_NIK_1_4_202_008
CLI v1.0
set system mode router
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 4,10,100,110
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip dhcp server
ip dhcp excluded-address 192.168.100.1 192.168.100.1
ip dhcp pool network Office
address low 192.168.100.200 high 192.168.100.230 255.255.255.0
default-router 192.168.100.1
dns-server 192.168.1.1
exit
bonjour interface range vlan 1
hostname SG300
username cisco password encrypted privilege 15
ip ssh port 22
ip ssh server
!
interface vlan 1
no ip address dhcp
!
interface vlan 4
name LinkL3RV320
ip address 192.168.1.2 255.255.255.0
!
interface vlan 10
name MGMT
ip address 192.168.10.2 255.255.255.0
!
interface vlan 100
name Office
ip address 192.168.100.1 255.255.255.0
!
interface vlan 110
name Printers
ip address 192.168.110.1 255.255.255.0
!
interface gigabitethernet1
switchport trunk allowed vlan add 100
switchport trunk native vlan 10
!
interface gigabitethernet2
switchport trunk allowed vlan add 100
switchport trunk native vlan 10
!
interface gigabitethernet3
switchport trunk allowed vlan add 100
switchport trunk native vlan 10
!
interface gigabitethernet4
channel-group 1 mode auto
switchport mode access
!
interface gigabitethernet5
channel-group 1 mode auto
switchport mode access
!
interface gigabitethernet6
switchport mode access
switchport access vlan 10
!
interface gigabitethernet7
switchport mode access
switchport access vlan 110
!
interface gigabitethernet8
switchport mode access
switchport access vlan 100
!
interface gigabitethernet9
switchport mode access
switchport access vlan 110
!
interface gigabitethernet10
switchport mode access
switchport access vlan 100
!
interface gigabitethernet11
switchport mode access
switchport access vlan 100
!
interface gigabitethernet12
switchport trunk allowed vlan add 100
switchport trunk native vlan 10
!
interface gigabitethernet19
switchport mode access
switchport access vlan 100
!
interface gigabitethernet24
switchport mode access
switchport access vlan 10
!
interface gigabitethernet25
switchport mode access
switchport access vlan 4
!
interface gigabitethernet26
!
interface gigabitethernet27
!
interface gigabitethernet28
!
interface Port-channel1
switchport mode access
switchport access vlan 100
!
exit
ip default-gateway 192.168.1.1
10-05-2017 01:56 AM
Are the other devices in VLAN100 directly attached to the switch? If so, are they configured to receive tagged packets?
cheers,
Seb.
10-05-2017 02:01 AM
hi,
The only devices that are connected and include the tag are the access points that have vlan native 10 ie management while tag 100. Devices within the sg300 switch can reach everyone else quietly. They also succeed in reaching the address of SG300 192.168.1.2 but fail to reach the address 192.168.1.1 which corresponds to the rv320.
10-08-2017 06:49 PM - edited 10-08-2017 07:08 PM
I currently have a RV320 router setup with a SG300-28 switch in layer 3 mode.
I am using a tagged VLAN for my router VLAN. The only thing which comes to mind, is do you have a route statement on the RV320 for network IP address (192.168.100.0) of VLAN100 poining to 192.168.1.2(VLAN4 IP ) so there is a path back to the switch?
You also need a route statement on the RV320 for each network not directly connected to the RV320 router.
PS
I noticed you are passing out 192.168.100.1 as your default router IP. I use the switch's VLAN IP address for each VLAN. So there is a different default gateway for each VLAN scope on DHCP.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide