Showing results for 
Search instead for 
Did you mean: 

RVS4000 won't upgrade from to firmware + freezes



I've just purchased 2 RVS4000. The units, which are V2, have been shipped with firmware

It seems this version suffers from multiple vulnerabilities I would like to fix asap. Unfortunately, I was unable to upgrade to

One one of the units, I went through the upgrade process via the admin interface. It seemed to work, though it got stucked at 100% - which is a known issue, as per the release notes - but then, instead of having my unit upgraded as advertised when going back to the home page. It seems I'm stucked in I tried the upgrade a couple of times without any success before posting here.

On top of that, the other unit I have is on another site, far from where I am at the moment. It is also a firmware. I didn't try the upgrade, as I prefer to be on site when doing this type of things, this will be the case next week. This other unit seems to be much more responsive than the one I tried to upgrade without success. On the one I have now with me, I have plenty of freezes everytime, it can take up to 5mn for the device to respond to a query. The other one I'm managing remotely does not show these problems. Also, even though the units are the same, the "faulty" one seems to have issues to keep all the settings properly. For example, key lifetimes get always reset to 0 sec, and I have to fill 28800 and 3600 each time I make a change in the configuration. Again, the remote one does not have this issue.

So my questions are :

- Does somebody already have this kind of issues with the RVS4000 ?

- Is it normal 2 units purchased at the same time, which have been shipped with the same firmware, behave differently ?

- Is it possible I have a faulty hardware ?

Any advice would be welcome.



1 Reply 1


Hi Franck,

I am sorry that you are having this issues.

I can't say that it is normal for RVS000 to have this issues.  What I would like to recommend is to reset the device to factory default and reconfigure it manually.  It is possible that your router have corrupter f/w and simple reset to factory should fix the problem.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: