cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2424
Views
0
Helpful
7
Replies

WRVS4400N slowing down my 100Mb internet connection

Ripjing76
Level 1
Level 1

Hi,

  I have a Cisco WRVS4400N on the latest firmware and I have just had my Virgin internet connection upgraded to the 100Mb. Once i thought it was upgraded i checked with a broadband speed test and it came back as 15Mb download and 5Mb upload. Before i rang Virgin i thought i'd check with a direct connection from my pc straight to the modem. Ran the speed test and it came back as 100Mb download and 5Mb upload. I thought the best thing to do is restore my settings back to factory and its still the same. Just wondering if anyone can assist?

Thanks

Andy

7 Replies 7

doug_counsil
Level 1
Level 1

Disable IPS (Intrusion Protection System).  It is very resource intensive because it does deep packet inspection.  From my experience the best the router can do with IPS enabled is about 20 Mbps.

Thanks Curtis, just disabled that and now its up to 34.77Mb. So a bit better. I've disabled the QoS i had setup as well. Do you have any more idea's?

Thanks for your help, i really do appreciate it!

Andy

I'm out of ideas.

Why version is your WRVS4400N?  v1 or v2?  We had a v2 which I believe was a little bit different.  I think it had a little more horsepower (CPU, RAM, etc.) than the original v1.

It's the v2 one. Same here, especially with me taking it back to factory settings.

Is there anyway of raising this with Cisco themselves as it might be some sort of hardware error? Thanks again for all your help. I really do appreciate it!

are you running CAT5 cable or above on your wan port?

Also how are you running the speedtest? fully wired or is your PC wireless? if it is wireless then make sure you are using N and not b/g for connection. the wan/lan should handle more than 100mbs.

try putting your PC onto one of the ethernet ports using a cat5e/6 cable and test again.

Regards Simon
http://www.linksysinfo.org

Regards Simon

Hi Simon,

   Thanks for helping mate. Definitely not testing over the wireless so I'm running the connection over a Cat5e cable, 1Gb auto negotiated connection from the Virgin modem to the router,  then Cat5e through from the router to the pc also 1Gb auto negotiated. No errors over the connection as reported by the router for the WAN port and none for the LAN port. They are the only things connected. I've turned the wireless off so there should be no wireless devices connected, just the pc.

Cheers again

Andy