cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
704
Views
10
Helpful
3
Replies

1921 and 1602i Autonomous

magicman_64
Level 1
Level 1

Hello, I'm very new to cisco programming but I recently acquired a client that has a Cisco 1921 with a EHWIC-4ESG-P. One of the HWIC ports feeds a 1602i with POE. The client has an odd issue. That is, DHCP will not issue wired or wireless clients any IP addresses. I have been able to get manually set IP addresses on both wired and wireless devices to work without issues. But beyond that I have reached my troubleshooting expertise this this matter. Also, the 1921 has some firewall stuff but nothing limiting manually assigned IP address devices from accessing anything inside/outside the network. Any guidance from here would be marvelous.

 

Aditional tests:

Ping to 10.0.0.3 results in "U.U.U" output from 10.0.0.1 and vise versa.

Pinging any wireless device with a manually set IP via wireless works.

Pinging from wired device on the router to wireless anything does not work.

 

Here is the 1602i programming: (redacted)


version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime localtime year
service password-encryption
!
hostname WAP-01
!
!
logging rate-limit console 9
!
!
aaa session-id common
clock timezone EST -5 0
clock summer-time EDT recurring
no ip source-route
ip routing
ip cef
ip domain name Local
!
!
!
!
dot11 pause-time 100
dot11 syslog
dot11 vlan-name LAN vlan 20
!
dot11 ssid CLIENTSSID
vlan 20
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii 7 SOMENUMBERS
!
dot11 network-map
!
no ipv6 cef
!
bridge irb
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers aes-ccm
!
encryption vlan 20 mode ciphers aes-ccm
!
ssid CLIENTSSID
!
antenna gain 128
stbc
beamform ofdm
channel 2462
station-role root
!
interface Dot11Radio0.20
encapsulation dot1Q 20 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
!
encryption vlan 20 mode ciphers aes-ccm
!
ssid CLIENTSSID
!
antenna gain 128
peakdetect
dfs band 3 block
stbc
beamform ofdm
channel dfs
station-role root
!
interface Dot11Radio1.20
encapsulation dot1Q 20 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
ip helper-address 10.0.0.1
duplex full
speed 1000
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface GigabitEthernet0.20
encapsulation dot1Q 20
!
interface BVI1
mac-address MACADDRESSOFDEVICE
ip address 10.0.0.3 255.255.255.0
!
ip default-gateway 10.0.0.1
ip forward-protocol nd
no ip http server
ip http authentication local
ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip ssh version 2
!
ip access-list extended Network_1
permit ip 10.0.0.0 0.0.0.255 any log
deny ip any any log
!
logging facility local3
logging host 10.0.0.20
!
!
bridge 1 route ip

 

 

1921 Programming: (redacted as well)

version 15.7
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname RTR-01
!
boot-start-marker
boot system flash:c1900-universalk9-mz.SPA.157-3.M4.bin
boot-end-marker
!
security authentication failure rate 3 log
!
no ip source-route
!
ip nbar protocol-pack flash:pp-adv-isrg2-157-3.M-23-32.3.0.pack
!
ip dhcp excluded-address 10.0.0.1 10.0.0.50
ip dhcp excluded-address 10.0.0.150 10.0.0.255
!
ip dhcp pool 1
import all
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1
option 150 ip 10.0.0.20
option 66 ip 10.0.0.20
option 67 ascii boot\x64\pxeboot.com
dns-server 10.0.0.1 NEXTHOPIPREMOVED
lease 8
!
no ip bootp server
ip name-server 8.8.8.8
ip inspect tcp reassembly queue length 80
ip ips config location flash:IPS retries 1
ip ips name IOS-IPS
!
ip ips signature-category
category all
retired true
category ios_ips basic
retired false
!
ip device tracking
ip cef
login block-for 300 attempts 3 within 60
no ipv6 cef
!
multilink bundle-name authenticated
!
domain Local
!
license udi pid CISCO1921/K9 sn SERIALNUMBER
license boot module c1900 technology-package securityk9
license boot module c1900 technology-package datak9
!
vtp mode transparent
!
redundancy
!
vlan 20
name LAN
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Primary_WAN
ip address dhcp
ip nbar protocol-discovery ipv4
ip flow ingress
ip flow egress
ip nat outside
ip inspect Firewall in
ip inspect Firewall out
ip ips IOS-IPS in
no ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
!** other ports removed **
!
interface GigabitEthernet0/1/3
description WAP-01
switchport access vlan 20
switchport trunk native vlan 20
switchport mode dot1q-tunnel
ip device tracking maximum 10
no ip address
zone-member security inside
duplex full
speed 1000
!
interface Vlan1
no ip address
shutdown
!
interface Vlan20
ip address 10.0.0.1 255.255.255.0
ip access-group Network_1 in
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
!
no ip http server
no ip http secure-server
ip flow-top-talkers
top 50
sort-by bytes
cache-timeout 600000
!
ip dns server
ip nat inside source list 100 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 NEXTHOPIPREMOVED
ip ssh version 2
!
ip access-list extended Network_1
remark Allow TCP Traffic to Internet
permit tcp 10.0.0.0 0.0.0.255 any
remark Deny any remaining inbound traffic
deny ip any any
!
logging facility local1
logging host 10.0.0.20
ipv6 ioam timestamp
!
route-map RM1 permit 0
match ip address Network_1
!
!
access-list 100 remark Allow TCP Traffic to Internet
access-list 100 permit tcp 10.0.0.0 0.0.0.255 any
access-list 100 remark Deny any remaining inbound traffic
access-list 100 deny ip any any
!
!
!
control-plane
!
bridge 1 protocol ieee

 

 

Thanks

1 Accepted Solution

Accepted Solutions

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

For DHCP to work you must allow a host without an IP address (0.0.0.0) send a broadcast (255.255.255.255) to UDP/67 (bootps). This means you need to adjust your ACL on the router so that it looks like:

 

!
ip access-list extended Network_1
remark permit DHCP
permit udp any eq bootpc any eq bootps
remark Allow DNS too
permit udp 10.0.0.0 0.0.0.255 any eq 53
remark Allow TCP Traffic to Internet
permit tcp 10.0.0.0 0.0.0.255 any
remark Deny any remaining inbound traffic
deny ip any any
!

... I've also add a ACE for DNS too.

 

cheers,

Seb.

 

 

 

View solution in original post

3 Replies 3

Hello,

 

at first glance, since you have ip routing enabled on the 1602i, you need a default route. Add:

 

ip route 0.0.0.0 0.0.0.0 10.0.0.1

 

Also, remove:

 

ip default-gateway 10.0.0.1 (this is for layer 2 only)...

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

For DHCP to work you must allow a host without an IP address (0.0.0.0) send a broadcast (255.255.255.255) to UDP/67 (bootps). This means you need to adjust your ACL on the router so that it looks like:

 

!
ip access-list extended Network_1
remark permit DHCP
permit udp any eq bootpc any eq bootps
remark Allow DNS too
permit udp 10.0.0.0 0.0.0.255 any eq 53
remark Allow TCP Traffic to Internet
permit tcp 10.0.0.0 0.0.0.255 any
remark Deny any remaining inbound traffic
deny ip any any
!

... I've also add a ACE for DNS too.

 

cheers,

Seb.

 

 

 

I have updated the config on the AP and Router and both answers appear to be my solution. Thank you for the valued suggestions. I'll mark the firewall rules as the ultimate answer but both were extremely helpful.

 

Thanks Again!

Review Cisco Networking products for a $25 gift card