01-11-2016 10:24 AM - edited 03-05-2019 03:06 AM
Has anyone setup something similar to attachment? If so, can you share the configuration?
What I am trying to do is to run some bandwidth test tool, like NTttcp, JPerf, iPerf, etc. on the PCs (PC-1 and PC-2). But I wanted to test the actual ISP connections between Site-A and Site-B without installing the PC at Site-B. Both PCs will be installed at Site-A.
I can use the same setup to test between Site-A and any site out there that I have configuration control over the remote router. Of course, I don't have any configuration control over the ISP equipment but they are routing the networks I tell them via BGP.
I have look at GRE and VRF, but can't seem to make them work.
Thanks.
01-11-2016 09:48 PM
Can you not plug a PC into site 'b'? Even a spare port on the router and use NAT?
I think this could skew your results quite a bit because of the CPU load. Try creating two GRE tunnels between router A and B. Make sure you specify a tunnel key so the routers can tell them apart.
Router B is the easy one. Something like:
Tunnel0
ip address 192.168.0.10 255.255.255.252
tunnel source ...
tunnel destination ...
tunnel key 0
Tunnel1
ip address 192.168.0.14 255.255.255.252
tunnel source ...
tunnel destination ...
tunnel key 1
ip route 192.168.0.0 255.255.255.252 192.168.0.9
ip route 192.168.4.0 255.255.255.252 192.168.0.13
Router A needs a bit more work. Lets pretend the PC's are on gig0/0 and gig0/1. Create two VRF's.
ip vrf A
ip vrf B
interface Gigabit0/0
ip vrf forwarding A
ip address 192.168.0.1 255.255.255.252
interface Gigabit0/1
ip vrf forwarding B
ip address 192.168.0.5 255.255.255.252
Tunnel0
ip vrf forwarding A
ip address 192.168.0.9 255.255.255.252
tunnel source ...
tunnel destination ...
tunnel key 0
Tunnel1
ip vrf forwarding B
ip address 192.168.0.13 255.255.255.252
tunnel source ...
tunnel destination ...
tunnel key 1
ip route vrf A 192.168.0.4 255.255.255.252 192.168.0.10
ip route vrf B 192.168.0.0 255.255.255.252 192.168.0.14
Give PC A the IP address 192.168.0.2/255.255.255.252 (GW=192.168.0.1) and PC B 192.168.0.6/255.255.255.252 (GW=192.168.0.5).
If you have it right, PC A and PC B should now be able to ping each other, going via the remote site.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide