cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1960
Views
10
Helpful
5
Replies

BGP is not getting up useing default route

saibal_maji
Level 1
Level 1

R1-----R2 

I want to create a ebgp  session in between these two router with Loopback

configuration R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.0.0.2 255.255.255.252
duplex auto
speed auto

router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 12.0.0.1

Configuration of R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.0.0.1 255.255.255.252
duplex auto
speed auto

router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 12.0.0.2
!

I am able to ping loopback of both router from other.

But BGP session is not getting up.

Please help me to find the reason

5 Replies 5

Rolf Fischer
Level 9
Level 9

Hi,

from the neighbor ebgp-multihop Command Reference (Usage Guidelines) :

To prevent the creation of loops through oscillating routes, the multihop will not be established if the only route to the multihop peer is the default route (0.0.0.0).

Just add two hostroutes for the loopback-connectivity (or enable an IGP) and the eBGP-session will come up immediately.

HTH
Rolf

I don't understand the reason , can you please elaborate the Reason.

Just add two hostroutes for the loopback-connectivity and the eBGP-session will come up immediately.

To be more precise: A BGP speaker doesn't initiate a session when the only routing information to the neighbor is the default route. So a more specific route on one router would actually be enough. By the way, this check is only performed when establishing a session; you could even remove the more specific route once the peering is done.

I found a blog saying that this check is defined in RFC 4271 but I couldn't find the paragraph(s) so far.

However, you rarely would configure eBGP peers with default-routes pointing to each other in a real environment, right?

Perhaps one of the BGP experts here at CSC can provide a better answer.

Hello

i agree - the bgp peering as I see it is  client-server establishment  thus either peer needs to be able have a definative  route towards the other to initiate and establish a Bgp session and having two defaults won't work 

cco documentation states this is due to incurring possible route flaps and routing loops

So in this case I guess if you have just apply one host route on any of the peers that the bgp session should establish.

Res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Great tip! I tried it and the bgp session got established right away as soon as I configure one definitive host route on one of the two routers. Thanks a lot
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: