cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
848
Views
0
Helpful
1
Replies

BGP Lapping

jennytong
Level 1
Level 1

Hi Tech friends,

I have struggled this question for a long time. Can you guys help me with that?

Problem 1: the ebgp connection between R2 and R7 is up and down a lot

Problem 2: I cannot use R1 to learn all the route of R7 and R8

Really appreciate your help~

q.PNGHere is my configuration:

R1:

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1
!
boot-start-marker
boot-end-marker
!
!
vrf definition acme
rd 1:1100
route-target export 1:1100
route-target import 1:1100
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
!
!
!
ip vrf mgmt
rd 1:1000
route-target export 1:1000
route-target import 1:1000
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip vrf forwarding mgmt
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Ethernet1/0
vrf forwarding acme
ip address 172.16.12.1 255.255.255.0
duplex half
!
interface Ethernet1/1
no ip address
shutdown
duplex half
!
interface Ethernet1/2
no ip address
shutdown
duplex half
!
interface Ethernet1/3
no ip address
shutdown
duplex half
!
interface Ethernet1/4
no ip address
shutdown
duplex half
!
interface Ethernet1/5
no ip address
shutdown
duplex half
!
interface Ethernet1/6
no ip address
shutdown
duplex half
!
interface Ethernet1/7
no ip address
shutdown
duplex half
!
router bgp 27
bgp always-compare-med
bgp log-neighbor-changes
timers bgp 10 30
!
address-family ipv4 vrf acme
redistribute connected
neighbor 172.16.12.2 remote-as 27
neighbor 172.16.12.2 activate
neighbor 172.16.12.2 send-community both
neighbor 172.16.12.2 soft-reconfiguration inbound
exit-address-family
!
address-family ipv4 vrf mgmt
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
mgcp profile default
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
transport input all
!
!
end

 

R2:

version 15.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service counters max age 5
no service dhcp
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
vrf definition acme
rd 1:1100
route-target export 1:1100
route-target import 1:1100
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
!
!
!
ip vrf mgmt
rd 1:1000
route-target export 1:1000
route-target import 1:1000
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
mpls label range 16 1048575
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip vrf forwarding mgmt
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Ethernet1/0
description connection to R7 the first
ip address 10.23.0.2 255.255.255.0
duplex full
mpls bgp forwarding
mpls ip
!
interface Ethernet1/1
description connection to R7 the second
ip address 10.24.0.2 255.255.255.0
duplex full
mpls bgp forwarding
mpls ip
!
interface Ethernet1/2
description connection to R1
vrf forwarding acme
ip address 172.16.12.2 255.255.255.0
duplex half
!
interface Ethernet1/3
description connection to R3
vrf forwarding acme
ip address 156.16.12.2 255.255.255.0
duplex half
!
interface Ethernet1/4
no ip address
shutdown
duplex half
!
interface Ethernet1/5
no ip address
shutdown
duplex half
!
interface Ethernet1/6
no ip address
shutdown
duplex half
!
interface Ethernet1/7
no ip address
shutdown
duplex half
!
!
router eigrp 27
network 2.2.2.2 0.0.0.0
network 10.23.0.0 0.0.255.255
network 10.24.0.0 0.0.255.255
passive-interface default
no passive-interface Ethernet1/0
no passive-interface Ethernet1/1
!
router bgp 27
bgp router-id 2.2.2.2
bgp always-compare-med
bgp log-neighbor-changes
neighbor 7.7.7.7 remote-as 28
neighbor 7.7.7.7 ebgp-multihop 2
neighbor 7.7.7.7 update-source Loopback0
!
address-family ipv4
redistribute connected
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community both
neighbor 7.7.7.7 soft-reconfiguration inbound
neighbor 7.7.7.7 send-label
exit-address-family
!
address-family vpnv4
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 send-community both
exit-address-family
!
address-family ipv4 vrf acme
redistribute connected
neighbor PEER1 peer-group
neighbor PEER1 remote-as 26
neighbor PEER1 ebgp-multihop 2
neighbor PEER1 send-community both
neighbor PEER1 next-hop-self
neighbor PEER1 allowas-in
neighbor PEER1 soft-reconfiguration inbound
neighbor PEER2 peer-group
neighbor PEER2 remote-as 27
neighbor PEER2 send-community both
neighbor PEER2 next-hop-self
neighbor PEER2 soft-reconfiguration inbound
neighbor 156.16.12.1 peer-group PEER1
neighbor 156.16.12.1 activate
neighbor 172.16.12.1 peer-group PEER2
neighbor 172.16.12.1 activate
exit-address-family
!
address-family ipv4 vrf mgmt
redistribute connected
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
mgcp profile default
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
transport input all
!
!
end

 

R7:

version 15.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service counters max age 5
no service dhcp
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
vrf definition acme
rd 110:110
route-target export 110:110
route-target import 110:110
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
!
!
!
ip vrf mgmt
rd 1:1000
route-target export 1:1000
route-target import 1:1000
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
mpls label range 16 1048575
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description global loopback
ip address 7.7.7.7 255.255.255.255
!
interface Loopback1
description management loopback
ip vrf forwarding mgmt
ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Ethernet1/0
ip address 10.23.0.1 255.255.255.0
duplex full
mpls bgp forwarding
mpls ip
!
interface Ethernet1/1
ip address 10.24.0.1 255.255.255.0
duplex full
mpls bgp forwarding
mpls ip
!
interface Ethernet1/2
vrf forwarding acme
ip address 192.168.78.7 255.255.255.0
duplex half
!
interface Ethernet1/3
vrf forwarding acme
ip address 111.1.1.1 255.255.255.0
duplex half
!
interface Ethernet1/4
no ip address
shutdown
duplex half
!
interface Ethernet1/5
no ip address
shutdown
duplex half
!
interface Ethernet1/6
no ip address
shutdown
duplex half
!
interface Ethernet1/7
no ip address
shutdown
duplex half
!
!
router eigrp 27
network 7.7.7.7 0.0.0.0
network 10.23.0.0 0.0.255.255
network 10.24.0.0 0.0.255.255
passive-interface default
no passive-interface Ethernet1/0
no passive-interface Ethernet1/1
!
router ospf 2
network 111.0.0.0 0.255.255.255 area 0
!
router bgp 28
bgp router-id 7.7.7.7
bgp always-compare-med
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 27
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
!
address-family ipv4
redistribute connected
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 2.2.2.2 soft-reconfiguration inbound
neighbor 2.2.2.2 send-label
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf acme
redistribute connected
neighbor PEER3 peer-group
neighbor PEER3 remote-as 28
neighbor PEER3 send-community both
neighbor PEER3 next-hop-self
neighbor PEER3 soft-reconfiguration inbound
neighbor 192.168.78.8 peer-group PEER3
neighbor 192.168.78.8 activate
exit-address-family
!
address-family ipv4 vrf mgmt
redistribute connected
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 7.7.7.77
ip route 7.7.7.7 255.255.255.255 2.2.2.2
ip route 7.7.7.7 255.255.255.255 10.23.0.2
!
!
!
!
control-plane
!
!
!
mgcp profile default
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
transport input all
!
end

 

R8:

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8
boot-start-marker
boot-end-marker
!
!
vrf definition acme
rd 1:1100
route-target export 1:1100
route-target import 1:1100
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
!
!
!
ip vrf mgmt
rd 1:1000
route-target export 1:1000
route-target import 1:1000
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
!
interface Loopback1
ip vrf forwarding mgmt
ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Ethernet1/0
vrf forwarding acme
ip address 192.168.78.8 255.255.255.0
duplex half
!
interface Ethernet1/1
no ip address
shutdown
duplex half
!
interface Ethernet1/2
no ip address
shutdown
duplex half
!
interface Ethernet1/3
no ip address
shutdown
duplex half
!
interface Ethernet1/4
no ip address
shutdown
duplex half
!
interface Ethernet1/5
no ip address
shutdown
duplex half
!
interface Ethernet1/6
no ip address
shutdown
duplex half
!
interface Ethernet1/7
no ip address
shutdown
duplex half
!
router bgp 28
bgp always-compare-med
bgp log-neighbor-changes
timers bgp 10 30
!
address-family ipv4 vrf acme
redistribute connected
neighbor 192.168.78.7 remote-as 28
neighbor 192.168.78.7 activate
neighbor 192.168.78.7 send-community both
neighbor 192.168.78.7 soft-reconfiguration inbound
exit-address-family
!
address-family ipv4 vrf mgmt
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
mgcp profile default
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
transport input all
!
!
end

1 Reply 1

tellis002
Spotlight
Spotlight

I'm not sure overall what you are asking, but I think you are asking due to the ebgp session between router 2 and router 7 going up and down, you want to fail over to the link between router 7 <--> router 3.  Taking a glance at it, you are not redistributing any BGP routes into OSPF on Router 7.  So even if everything else is correct, R3 will never receive and/or pass on routes that R7 is aware of via BGP.  

Review Cisco Networking for a $25 gift card