cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
706
Views
0
Helpful
3
Replies

BGP Query

drikilbride
Level 1
Level 1

Hi

I have an MPLS connection with two Cisco 877 routers on either end.

I believe I need to use BGP to link the two networks on either end.

Site A - 10.255.0.0

Site B - 192.168.14.0

Do I just need to add the line network 10.255.0.0 mask 255.255.0.0 on the router on Site B and network 192.168.14.0 mask 255.255.255.0 on the router on site A so I can ping between the two networks?

At the moment the two routers can ping each other's circuit address. I just need to know how to ping past the external IP address internally.

Thanks a mil

1 Accepted Solution

Accepted Solutions

Collin Clark
VIP Alumni
VIP Alumni

You do not add the network statement of the network you want to reach under the BGP configuration. The network you do want to add is the network you will be advertising from that particular location.

interface Vlan1
ip address 192.168.14.130 255.255.255.0
!
router bgp 65500
no synchronization
bgp log-neighbor-changes
network 10.0.0.0 mask 255.255.0.0
network 192.168.14.0 mask 255.255.255.0

  neighbor 83.70.100.241 remote-as 5466
no auto-summary

View solution in original post

3 Replies 3

Collin Clark
VIP Alumni
VIP Alumni

You do not add the network statement of the network you want to reach under the BGP configuration. The network you do want to add is the network you will be advertising from that particular location.

interface Vlan1
ip address 192.168.14.130 255.255.255.0
!
router bgp 65500
no synchronization
bgp log-neighbor-changes
network 10.0.0.0 mask 255.255.0.0
network 192.168.14.0 mask 255.255.255.0

  neighbor 83.70.100.241 remote-as 5466
no auto-summary

Thanks a mil! That was exactly it!

Richard Burts
Hall of Fame
Hall of Fame

I am assuming that you have communicated with your provider about MPLS and about running BGP and my answers are based on this assumption. I also assume that the parts of the BGP configuration in the config files that you posted are based on advice from the provider (especially use of AS numbers etc).

In the config of siteA you already have this network statement:

network 192.168.14.0

you should remove it and replace it with the

network 10.255.0.0 mask 255.255.0.0

statement.

In the config of siteB you already have this network statement

network 10.0.0.0 mask 255.255.0.0

you should remove it and replace it with the

network 192.168.14.0 mask 255.255.255.0

statement.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card