cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
629
Views
0
Helpful
10
Replies
Highlighted
Beginner

Big trouble with Multicast! Please help!

I have a 5915 router.  Trying to configure multicast to pass.  I have implemented different version of the configuration, but the attached is the latest and suggest by CCIE support.  I have a Java program on one side of the router that pulls the multicast traffic fromt he other side of the router.  The data is not getting to the java program with this configuration.  I have been working on this for a week and unable to see anything.  Wireshark doesn't see the traffic.  In the attached config, I have also included some stats....

I am up against a deadline now and holding up the project.  Any help anyone can provide would be greatly appreciated.

Tracey                  

hostname HPIB-Rtr
!
boot-start-marker
boot system flash:C5915-ADVENTERPRISEK9-MZ.SPA.152-1.GC.BIN
boot-end-marker
!
!
!
no aaa new-model
crypto pki token default removal timeout 0
!
!
!
!
!

!
ip multicast-routing
ip cef
no ipv6 cef
!
multilink bundle-name authenticated

interface Loopback0
ip address 10.10.1.3 255.255.255.255
ip pim sparse-mode
!
interface Loopback100
ip address 192.168.3.1 255.255.255.0
ip pim sparse-mode
ip igmp static-group 239.255.10.10
!
interface FastEthernet0/0
ip address 172.30.255.1 255.240.0.0
ip pim sparse-mode
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/2
switchport access vlan 10
no ip address
!
interface FastEthernet0/3
switchport access vlan 10
no ip address
!
interface FastEthernet0/4
switchport access vlan 10
no ip address
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.64.3.3 255.255.0.0
ip pim sparse-mode
ip nat inside
ip virtual-reassembly in
!
router ospf 10
network 172.16.0.0 0.15.255.255 area 0
network 192.168.3.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip pim bidir-enable
ip pim rp-address 10.10.1.3 1
ip nat inside source static 10.64.3.11 172.30.255.11
ip nat inside source static 10.64.3.12 172.30.255.12
ip nat inside source static 10.64.3.1 172.30.255.101
ip nat inside source static 10.64.3.2 172.30.255.102
ip nat inside source static 10.64.70.1 172.30.255.171
ip nat inside source static 10.64.70.2 172.30.255.172
ip nat inside source static 10.64.70.11 172.30.255.173
ip nat inside source static 10.64.70.12 172.30.255.174
!
access-list 1 permit 239.255.10.10
access-list 1 permit 239.255.20.20
access-list 7 permit 10.64.0.0 0.0.255.255

control-plane
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!

10 REPLIES 10
Highlighted
Hall of Fame Master

Hello Tracey,

a) first of all, I would use the command

ip pim rp-address 10.10.1.3

instead of ip im rp-address 10.10.1.3 1

so whatever multicast addess is used by the Java program the RP will be there.

b)  check with a packet capture on the source LAN that IP TTL of packets sent by the Java program is greater then 1, otherwise the traffic cannot be routed to another router interface

Many times software that sends multicast traffic defaults to TTL=1 and needs to be tuned.

Hope to help

Giuseppe

Highlighted

TTL on both sides is greater than 1.  Source side is 5 and other side is either 2 or 3 depending on the requester.

Good idea, you have anything else????? Please, Pelase, Please!

Highlighted

Oddly enough, while checking something else, we saw 2 lines come up on wireshark and then stop.  Just a blib.  Not sure how or why if I can't get it to work continuely.

Highlighted

Hello Tracey,

try to move the following command

ip igmp static-group 239.255.10.10

under the LAN interface towards the wireshark packet analyzer. This way should work.

Hope to help

Giuseppe

Highlighted

I have moved the line to the other 2 interfaces just to try and still not seeing the data. 

Judging by your suggestions, the configuration seem to be right in your eyes???

Tracey

Highlighted

Hello Tracey,

you need to configure the command on a L3 interface not a switchport.

What is the L3 interface the traffic is received on?

I wonder if NAT configuration can interfer with multicast here.

you may try to remove the NAT commands from the L3 interfaces for a moment

WARNING: do it only if you are not going to lose connectivity to the router

Hope to help

Giuseppe

Highlighted

This is a 5915.  I only have 2 router interfaces, F0/0 and F0/1 (not in use) and 3 switch ports.  To accommodate multiple conenctions, I made vlan 10 and put the f0/2 and f0/3 into that vlan.

I did apply the line to interface F0/0 and was still not successful.

Any other suggestions????

I can take off the NAT and see what happens.  Why not at this point!

Highlighted

hello
Remove the acl from the static rp address for now
Make sure all router in the multicast path have reach ability to the rp address

On the last of hop router (this will be the furthest from source)

show ip igmp groups
show ip pim interface count
show ip pim rp mapping
Sh ip mroute

On first hop ( closest to source)

Sh ip mroute
show ip mroute active

Res
Paul








Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Contributor

Does your network require the use of SSM (source specific multicast)? If so, you need to define your common RP, and either do dns or static SSM mappings.

I can get you a working config example when I get back to work if needed.


Highlighted
Beginner

I can tell you that we learned a lot about Multicast in these past 3 weeks and we finally have it running the way we need it to run.

First lesson learned is that we did not understand RP correctly in the beginning.   We now understand, RP is just a meeting place and my router in this project, is not the RP, it is the source of the multicast.  Therefore a RP on my router was not needed in our configuration.

Second lesson is that in Multicast a tunnel will be dynamically created.  The IP address of that tunnel is important in the passing of the multicast.  In the anomalies that we were seeing last week, the tunnel was taking the outside interface IP which was incorrect.  We have added "ip pim register-source [source interface]"  to always be the inside interface (Vlan 10), and it is working consistently, even after reboots of different equipment and in different order.

Below is our config.  It is not the final config as we need to apply some security measures, but for now, we know this works!

Again thank you for all  your help and time!

ip multicast-routing

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

interface FastEthernet0/0

ip address 172.30.255.1 255.240.0.0

ip pim sparse-mode

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

interface FastEthernet0/2

switchport access vlan 10

no ip address

!

interface FastEthernet0/3

switchport access vlan 10

no ip address

interface Vlan10

ip address 10.64.3.3 255.255.0.0

ip pim sparse-mode

ip nat inside

ip virtual-reassembly in

!

router ospf 10

network 10.64.0.0 0.0.255.255 area 0

network 172.16.0.0 0.15.255.255 area 0

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip pim register-source Vlan10

ip nat inside source static 10.64.70.1 172.30.0.1

ip nat inside source static 10.64.70.2 172.30.0.2

ip nat inside source static 10.64.70.11 172.30.0.11

ip nat inside source static 10.64.70.12 172.30.0.12

ip nat inside source static 10.64.70.21 172.30.0.21

ip nat inside source static 10.64.70.22 172.30.0.22

ip nat inside source static 10.64.3.1 172.30.3.1

ip nat inside source static 10.64.3.2 172.30.3.2

ip nat inside source static 10.64.3.11 172.30.3.11

ip nat inside source static 10.64.3.12 172.30.3.12