cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
613
Views
0
Helpful
8
Replies

Can't ping two points on Multi area Ospf

StolenSkills
Beginner
Beginner

Doing a project for my job interview,

one of my goals is to connect everything using different technologies,

I did multi area OSPF here with a back bone and all

R4 and R0 connect well to R2,R5,R6 and R6 connect to R4 and R0

The problem is with R3 and R7

They connect well inside of the their area, R3 pings R0,R4,R1 and R7 pings R6 and R5

but both of them cant ping outside their of their area.

 

here is the commands :

for R3:

 

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.111

encapsulation dot1Q 111

ip address 172.17.111.254 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 10.17.12.9 255.255.255.252

!

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/2/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/3/0

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 10

router-id 1.1.1.1

log-adjacency-changes

passive-interface FastEthernet0/0

network 10.17.111.0 0.0.0.255 area 22

network 10.17.12.8 0.0.0.3 area 22

 

for R7:

 

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.45

encapsulation dot1Q 45

ip address 10.17.45.253 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/0/0

ip address 10.17.12.22 255.255.255.252

clock rate 2000000

!

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/2/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/3/0

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 10

router-id 2.2.2.1

log-adjacency-changes

passive-interface FastEthernet0/0

network 10.17.45.0 0.0.0.255 area 10

network 10.17.12.20 0.0.0.3 area 10

 

 

 

 

Untitled.png

 

 

1 Accepted Solution

Accepted Solutions

You need to reload both routers after removing that line...

 

Install version 8, that is always (backwards) compatible with all earlier versions...

View solution in original post

8 Replies 8

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

it is difficult to see what the ABRs are for the given areas. Post the zipped Packet Tracer project (.pkt) file...

Its not done and alot of configuration haven't been done yet,so focus on the ospf for now

Hello,

 

the problem were the lines marked in bold. These lines made all interfaces part of the backbone area as well, which is incorrect. After removing these statements I could ping from anywhere to anywhere...

 

Attached the working file with end to end connectivity...

 

R5

router ospf 10
router-id 2.2.2.3
log-adjacency-changes
passive-interface FastEthernet0/0
network 10.17.132.0 0.0.0.255 area 10
network 10.17.12.16 0.0.0.3 area 10
network 10.17.0.0 0.0.255.255 area 0
network 192.168.10.4 0.0.0.3 area 0

 

R1

router ospf 10
router-id 1.1.1.4
log-adjacency-changes
passive-interface FastEthernet0/0
network 10.17.12.12 0.0.0.3 area 22
network 10.17.12.0 0.0.0.3 area 22
network 10.17.21.0 0.0.0.255 area 22
network 10.17.143.0 0.0.0.255 area 22
network 10.17.0.0 0.0.255.255 area 0
network 172.17.111.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0

Can you explain why? From what I remember you need to to give the addresses to the backbone in order to connect the two different areas

 

Hello,

 

one interface cannot be part of two areas. Typically, on an ABR, only the interface connected to the backbone is member of area 0.

I removed both of those myself and they still can't Ping, why?

And your Packet tracer version is not comptable with mine So I cannot look into your file

You need to reload both routers after removing that line...

 

Install version 8, that is always (backwards) compatible with all earlier versions...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers