cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
453
Views
0
Helpful
2
Replies
sjkoehler
Beginner

Cisco 1760 w/WIC-1ADSL: Interruptions, drops

I currently have a Cisco 1760 installed with a WIC-1ADSL connected to AT&T ADSL line.  Thanks to this board, we have been able to get everything up and running.  I know my config may be a bit 'dirty' but it works.  It is our intent to establish a VPN in the near future, so some of the configuration remains (expecting to complete an IOS update for VPN fuctionality).

THE PROBLEM: I am unable to initiate/complete downloads reliably (especially larger files >2MB).  Normally it will download the first few MB and then it just stops and does not resume.  I have noticed this in itunes, Outlook, Internet Explorer, Chrome, et al.

I want to figure out why my connection seems to be interrupted or dropping with no symptoms appearing other than when I attempt to download files.

ROUTER VERSION


Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-ADVENTERPRISEK9-M), Version 12.3(9c), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Wed 01-Dec-04 01:13 by kellythw
Image text-base: 0x80008120, data-base: 0x8190696C

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

KOEHLER-ROUTER uptime is 14 hours, 21 minutes
System returned to ROM by power-on
System restarted at 17:37:01 UTC Tue Jun 21 2011
System image file is "flash:c1700-adventerprisek9-mz.123-9c.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco 1760 (MPC860P) processor (revision 0x500) with 87493K/10811K bytes of memory.
Processor board ID FOC0729171W (1641138353), with hardware revision 0000
MPC860P processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
1 Virtual Private Network (VPN) Module(s)
32K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

DSL INTERFACE

Alcatel 20150 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ANSI T1.413
ANSI Issue/rev:  2/1                             2/1
Vendor ID:       0x0022                          0x0022
Capacity Used:   78%                             85%
Noise Margin:    11.5 dB                         11.0 dB
Output Power:    16.0 dBm                        12.0 dBm
Attenuation:     28.0 dB                         21.5 dB
Defect Status:   None                            None
Last Fail Code:  None
Selftest Result: 0x00
Subfunction:     0x15
Interrupts:      1331 (0 spurious)
PHY Access Err:  0
Activations:     1
Init FW:         embedded
Operation FW:    embedded
SW Version:      3.8131
FW Version:      0x1A04

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          6016                0           768                 0
Reed-Solomon EC:         12                0             5                 0
CRC Errors:               0                0             0                 0
Header Errors:            0                0             0                 0
Bit Errors:               0                0
BER Valid sec:        51651                0
BER Invalid sec:          0                0

DMT Bits Per Bin
00: 0 0 0 0 0 0 0 7 7 8 9 A B B C C
10: C B A B B B B B B A A 9 9 8 0 0
20: 0 0 0 0 0 0 2 2 2 2 3 3 4 4 4 4
30: 5 5 6 6 7 7 7 8 8 8 8 9 9 9 9 9
40: A A A A A A B B A 2 B B B B B B
50: B B B C C C C C C B C C C C C C
60: C C C C C C C B B B B A B B B B
70: B B B B B A A A A A A A A A A A
80: A A A A A A A A A A 9 9 9 9 9 9
90: 9 9 9 9 8 8 8 8 8 8 8 8 7 7 6 7
A0: 7 6 6 6 6 6 7 7 7 7 7 7 7 7 7 7
B0: 4 6 7 7 7 7 7 7 7 7 6 6 6 6 5 5
C0: 6 6 6 6 7 7 7 7 7 7 8 8 8 8 8 8
D0: 8 8 8 7 8 8 8 8 8 7 7 7 5 6 6 6
E0: 6 6 5 4 4 4 4 4 4 5 5 6 6 6 6 6
F0: 7 6 7 7 7 7 7 7 6 6 6 5 5 4 4 3

DSL: Training log buffer capability is not enabled

ATM INTERFACE

ATM1/0 is up, line protocol is up
  Hardware is DSLSAR (with Alcatel ADSL Module)
  Description: adsl wan int
  MTU 4470 bytes, sub MTU 4470, BW 768 Kbit, DLY 2660 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  23 maximum active VCs, 256 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input 14:09:08, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/224/0/0 (size/max/drops/flushes); Total output drops: 1288
  Queueing strategy: Per VC Queueing
  5 minute input rate 6000 bits/sec, 2 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     382495 packets input, 441889688 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 42 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     364367 packets output, 48310789 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out

DIALER INTERFACE

Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Description: adsl WAN Dialer$FW_OUTSIDE$
  Internet address is 76.226.113.143/32
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi1
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 14:10:09
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     382516 packets input, 428886527 bytes
     365677 packets output, 38006297 bytes
Bound to:
Virtual-Access1 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1500 bytes, BW 56 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP
  PPPoE vaccess, cloned from Dialer1
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di1 (Encapsulation PPP)
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters 14:09:34
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     382523 packets input, 428886622 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     365684 packets output, 38006426 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

CONFIGURATION

Current configuration : 4918 bytes
!
! Last configuration change at 17:58:40 UTC Tue Jun 21 2011
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname KOEHLER-ROUTER
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable password Blair01
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.10.9.1 10.10.9.99
!
ip dhcp pool koehler-dhcp
   network 10.10.9.0 255.255.255.0
   dns-server 8.26.56.26 8.20.247.20
   default-router 10.10.9.1
   domain-name cygnus.com
!
ip domain name cygnus.com
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp
ip inspect name SDM_LOW udp
ip inspect name SDM_LOW vdolive
ip audit po max-events 100
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key [OMITTED] address [OMITTED]
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto map SDM_CMAP_1 1 ipsec-isakmp
description Tunnel [OMITTED]
set peer [OMITTED]
set transform-set ESP-3DES-SHA
match address 100
!
!
!
!
interface Ethernet0/0
description $ETH-WAN$
ip address dhcp client-id Ethernet0/0
no ip proxy-arp
shutdown
half-duplex
!
interface FastEthernet0/0
description $FW_INSIDE$
ip address 10.10.9.1 255.255.255.0
ip access-group 102 in
ip nat inside
speed auto
!
interface ATM1/0
description adsl wan int
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
pvc 0/35
  pppoe-client dial-pool-number 1
!
!
interface Dialer1
description adsl WAN Dialer$FW_OUTSIDE$
ip address negotiated
ip access-group 104 in
no ip unreachables
ip mtu 1492
ip nat outside
ip inspect SDM_LOW out
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname [OMITTED]

ppp chap password 0 [OMITTED]
ppp pap sent-username [OMITTED] password 0 [OMITTED]
ppp ipcp address accept
crypto map SDM_CMAP_1
!
ip nat inside source route-map SDM_RMAP_2 interface Dialer1 overload
no ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
ip http server
ip http secure-server
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.9.0 0.0.0.255
access-list 2 remark SDM_ACL Category=2
access-list 2 permit 10.10.9.0 0.0.0.255
access-list 100 remark SDM_ACL Category=4
access-list 100 remark IPSec Rule
access-list 100 permit ip 10.10.9.0 0.0.0.255 10.10.0.0 0.0.255.255
access-list 101 remark SDM_ACL Category=2
access-list 101 remark IPSec Rule
access-list 101 deny   ip 10.10.9.0 0.0.0.255 10.10.0.0 0.0.255.255
access-list 101 permit ip 10.10.9.0 0.0.0.255 any
access-list 102 remark auto generated by SDM firewall configuration
access-list 102 remark SDM_ACL Category=1
access-list 102 deny   ip host 255.255.255.255 any
access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark SDM_ACL Category=2
access-list 103 remark IPSec Rule
access-list 103 deny   ip 10.10.9.0 0.0.0.255 10.10.0.0 0.0.255.255
access-list 103 permit ip 10.10.9.0 0.0.0.255 any
access-list 104 remark auto generated by SDM firewall configuration
access-list 104 remark SDM_ACL Category=1
access-list 104 permit ahp host 70.90.136.53 any
access-list 104 permit esp host 70.90.136.53 any
access-list 104 permit udp host 70.90.136.53 any eq isakmp
access-list 104 permit udp host 70.90.136.53 any eq non500-isakmp
access-list 104 remark IPSec Rule
access-list 104 permit ip 10.10.0.0 0.0.255.255 10.10.9.0 0.0.0.255
access-list 104 deny   ip 10.10.9.0 0.0.0.255 any
access-list 104 permit icmp any any echo-reply
access-list 104 permit icmp any any time-exceeded
access-list 104 permit icmp any any unreachable
access-list 104 deny   ip 10.0.0.0 0.255.255.255 any
access-list 104 deny   ip 172.16.0.0 0.15.255.255 any
access-list 104 deny   ip 192.168.0.0 0.0.255.255 any
access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
access-list 104 deny   ip host 255.255.255.255 any
access-list 104 deny   ip host 0.0.0.0 any
access-list 104 deny   ip any any log
dialer-list 1 protocol ip permit
!
route-map SDM_RMAP_1 permit 1
match ip address 101
!
route-map SDM_RMAP_2 permit 1
match ip address 103
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
no login
line vty 5 14
no login
!
end

2 REPLIES 2
sjkoehler
Beginner

It has been determined that the problem was being caused by the firewall.  All works fine when firewall is disabled.  However, no amount of adjusting configuration of the firewall works.

I have cisco 1760 and Alcatel 20150 chipset ADSL modem installed, But ADSL interface not bring up. Airtel service provider said that this configuration looks ok. There is compatibility issue with CISCO router modem ADSL and Provider side ADSL2. 

Looking for solution to bring up ATM interface. 

 

Current status of interface and configuration:-

 

Interface status:

sh interfaces atm 0/0
ATM0/0 is initializing, line protocol is down
  Hardware is DSLSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 1024 Kbit/sec, DLY 500 usec,
     reliability 0/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  23 maximum active VCs, 256 VCs per VP, 0 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/224/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

 

sh interfaces atm 0/0.1
ATM0/0.1 is initializing, line protocol is down
  Hardware is DSLSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, BW 1024 Kbit/sec, DLY 500 usec,
     reliability 0/255, txload 1/255, rxload 1/255
  Encapsulation ATM
     0 packets input, 0 bytes
     0 packets output, 0 bytes
     0 OAM cells input, 0 OAM cells output
  AAL5 CRC errors : 0
  AAL5 SAR Timeouts : 0
  AAL5 Oversized SDUs : 0
  Last clearing of "show interface" counters never

 

 

 

sh dsl interface
ATM0/0
Alcatel 20150 chipset information

Line has not yet been activated.

Modem Status:    Down (DMTDSL_DO_OPEN)
DSL Mode:        Unknown
Interrupts:      27686077 (0 spurious)
PHY Access Err:  0
Activations:     0
LED Status:      OFF
LED On Time:     100
LED Off Time:    100
Init FW:         ASW_init_3_8_131.bin
Operation FW:    ASW_R3_8_131.bin
FW Source:       embedded

Training log collection is in progress and is not yet completed.

 

Cisco Router ADSL configuration:-

interface ATM0/0

 no ip address

 no atm ilmi-keepalive

 bundle-enable

 dsl operating-mode splitterless

 dsl enable-training-log

 hold-queue 224 in

end

 

 

ahmEdgeA#sh run int atm 0/0.1

Building configuration...

 

Current configuration : 106 bytes

!

interface ATM0/0.1 point-to-point

 no snmp trap link-status

 pvc 1/32

  encapsulation aal5snap

 !

end

 

 

 

interface Dialer1

 mtu 1492

 ip address x.x.x.x 255.255.255.0

 ip nat outside

 ip virtual-reassembly

 encapsulation ppp

 ip tcp adjust-mss 1452

 dialer pool 1

 dialer-group 1

end