cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3015
Views
20
Helpful
13
Replies

Cisco 1841 Router Configuration for BT DSL Modem

Mark Hopewell
Beginner
Beginner

Hello,

I've stopped off half way through ICND1 to try some 'Home Lab' work, here in the UK. I wanted to use some of the commands learnt so far.

I've tried to get my 1841 router to connect directly to the LAN 1 port on my BT DSL Modem (Model ECI Telecom B-Focus V-2FUb/r Rev B) over an Ethernet cable, through FastEthernet0/0 on the 1841. However, I'm unable to get any connection which results in being able to browse web pages on my PC.

I'd hoped to be able to configure the router to act as a gateway to a home LAN. For the moment though, I want to use the output from the 1841 FastEthernet0/1 to connect to my main PC, for test/learning purposes.

The script I've tried to write (see below) is pulled together from various sources, whilst I try to get around some of the commands to fail to work on the IOS running on my 1841. The version of IOS I am using is as follows:-

1841 Software (C1841-ADVENTERPRISEK9-M), Version 15.1(4)M7, RELEASE SOFTWARE (fc2)

For example, 'protocol pppoe' is one of the commands missing from the version of IOS I'm using.

I'm using TeraTerm and the Console port of the 1841 to enter the script into the 1841.

No doubt anyone reading my script will be disappointed as I am showing my lack of knowledge (some may say naïve) at this point in my studies. I apologise about this. However, I've tried my best in the circumstances and needless to say, I'm embarrassed by it.

If anyone can shed light on how to get this connection to work, or where I should look for more information and learning opportunities, I shall be very grateful for your time and advice.

Thank you,

Mark

================================================================
Enter Privileged Mode
================================================================
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
================================================================
Give Router aHOSTNAME -> 'R1'
================================================================
Router(config)#hostname R1
================================================================
Make BT WAN INTERFACE FastEthernet0/0
================================================================
Router(config)#interface FastEthernet0/0
Router(config-if)#description BT WAN INTERFACE
Router(config-if)#no ip address
Router(config-if)#duplex auto
Router(config-if)#speed auto
================================================================
Make PPPOE-CLIENT DIAL POOL
================================================================
Router(config-if)#pppoe-client dial-pool-number 1
Router(config-if)#no cdp enable
Router(config-if)#no routing dynamic
================================================================
Make DIALLER1 INTERFACE
================================================================
Router(config-if)#interface Dialer1
Router(config-if)#ip address negotiated
Router(config-if)#no ip unreachables
Router(config-if)#ip mtu 1452
Router(config-if)#ip nat outside
Router(config-if)#ip virtual-reassembly in
Router(config-if)#encapsulation ppp
Router(config-if)#dialer pool 1
Router(config-if)#dialer-group 1
Router(config-if)#ppp authentication chap callin
Router(config-if)#ppp chap hostname bthomehub@btbroadband.com
Router(config-if)#ppp chap password 0 4567
Router(config-if)#no cdp enable
Router(config-if)#exit
Router(config)#ip access-list extended NAT
Router(config-ext-nacl)#permit ip 10.0.0.0 0.0.0.255 any
Router(config-ext-nacl)#exit
Router(config)#route-map NAT permit 1
Router(config-route-map)#match ip address NAT
Router(config-route-map)#exit
Router(config)#ip nat inside source route-map NAT interface Dialer1 overload
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 1
Router(config)#exit
================================================================
Make HOME LAN INTERFACE - FastEthernet0/1
================================================================
Router#interface FastEthernet0/1
Router#(config-if)description HOME LAN INTERFACE
Router#(config-if)ip address 192.168.1.254 255.255.255.0
Router#(config-if)no ip redirects
Router#(config-if)no ip unreachables
Router#(config-if)no ip proxy-arp
Router#(config-if)ip nat inside
Router#(config-if)ip virtual-reassembly
Router#(config-if)no ip mroute-cache
Router#(config-if)duplex auto
Router#(config-if)speed auto
Router#(config-if)no cdp enable
Router#(config-if)no shutdown
Router#(config-if)exit
Router#(config)exit
================================================================
Make DHCP for HOME LAN INTERFACE
================================================================
Router#(conf t)
Router(config)#ip dhcp pool R1DHCP
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.10.254
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit
Router(config)#ip dhcp ex
Router(config)#ip dhcp excluded-address 192.168.10.1 192.168.10.9
Router(config)#exit
================================================================
Make SIMPLE ACCESS LIST
================================================================
Router#conf t
Router(config)#access-list 100 permit ip any any
Router(config)#ip nat inside source list 100 interface FastEthernet0/0
Router(config)#exit
================================================================
Write Configuration
================================================================
Router#write
================================================================

13 Replies 13

Amit Goyal
Beginner
Beginner

Hi Mark,

I hope you are connecting Cisco 1841 as below.

Cisco 1841 -------Openreach Modem -------------ISP (BT).

If yes, then PPP negotiation with ISP will be done by Modem and not by Cisco 1841 router. So above configuration will not help.

Try below options:

1. If you know how to bring Openreach modem in bridge mode, PPP negotiation can be done between ISP and Cisco 1841 router.

2. If you can directly connect Cisco 1841 with ISP, PPP negotiation can be done.

HTH

-Amit

Hello Amit,

Firstly, I'm most grateful to you for you reply.

Unfortunately, the modem I allude to in my posting is not "bridgeable".

Well, it might be with a physical hack, from what I gather from some forum postings but I'm reluctant to try this for a number of reasons. Part being that my wife needs the internet connection too, so if it is lost, through an incorrect hack, this would cause problems.

In this respect, I probably have to try to find a way to merely tap off the LAN ports on the associated LAN ports of the BT Homehub that is fed by the modem. I'll have to try to work out how to do that at some point.

Meanwhile, thank you again for your patience and help.

Mark

Hi Mark,

I completely echo with the suggestion given by gpauwen on this thread. Best you can do with below.

Use 1841 device as a Hub and get the IP address from Openreach modem via DHCP.

Please rate this post if gpauwen or myself were able to help you in anyway.

HTH

-Amit

Hello Amit,

I do apologise about the delay in replying to you and to 'gpauwen'.

I stayed up late last night, to give the connection another go. I'm happy to report my final attempt was successful using a variation of 'gpauwen's' script and another project script from another source author, Callam McMillan.

I 'bolted' the two scripts together, and added some of my own very minor adaptations, and the BT connection came alive!

Thanks to you both and to the other project author, Callam McMillan (shown in the link below), I have been able to fashion a working connection.

However, what is also very important is that you have both been very patient and allowed me to learn about this process and this has been invaluable for my learning. I'm very grateful to you all.

Kind Regards,

Mark

Script snip:

===================================
hostname Routy MacRoutface
ip dchp excluded-address 192.x.y.z 192.x.y.z
ip dhcp pool main_dhcp_pool
network 192.x.y.z 255.255.255.0
default-router 192.x.y.z
dns-server 194.x.y.z 8.8.8.8
===================================
ip domain name testmynet
ip name-server 194.x.y.z
ip name-server 8.8.8.8
===================================
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ip tcp adjust-mss 1452
pppoe enable group global
pppoe-client dial-pool-number 1
===================================
interface FastEthernet0/1
ip address 192.x.y.z 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1350
duplex auto
speed auto
===========
interface dialer1
ip address negotiated
ip access-group 101 in
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly in
no cdp enable
encapsulation ppp
dialer pool 1
ppp chap hostname bthomehub@btbroadband.com
ppp chap password 0 xyz
=======================================
ip nat inside source list 1 interface dialer1 overload
access-list 1 remark INTERNET-ACCESS
access-list 1 permit 192.x.y.z 0.0.0.255
=======================================
ip route 0.0.0.0 0.0.0.0 dialer1
ip route 192.x.y.z 255.255.255.0 FastEthernet0/1
=======================================
End of Script
=======================================

Link to script contributor's BT Infinity Project:-

Callam McMillan

Thanks Mark.

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

in addition to Amit's post, I have sanitized your configuration (important additions are marked in bold). See if you can make this work...

hostname R1

ip dhcp pool R1DHCP
network 192.168.10.0 255.255.255.0
default-router 192.168.10.254
dns-server 8.8.8.8
ip dhcp excluded-address 192.168.10.1 192.168.10.9

interface FastEthernet0/0
description BT WAN INTERFACE
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
no routing dynamic

interface FastEthernet0/1
description HOME LAN INTERFACE
ip address 192.168.1.254 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
no ip mroute-cache
duplex auto
speed auto
no cdp enable
no shutdown

interface Dialer1
ip address negotiated
no ip unreachables
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname bthomehub@btbroadband.com
ppp chap password 0 4567
ppp ipcp dns request
no cdp enable

ip access-list extended NAT_INSIDE
permit ip 192.168.10.0 0.0.0.255 any

ip nat inside source list NAT_INSIDE interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 dialer 1

Hello,

Firstly, I'm grateful for your reply and help on this issue.

Unfortunately, the configuration also doesn't work so the internet connection is still unobtainable.

However, this may be down to one issue and that is of the command:

no ip mroute-cache

This command is deprecated in the IOS I'm using (Version 15).

Whether this line is enough to stop the configuration working as a whole, I don't know?

The system flagged up the following gripe when I tried to enter the following line as part of your suggested script:- 

no ip mroute-cache

The system came back with a warning, as follows:-

The above command is deprecated.
Use MFIB commands instead.

I tried to use something which was suggested by the IOS, in terms of a 'mfib' command of sorts but this may have been no use anyway.

So back to square one. I'm a little surprised this is proving so hard to crack as I would have thought the BT equipment I'm using is pretty standard stuff.

However, Amit seems to think I need to 'bridge' the modem I'm using. But as you can see from my reply to him, I can't risk attempting that.

Unless you can advise again, with respect to the deprecated command:-

no ip mroute-cache

I don't know what else to do, except work on with my studies and hopefully by the time I reach the end of ICND2, there will be material where I can learn how to configure these things with confidence. Else, it would have been useful to have the internet coming through the router as a means to learn as I go along at ICND1 level (which I've just finished this week). This arrangement would help me study with my small home lab at the same time freeing up the internet connection for my wife, who relies on it for a lot of her work access.

Again, I am very grateful to you for your time and patience in advising on this matter. It is much appreciated.

Mark

Mark,

the ip mroute-cache command is for multicasting only and has no impact on anything in your setup.

The configuration I gave you is actually supposed to work with the cable connection directly connected to the FastEthernet0/0 interface of your router. Can you try that and check if you can browse the Internet then ?

Thank you again, 'gpauwen',

I'm grateful for your time and continued advice on this issue.

I've drawn out a very basic network sketch which relates to how I believe you are asking me to configure the network (see attached).

I take it you are asking me to connect from the RJ45 socket on the router (FE0/0) directly to the BT/Openreach DSL wall socket (RJ11) - in effect taking the BT/Openreach VSDL modem out of circuit?

If this is the case, then I will need to order a RJ45 to RJ11 cable next week.

I understand what you have explained about the command:-

ip mroute-cache

However, I'm rather embarrassed about my lack of knowledge at this point especially since I've just completed ICND1. I can only hope it will be much improved by the time ICDN2 is finished this month!

Hello Mark,

connecting your 1841 directly to the wall socket won't work. You need to have a HWIC-xVDSL card installed in your router, which you don't have. That means, your 1841 will at best work as a hub, with only a basic configuration (below).

When you connect the Openreach modem to the FastEthernet0/0, do you get a link light ? If not, you might need a crossover cable.

hostname R1

interface FastEthernet0/0

description BT OPENREACH UPLINK
ip address 192.168.1.254
duplex auto
speed auto

interface FastEthernet0/1

description HOME LAN INTERFACE
duplex auto
speed auto
no cdp enable
no shutdown

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Many grateful thanks again.

I couldn't see how a physical, let alone an electrical connection between Ethernet to DSL could work :o/ but hey ho! Again, I'm embarrassed not to have mentioned it before drawing out the diagram earlier. No worries.

I understand about the HWIC-xVDSL card. I had looked into this option some weeks ago, when I bought these routers (bought two 1841's), before I started to work on my 'lab exercises' but the cost was prohibitive.

No matter which CAT lead I use, 'Cross' or 'Straight', the port FE0/0 'link light' lights when the interface comes up on the previous configuration you kindly provided earlier today.

I haven't tried the latter configuration, the one you have provided this evening, as I'm not sure if that is going to get me nearer being able to use this 1841 with my Openreach line as a full routing device.

Going back to the VSDL Openreach modem I'm using (or rather the one BT force me to use (as part of the Terms and Conditions), it seems disappointing it can connect to its associated BT Homehub 4 and work perfectly for the LAN's in the house but not connect to my Cisco 1841 routers instead.

Without wishing to repeat myself, my knowledge is right at its limits about the connection issues at the moment and its embarrassing to have to trouble you about it but again I'm thankful for your patience presently.

I'm not sure what else I can do, except wait for my knowledge to gain ground before coming back to this issue. That is to either give up completely on the physical connection or just use virtual Labs training with the Cisco materials.

Mark

Hello,

one more thing: the Openreach modem functions as a DHCP server, so if you configure the interfaces on your 1841 as DHCP clients, they should get IP addresses from the Openreach IP address range:

hostname R1

interface FastEthernet0/0

description BT OPENREACH UPLINK
ip address dhcp
duplex auto
speed auto

interface FastEthernet0/1

description HOME LAN INTERFACE

ip address dhcp
duplex auto
speed auto
no cdp enable
no shutdown

That said, is what you are trying to do just a technical challenge ? There is really no advantage to adding another layer 3 device (the 1841), since it will slow down your network. Is there a specific reason you want to add the 1841, other than learning what it can do ?

Thank you again, gpauwen.

I had misunderstood the function of the VSDL modem in this instance.

I'd thought that the IP address provisioning (DHCP server) came from the associated BTHomehub device, with the modem merely acting as modulate/demodulate interface of the DSL signal from/to house to/from FTTC. Again my lack of knowledge about the equipment in this instance is telling. It's very embarrassing, and I sincerely apologise to you for this.

I did (or do) want to learn about the 1841's and what they can do within the network context, for CCNA Home Labs work. Just having them being able to connect to the internet would have been another interesting dimension to learn about and to have some traffic I could route around the small home LAB I have here. Sadly, I don't appear to be able to do that in this instance and will give up on this aspect of learning about internet connections, within the scope of routing in a CCNA Home lab learning context. I

I've lost too much time over the past week, as I'd planned to complete the first whole read and note-taking of ICND1 and 2 over the course of last month and concluding at the end of this month. Getting distracted by the routing problem has probably delayed my schedule now until the early new year. Moreover, my course provider is just awful and I'm regretting choosing them as my CCNA Learning provider - there are so many glitches on their course materials. 'Would have been better to subscribe to Cisco Premium CCNA and CCNP Practice Toolkit directly and got on with learning myself that way. Still, once bitten, twice shy but they [the CCNA Cisco Learning Partner here in the UK] have my money now, so no room for manoeuvre now.

I do apologise again about seemingly wasting your time on helping me with the above issue. Had I thought this would have ended up with such a constraint on connectivity, I would not have troubled anyone. Even so, I have learnt quite a lot from it and your advice too.

Thank you again, and kind regards,

Mark

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers