cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

9939
Views
4
Helpful
4
Replies
Highlighted
Beginner

Cisco 881G-k9 3G connection problem

Hi everybody,

We bought new cisco 881G-K9 router:

NAME: "881G", DESCR: "881G chassis, Hw Serial#: xxx, Hw Revision: 1.0"

PID: CISCO881G-K9      , VID: V01 , SN: xxx

NAME: "Modem 0 on Cellular0", DESCR: "Sierra Wireless 504-G"

PID: 504-G             , VID: 1.0, SN: xxx

But now we cannot not configure it for work.
Problem description:
Router is not establishes 3G connection. Cellular0 Profile is inactive.  Below conf and debug. Please, provide any information or solution
----------------------------------------------------------------------------------------------------------------------------
yourname#sh run
Building configuration...
Current configuration : 5805 bytes
!
! Last configuration change at 07:07:40 UTC Thu Jan 27 2011 by tarlan
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot system flash:c880data-universalk9-mz.151-3.T.bin
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2252664030
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2252664030
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-2252664030
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32323532 36363430 3330301E 170D3131 30313237 30353536
  32315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 32353236
  36343033 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100AEBC 67DCF531 7C9C643C AB2B1537 FBA3A545 882DC149 A2646DFF 2812085D
  4719574A 05FB0D96 AF5DCE79 22A5D988 82DFF29C 941C5120 3F46BCC1 92485882
  7A66E6A5 F30BD2DC 49EFB1D3 0F5FF843 D9BBE38D 50B18251 0E6E7D3F 6D6CC6CF
  5DEE58E2 928AA98A 5A85AA27 A6DAD1D8 E5EF7626 7396CF48 1BF0A46D 9CB5871D
  E0370203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 14627E44 23679F24 E5829CD5 68BD31C5 3D87925D
  41301D06 03551D0E 04160414 627E4423 679F24E5 829CD568 BD31C53D 87925D41
  300D0609 2A864886 F70D0101 04050003 81810043 D6274B6C 9D5FE854 FF933482
  06A6D99C FE66AD8A 3980230B 8BC39E4A F1B3D931 92948855 F5F28C7B 6875611A
  621B1E3C C1F4EB7B B3989422 D3A9AFD0 D873D9E0 5AF5CD89 EBD70311 02E2C1A9
  F274A7FF E9695A32 5BB1743F 0F6EF03F 24CFBDF4 CCCA6C43 C4D4F27C 87FE6472
  0B7684BF 597FB3DF 09B16845 FBB96A07 20014D
        quit
ip source-route
!
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1
   lease 0 2
!
!
ip cef
no ip domain lookup
ip domain name yourdomain.com
no ipv6 cef
!
!
multilink bundle-name authenticated
chat-script gsm "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"
license udi pid CISCO881G-K9 sn FCZ1446C147
!
!
username xxx privilege 15 secret 5 xxx
!
!
!
!
controller Cellular 0
!
!
!
!
!
!
!
!
interface FastEthernet0
!        
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0
no ip address
ip virtual-reassembly in
encapsulation ppp
dialer in-band
dialer pool-member 1
async mode interactive
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.10.10.1 255.255.255.248
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string gsm
dialer persistent
ppp ipcp dns request
no cdp enable
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!        
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
logging esm config
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.7
access-list 23 permit 10.10.10.0 0.0.0.7
no cdp run
!
!
!
!
!
control-plane
!
line con 0
login local
no modem enable
line aux 0
line 3
script dialer gsm
modem InOut
no exec
transport input all
rxspeed 7200000
txspeed 5760000
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
end
---------------------------------------------------------------------------------------------------------------------------
terminal output :
*Jan 27 07:43:55.587: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*Jan 27 07:43:55.587: %DIALER-6-BIND: Interface Ce0 bound to profile Di0
*Jan 27 07:43:58.631: %LINK-5-CHANGED: Interface Cellular0, changed state to reset
*Jan 27 07:43:58.631: %DIALER-6-UNBIND: Interface Ce0 unbound from profile Di0
*Jan 27 07:44:03.703: %LINK-3-UPDOWN: Interface Cellular0, changed state to down
-------------------------------------------------------------------------------------------------------------------------------
yourname#sh cellular 0 all
Hardware Information
====================
Modem Firmware Version = K2_0_7_35AP C:/WS/F
Modem Firmware built = 03/04/10
Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 400042002002414
International Mobile Equipment Identity (IMEI) = 353223040039522
Integrated Circuit Card ID (ICCID) = 8999404091020024143
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) =
Factory Serial Number (FSN) = D9E217008581003
Modem Status = Online
Current Modem Temperature = 31 deg C, State = Normal
PRI SKU ID = 9993559, SKU Rev. = 1.2
Profile Information
====================
Profile 1 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = azerfon
Authentication = None
Username: , Password:
         
Profile 2 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = azerfon
Authentication = None
Username: , Password:
Profile 3 = INACTIVE
--------
PDP Type = PPP
Access Point Name (APN) = azerfon
Authentication = None
Username: , Password:
Profile 4 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = nar
Authentication = None
Username: , Password:
Profile 5 = INACTIVE
-------- 
PDP Type = PPP
Access Point Name (APN) = nar
Authentication = CHAP
Username: nar, Password: nar
* - Default profile
Data Connection Information
===========================
Data Transmitted = 0 bytes, Received = 0 bytes
Profile 1, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 2, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
...
Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSPA (Attached)
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = AZE, Network = Nar
Mobile Country Code (MCC) = 400
Mobile Network Code (MNC) = 4
Location Area Code (LAC) = 3021
Routing Area Code (RAC) = 132
Cell ID = 30047
Primary Scrambling Code = 5
PLMN Selection = Automatic
Registered PLMN =  , Abbreviated =
Service Provider = Azerfon
Radio Information
=================
Radio power mode = ON
Current Band = WCDMA 2100, Channel Number = 10588
Current RSSI = -59 dBm
Band Selected = Auto
Number of nearby cells = 1
Cell 1
        Primary Scrambling Code = 0x5
        RSCP = -61 dBm, ECIO = -4 dBm
Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
--------------------------------------------------------------------------------------------------
*Jan 27 06:04:29.403: Ce0 DDR: Attempting to dial gsm
*Jan 27 06:04:29.403: CHAT3: Attempting async line dialer script
*Jan 27 06:04:29.403: CHAT3: Dialing using Modem script: gsm & System script: none
*Jan 27 06:04:29.403: CHAT3: process started
*Jan 27 06:04:29.403: CHAT3: Asserting DTR
*Jan 27 06:04:29.403: CHAT3: Chat script gsm started
*Jan 27 06:04:29.407: CHAT3: Sending string: ATDT*98*1#
*Jan 27 06:04:29.407: CHAT3: Expecting string: CONNECT
*Jan 27 06:04:29.419: CHAT3: Completed match for expect: CONNECT
*Jan 27 06:04:29.419: CHAT3: Chat script gsm finished, status = Success
*Jan 27 06:04:29.495: TTY3: no timer type 1 to destroy
*Jan 27 06:04:29.495: TTY3: no timer type 0 to destroy
*Jan 27 06:04:29.495: TTY3: no timer type 2 to destroy
*Jan 27 06:04:31.495: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*Jan 27 06:04:31.495: Ce0 DDR: Dialer statechange to up
*Jan 27 06:04:31.495: %DIALER-6-BIND: Interface Ce0 bound to profile Di0
*Jan 27 06:04:31.495: Ce0 DDR: Dialer call has been placed
*Jan 27 06:04:31.495: Ce0 PPP: Sending cstate UP notification
*Jan 27 06:04:31.495: Ce0 PPP: Processing CstateUp message
*Jan 27 06:04:31.495: PPP: Alloc Context [855F0870]
*Jan 27 06:04:31.495: ppp11 PPP: Phase is ESTABLISHING
*Jan 27 06:04:31.495: Ce0 PPP: Using dialer call direction
*Jan 27 06:04:31.495: Ce0 PPP: Treating connection as a callout
*Jan 27 06:04:31.495: Ce0 PPP: Session handle[8200000B] Session id[11]
*Jan 27 06:04:31.495: Ce0 LCP: Event[OPEN] State[Initial to Starting]
*Jan 27 06:04:31.495: Ce0 PPP: No remote authentication for call-out
*Jan 27 06:04:31.495: Ce0 LCP: O CONFREQ [Starting] id 1 len 20
*Jan 27 06:04:31.499: Ce0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan 27 06:04:31.499: Ce0 LCP:    MagicNumber 0x8D11E4A2 (0x05068D11E4A2)
*Jan 27 06:04:31.499: Ce0 LCP:    PFC (0x0702)
*Jan 27 06:04:31.499: Ce0 LCP:    ACFC (0x0802)
*Jan 27 06:04:31.499: Ce0 LCP: Event[UP] State[Starting to REQsent]
*Jan 27 06:04:31.499: Ce0 LCP: I CONFACK [REQsent] id 1 len 20
*Jan 27 06:04:31.499: Ce0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan 27 06:04:31.499: Ce0 LCP:    MagicNumber 0x8D11E4A2 (0x05068D11E4A2)
*Jan 27 06:04:31.499: Ce0 LCP:    PFC (0x0702)
*Jan 27 06:04:31.499: Ce0 LCP:    ACFC (0x0802)
*Jan 27 06:04:31.499: Ce0 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
*Jan 27 06:04:32.499: Ce0 LCP: I CONFREQ [ACKrcvd] id 29 len 25
*Jan 27 06:04:32.499: Ce0 LCP:    ACCM 0x00000000 (0x020600000000)
*Jan 27 06:04:32.499: Ce0 LCP:    AuthProto CHAP (0x0305C22305)
*Jan 27 06:04:32.499: Ce0 LCP:    MagicNumber 0x05CC33B8 (0x050605CC33B8)
*Jan 27 06:04:32.499: Ce0 LCP:    PFC (0x0702)
*Jan 27 06:04:32.499: Ce0 LCP:    ACFC (0x0802)
*Jan 27 06:04:32.499: Ce0 LCP: O CONFACK [ACKrcvd] id 29 len 25
*Jan 27 06:04:32.499: Ce0 LCP:    ACCM 0x00000000 (0x020600000000)
*Jan 27 06:04:32.499: Ce0 LCP:    AuthProto CHAP (0x0305C22305)
*Jan 27 06:04:32.499: Ce0 LCP:    MagicNumber 0x05CC33B8 (0x050605CC33B8)
*Jan 27 06:04:32.499: Ce0 LCP:    PFC (0x0702)
*Jan 27 06:04:32.499: Ce0 LCP:    ACFC (0x0802)
*Jan 27 06:04:32.499: Ce0 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
*Jan 27 06:04:32.507: Ce0 PPP: No authorization without authentication
*Jan 27 06:04:32.507: Ce0 PPP: Phase is AUTHENTICATING, by the peer
*Jan 27 06:04:32.507: Ce0 LCP: State is Open
*Jan 27 06:04:32.511: Ce0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
*Jan 27 06:04:32.511: Ce0 PPP: Sent CHAP SENDAUTH Request
*Jan 27 06:04:32.511: Ce0 PPP: Received SENDAUTH Response FAIL
*Jan 27 06:04:32.511: Ce0 CHAP: Unable to authenticate for peer
*Jan 27 06:04:32.511: Ce0 PPP DISC: User failed CHAP authentication
*Jan 27 06:04:32.511: PPP: NET STOP send to AAA.
*Jan 27 06:04:32.511: Ce0 LCP: O TERMREQ [Open] id 2 len 4
*Jan 27 06:04:32.511: Ce0 LCP: Event[CLOSE] State[Open to Closing]
*Jan 27 06:04:32.511: Ce0 PPP: Phase is TERMINATING
*Jan 27 06:04:32.519: Ce0 LCP: I TERMACK [Closing] id 2 len 4
*Jan 27 06:04:32.519: Ce0 PPP: No remote authentication for call-out
*Jan 27 06:04:32.519: Ce0 LCP: Event[Receive TermAck] State[Closing to Closed]
*Jan 27 06:04:32.519: Ce0 LCP: Event[DOWN] State[Closed to Initial]
*Jan 27 06:04:32.519: Ce0 PPP: Phase is DOWN
*Jan 27 06:04:32.519: TTY3: Async Int reset: Dropping DTR
*Jan 27 06:04:32.827: TTY3: DSR was dropped
*Jan 27 06:04:32.827: tty3: Modem: READY->(unknown)
*Jan 27 06:04:33.827: TTY3: dropping DTR, hanging up
*Jan 27 06:04:33.827: tty3: Modem: HANGUP->(unknown)
*Jan 27 06:04:33.827: TTY3: cleanup pending. Delaying DTR
*Jan 27 06:04:34.523: %LINK-5-CHANGED: Interface Cellular0, changed state to reset
*Jan 27 06:04:34.523: Ce0 DDR: has total 0 call(s), dial_out 0, dial_in 0
*Jan 27 06:04:34.523: %DIALER-6-UNBIND: Interface Ce0 unbound from profile Di0
*Jan 27 06:04:34.523: Ce0 PPP: Sending cstate DOWN notification
*Jan 27 06:04:34.523: Ce0 PPP: Processing CstateDown message
*Jan 27 06:04:34.831: TTY3: cleanup pending. Delaying DTR
*Jan 27 06:04:34.831: TTY3: cleanup pending. Delaying DTR
*Jan 27 06:04:35.523: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:35.831: TTY3: cleanup pending. Delaying DTR
*Jan 27 06:04:35.831: TTY3: cleanup pending. Delaying DTR
*Jan 27 06:04:36.523: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:36.831: TTY3: cleanup pending. Delaying DTR
*Jan 27 06:04:36.831: TTY3: cleanup pending. Delaying DTR
*Jan 27 06:04:37.599: TTY3: no timer type 0 to destroy
*Jan 27 06:04:37.599: TTY3: no timer type 1 to destroy
*Jan 27 06:04:37.599: TTY3: no timer type 3 to destroy
*Jan 27 06:04:37.599: TTY3: no timer type 4 to destroy
*Jan 27 06:04:37.599: TTY3: no timer type 10 to destroy
*Jan 27 06:04:37.599: TTY3: no timer type 2 to destroy
*Jan 27 06:04:37.599: Cellular0: allowing modem_process to continue hangup
*Jan 27 06:04:37.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:37.831: TTY3: restoring DTR
*Jan 27 06:04:37.831: TTY3: DSR came up
*Jan 27 06:04:37.831: tty3: Modem: IDLE->READY
*Jan 27 06:04:38.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:39.603: %LINK-3-UPDOWN: Interface Cellular0, changed state to down
*Jan 27 06:04:39.603: Ce0 PPP: Sending cstate DOWN notification
*Jan 27 06:04:39.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:39.603: Ce0 PPP: Processing CstateDown message
*Jan 27 06:04:40.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:41.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:42.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:43.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:44.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:45.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:46.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:47.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:48.603: Di0 DDR: No free dialer - starting fast idle timer
*Jan 27 06:04:49.523: Ce0 DDR: re-enable timeout
*Jan 27 06:04:49.603: Ce0 DDR: rotor dialout [best] least recent failure is also most recent failure
*Jan 27 06:04:49.603: Ce0 DDR: rotor dialout [best] also has most recent failure
*Jan 27 06:04:49.603: Ce0 DDR: rotor dialout [best]
*Jan 27 06:04:49.603: Di0 DDR: Nailing up the Dialer profile [attempt 171]
*Jan 27 06:04:49.603: Di0 DDR: Dialer dialing - persistent dialer profile
*Jan 27 06:04:49.603: Ce0 DDR: Dialing cause Persistent Dialer Profile
Everyone's tags (5)
4 REPLIES 4
Participant

Re: Cisco 881G-k9 3G connection problem

Hi,

Can you try to configure a dummy CHAP username/password (for example guest/guest) under profile and cellular?

I would also move all the configuration from dialer to cellular interface. The cellular interface is already a dialer per-se, you can move all the commands there, it simplify the troubleshooting.

Can you try the following config:

interface Cellular0

 

ip address n
egotiated
 encapsulation ppp
 dialer in-band
 dialer string gsm
 dialer-group 1
 async mode interactive
 ppp chap hostname guest     
 ppp chap password 0 guest
 ppp ipcp dns request

ip route 0.0.0.0 0.0.0.0 Cellular0/0/0

access-list 1 permit any
dialer-list 1 protocol ip list 1

line 3
 exec-timeout 0 0
 script dialer gsm
 login
 modem InOut
 no exec

After that, can you collect the same debugs again?

Hope this helps

Marco

* Don't forget to rate useful posts *

Beginner

Re: Cisco 881G-k9 3G connection problem

Dear Marco,

You are right about configuration. But it is not solved problem. And I got same debug strings.

Although, I found problem. Problem was in below part:

Jan 27 06:04:32.507: Ce0 PPP: No authorization without authentication
*Jan 27 06:04:32.507: Ce0 PPP: Phase is AUTHENTICATING, by the peer
*Jan 27 06:04:32.507: Ce0 LCP: State is Open
*Jan 27 06:04:32.511: Ce0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
*Jan 27 06:04:32.511: Ce0 PPP: Sent CHAP SENDAUTH Request
*Jan 27 06:04:32.511: Ce0 PPP: Received SENDAUTH Response FAIL
*Jan 27 06:04:32.511: Ce0 CHAP: Unable to authenticate for peer

*Jan 27 06:04:32.511: Ce0 PPP DISC: User failed CHAP authentication

My friend Michel (big thanks to him) said that :

"What seems to be happening is that your local router is asking the network to authenticate itself.

Obviously the network does NOT authenticate itseld (except with to the SIM card, using the auth quintuplets).
Because the network is not authenticating itself to you, the connection fails.

You need to configure the router to trust the network and not ask for CHAP authentication "

and adviced to add below commands:

interface Cellular0

ppp chap refuse

So, at the end correct config is below:

interface Cellular0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer in-band

dialer idle-timeout 0

dialer string gsm

dialer-group 1

async mode interactive

ppp chap refuse

ppp ipcp dns request

dialer-list 1 protocol ip permit

line 3

script dialer gsm

modem InOut

no exec

transport input all

Thanks to all for support...

Beginner

Hello Secureboy,

Hello Secureboy,

I had the same issue with one of our 881G-G-box and issuing the below command the cellular came up...

"ppp chap refuse"

Thanks a lot..

Ranjit

 

Beginner

Hi Ranjit,

Hi Ranjit,

I'm having problems configuring an 881G router as well. Did you configure on your Cellular interface or did you use a dialer interface?

If you don't mind, could you provide your interface config?

Thanks

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here