cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2080
Views
0
Helpful
12
Replies
Highlighted

Cisco BackUp Interface Operation Failing

OK Experts,

I have made this issue very simple for you guys to help me out.

I  have two routers R22 and R23. I have configured the back up interface  on R22 to be interface fas 0/1. Everything appears to be working fine. I  issue the command show backup and I get the following on R22

r22#show backup

Primary Interface   Secondary Interface   Status

-----------------   -------------------   ------

FastEthernet0/0     FastEthernet0/1       normal operation

r22#

Also I get the following:

FastEthernet0/1            10.10.13.2      YES manual standby mode          down

However, when I shutdown interface fast 0/0 to test the back up interface fast 0/1 I get the following:

r22#show backup

Primary Interface   Secondary Interface   Status

-----------------   -------------------   ------

FastEthernet0/0     FastEthernet0/1       disabled

r22#

FastEthernet0/1            10.10.13.2      YES manual standby mode/disabled down

So it doesn't work.

Attached are the configs.

I was wondering if someone could help me figure out why this won't work.

Cheers

12 REPLIES 12
Highlighted
Hall of Fame Master

Re: Cisco BackUp Interface Operation Failing

Hello Carlton,

there are some notes about your tests:

a)  the configuration of the primary interface includes two logical interfaces main interface and a vlan based subinterfaces both fail when you disable fas0/0, the secondary interface has only IP configuration at main interface level

from your log files:

interface FastEthernet0/0

backup interface FastEthernet0/1

ip address 10.10.14.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 12

ip address 10.10.12.2 255.255.255.0

!

You should remove the subinterface fas0/0.1 as a minimum to make interface configurations compatible,

b) the specific type of interface you  would like to use for backup is LAN based Fastethernet.

The backup command had been introduced for providing a backup interface for serial interface and the secondary interface may be a serial interface or ISDN based ( in this case a DDR call is triggered over ISDN).

The dial backup command reference says that support for gigabit interfaces in C7600 has been later introduced.

see

http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_a1.html#wp1012054

The use of backup command may be supported or not for fastethernet interface on your routers.

If it is not supported, you can easily implement an alternate solution, because you are running OSPF in area 0 in all router interfaces

router ospf 1

log-adjacency-changes

>>network 0.0.0.0 255.255.255.255 area 0

!

So all you need to do  is to increase OSPF cost on fas0/1 to create a backup path

on R22, R23:

conf t

interface fas0/1

ip ospf cost 50

Hope to help

Giuseppe

Highlighted
Hall of Fame Guru

Re: Cisco BackUp Interface Operation Failing

Carlton

In my experience with backup interface one of the lessons that I learned is that you can not test it by doing shutdown on the primary interface. It seems that IOS is smart enough to say that if you shut down the interface it was intentional and therefore it does not activate the backup interface. I suggest that you test by creating a real problem on the primary interface. (unplug is the first thing that comes to mind but there are probably other things that might work)

HTH

Rick

Sent from Cisco Technical Support iPad App

HTH

Rick
Highlighted

Re: Cisco BackUp Interface Operation Failing

Hi Giuseppe,

Thanks for responding, I did try the backup interface solution without sub-interfaces and I got the same results.

I wonder if you're correct when you mention that 'backup interface' was introduced to backup a  serial interface?

Increasing the ip ospf cost is a solution I will investigate.

Cheers

Highlighted
Advisor

Cisco BackUp Interface Operation Failing

Hi Carlton,

Follow Rick advice because as he stated the backup interface can't be put out of standby mode by shutting down the primary interface, this was made on purpose because at the beginning the backup interface was a link you were paying for only when  traffic was flowing and it was expensive and so to prevent using that line by just doing a mistake and shutting down the primary they conceived it like this.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

Cisco BackUp Interface Operation Failing

Hi Cadet,

I'm back in the office now and will setup the backup interface in our lab.

In the meantime, apart from actually disconnecting the cable,  is there another way of testing backup interface?

Regards

Carlton

Highlighted
Advisor

Cisco BackUp Interface Operation Failing

Hi,

just shut down the primary interface on the other router.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

Cisco BackUp Interface Operation Failing

cadet,

I tried your suggestion by shutting the primary interface on the other router.... However, the backup interface still didn't activate.

R10#show backup

Primary Interface   Secondary Interface   Status

-----------------   -------------------   ------

FastEthernet0/0     FastEthernet0/1       disabled

I think I will have to pull the cable. If that doesn't work I will then assume it won't work with the primary and backup interface both being ethernet???

Highlighted
Advisor

Cisco BackUp Interface Operation Failing

Hi,

is there a switch  between the 2 devices ?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted
Hall of Fame Guru

Cisco BackUp Interface Operation Failing

Carlton

I am not authoritative on this, but I believe that backup interface should work with Ethernet interfaces. And a couple of things from your original post see to indicate that it is ok

r22#show backup

Primary Interface   Secondary Interface   Status

-----------------   -------------------   ------

FastEthernet0/0     FastEthernet0/1       normal operation

r22#

Also I get the following:

FastEthernet0/1            10.10.13.2      YES manual standby mode          down

If backup interface was not supported on Ethernet then I would not expect to get these outputs.

With serial interfaces there were a couple of things that we could do to create a problem that would initiate the backup interface (things like changing the line encapsulation or turning off keepalives on the neighbor device). But those do not affect Ethernet. On a router I would have thought that shutting down the interface on the directly  connected device would have caused the Ethernet to go line protocol down. But the most reliable test is to unplug the router interface.

HTH

Rick

HTH

Rick
Highlighted

Cisco BackUp Interface Operation Failing

Hi Rick,

Unplug the router interface maybe my only option, however it should work by shutting down both interfaces...

Highlighted

Cisco BackUp Interface Operation Failing

No switch between.

Highlighted
Beginner

Hi, The configurations on the

Hi,

 

The configurations on the primary and backup interfaces must match or the backup interface does not work.

 

BR,