05-02-2023 03:27 PM
Hello can someone help me I have a problem with Cisco router c7200 I'm trying to make a backup link between two routers but for some reason when I disable the main interface the backup interface doesn't turn on it says disabled, here is my config:
R1#sh run
Building configuration...
Current configuration : 1873 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
--More--
*May 3 00:22:32.011: %SYS-5-CONFIG_I: Configured from console by console
R1#sh run
Building configuration...
Current configuration : 1873 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
duplex auto
!
interface GigabitEthernet0/0
ip address 10.10.14.1 255.255.255.0
shutdown
duplex full
speed 1000
media-type gbic
negotiation auto
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface Serial2/0
backup interface GigabitEthernet0/0
ip address 10.10.12.1 255.255.255.0
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
---------------------------------------------------------------------------------------------------------
R2#sh run
Building configuration...
Current configuration : 1853 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
duplex auto
!
interface GigabitEthernet0/0
ip address 10.10.14.2 255.255.255.0
duplex full
speed 1000
media-type gbic
negotiation auto
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface Serial2/0
backup interface GigabitEthernet0/0
ip address 10.10.12.2 255.255.255.0
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
Solved! Go to Solution.
05-03-2023 11:58 AM
Testing the backup interface is a little more difficult. A simple shutdown of the interface will not cause the IOS software to see this as a link failure. To test the backup interface, you must physically remove the cable from the serial interface.
so to test backup you must select the link and delete it.
05-02-2023 03:29 PM
05-02-2023 03:51 PM
Hi
If this is a simulator, it might be a failure on the simulator.
https://www.youtube.com/watch?v=8dRuzzecToA
This video is pretty clear on how this feature works.
05-03-2023 11:53 AM
I did this but when I shut the primary interface it doesn't enable the backup interface therefore I can't ping the other router from the backup interface.
05-02-2023 03:53 PM - edited 05-03-2023 11:56 AM
Why both interface shutdown' In one router
It must be no shut
05-03-2023 11:58 AM
Testing the backup interface is a little more difficult. A simple shutdown of the interface will not cause the IOS software to see this as a link failure. To test the backup interface, you must physically remove the cable from the serial interface.
so to test backup you must select the link and delete it.
05-03-2023 12:02 PM
Right this makes more sense I understand now, thanks for the explanation.
05-03-2023 12:00 PM
05-03-2023 12:59 AM
Hello
Looks like you are trying t use flex-link, as such the backup interfaces need to be administratively enabled
int x.x
backup xxx
no shut
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide