12-12-2011 11:55 PM - edited 03-04-2019 02:36 PM
I'm new to CISCO Routers, we bought this unit as a recomendation from a CISCO representative to provide just internet service for our guests.I have tried to set it up using CISCO CP Express and was able to set up the LAN side but when it comes to the WAN it doesn't connect to the internet and I cannot find the field to setup the gateway provided by the ISP.
We have a cable modem with 5 static IP's, we have 2 in use and planning to use a 3rd one for this router, here's a sample of the info (not the real numbers) I have to set up:
*WAN
IP 24.182.198.23
Subnet 255.255.255.248
Gateway 24.182.198.22
DNS 24.205.192.61
DNS 24.205.224.16
*LAN
IP 172.16.0.1
Subnet 255.255.252.0
DHCP pool 172.16.0.40 172.16.3.254
12-13-2011 02:44 AM
Hi Luis,
would it be possible to connect to the router via console cable, and collect a 'show run'?
If you are not familiar with CLI:
Router>
Router> enable
Router# show run
Building configuration...
If I understand correctly, you use a cable modem for connectivity, and the router is connected behind it, is that right?
2921 ----- CM ----- internet
Which type of connection do you have between 2921 and cable modem? Is that Ethernet?
Cheers
Marco
12-13-2011 02:53 AM
Hi,
for the default gateway:
router(config)# ip route 0.0.0.0 0.0.0.0 < IP address of Modem interface connected to router>
for the WAN IP:
router(config)# interface fx/x
ip address 24.182.198.23 255.255.255.248
no shutdown
for the DHCP:
ip dhcp excluded-address 172.16.0.1 172.16.0.39
ip dhcp pool MYPOOL
network 172.16.0.0 255.255.252.0
default-router 172.16.0.1
dns-server 24.205.192.61 24.205.224.16
You'll have to configure NAT for machines on the LAN to go to the internet:
access-list 99 permit 172.16.0.0 0.0.3.255
ip nat inside source list 99 interface fx/x
under LAN interface: ip nat inside
under WAN interface: ip nat outside
Regards.
Alain
12-13-2011 05:58 AM
Hi Luis,
To get internet access to your LAN (guests), you need to do some configuration manually.
First configure the WAN interface (whcih connected to your ISP router/modem)
All the below config will be done from router config mode Router(cofnig)#
int gi0/0
ip address 24.182.198.23 255.255.255.248
ip nat outside
no shut
Now config your LAN interface:
int gi0/1
ip address "your LAN ip"
ip nat inside
no shut
Configure your dns servers:
ip name-server 24.205.192.61
ip name-server 24.205.224.16
Configure default router pointing to your ISP gateway:
ip route 0.0.0.0 0.0.0.0 24.182.198.22
Configure NAT in order to get your all local private ip rage to get access to internet with single IP as you have:
ip nat inside source route-map nonat interface gig0/0 overload
route-map nonat permit 10
match ip address NONAT
ip access-list extended NONAT
permit ip 172.16.0.0 0.0.0.255 any
Hope the above helps you to achieve your task...
Please rate the helpfull posts.
Regards,
Naidu.
12-13-2011 09:34 AM
Naidu
First of all thanks for your help
I have a problem in the last line: permit ip 172.0.0.0 0.0.0.255 any . It gives me an %invalid input detected at ^ marker.
Thanks
12-13-2011 11:20 PM
Hi Luis,
You have to apply the below commands in your router global configuration mode which looks like below...
Router(config)#
ip access-list extended NONAT
permit ip 172.16.0.0 0.0.0.255 any
Let me know if you have any troubles.
Please rate the helpfull posts.
Regards,
Naidu.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide