cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15813
Views
5
Helpful
15
Replies

Configure router for internet access

Brian Taylor
Level 1
Level 1

Hi,

I'm trying to find information on configuring a 877 to allow internet access on one of the Ethernet ports (e.g. fas2).

Currently internet is supplied via an external Ethernet device which returns the following information when plugged into a laptop:

   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : D8-9D-67-CA-62-15
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::5438:6d7e:1491:ad3a%19(Preferred)
   IPv4 Address. . . . . . . . . . . : 10.0.0.253(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, 13 February 2016 1:12:22 PM
   Lease Expires . . . . . . . . . . : Tuesday, 16 February 2016 1:12:20 PM
   Default Gateway . . . . . . . . . : 10.0.0.1
   DHCP Server . . . . . . . . . . . : 10.0.0.1
   DHCPv6 IAID . . . . . . . . . . . : 366517607
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-39-5C-BB-B8-76-3F-53-F7-67
   DNS Servers . . . . . . . . . . . : 10.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

How can I configure a port for internet traffic and route all traffic externally through a Fast Ethernet port - are there instructions for this?

Brian

15 Replies 15

mionan
Level 1
Level 1

Seems like the ISP is using a modem/router combo box which is why you're being supplied an internal IP address. You could call your ISP and tell them you want to use your own router and they need to put their modem in bridge mode. As for the router it's a pretty simple setup and you will need command line access via console cable or telnet/ssh. 

Here's an example config that you can alter to fit your needs:

ip dhcp pool Internal
   import all
   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1
   dns-server 8.8.8.8 8.8.4.4

!

ip access-list standard NAT
 permit 192.168.10.0 0.0.0.255

!

ip nat inside source list NAT interface FastEthernet0/0 overload

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

no shut

!

interface FastEthernet0/1

ip address 192.168.10.1 255.255.255.0

ip nat inside

no shut

!

Thank you very much for your reply. I can contact the ISP regarding the bridge and I'm looking through your example now. By the way I get the below message when selecting the interface mentioned in your post - what does it mean? The arrow is pointing to the "/" character.

dslmodem(config)#interface FastEthernet0/0
                                        ^
% Invalid input detected at '^' marker.

Brian

I ended up with the following. Still need to check with the ISP on the bridging.

interface FastEthernet2
 switchport trunk native vlan 3
 switchport mode trunk
!

interface Vlan3
 ip address dhcp
 ip access-group 101 in
 ip nat outside
 ip virtual-reassembly
!

ip nat inside source list 3 interface Vlan3 overload

Hi sir brian,
Did Mionan's commands work? Because I wanna use them as well.
Thanks

m.rana.ku
Level 1
Level 1

I am sharing a great content which will demonstrate step by step process of Connecting Cisco 2851 Router and Cisco 3560 Switch to ISP Home router and Configuring Cisco Router using Putty and finally Accessing Internet from Laptop and Desktop PC through this network. 

 

PuTTY command line for Router Configuration:

Where hostname of the Router is "Router"

Entering to Privileged mode:

Router>enable

Check IP Interface:

Router#show ip interface brief

Entering to Global Configuration mode:

Router#configure terminal

Entering GE0/0 Interface:

Router(config)#interface gigabitEthernet 0/0

Making Interface up:

Router(config-if)#no shutdown

Assigning IP address from DHCP:

Router(config-if)# ip address dhcp

Ping to Google DNS server:

Router#ping 8.8.8.8

Entering GE0/1 Interface:

Router(config)#interface gigabitEthernet 0/1

Assigning IP address :

Router(config-if)#ip address 192.168.2.1 255.255.255.0

Making Interface up:

Router(config-if)#no shutdown

Creating DHCP pool:

First go to global configuration mode then

Router(config)#ip dhcp pool mainuser

Router(dhcp-config)#network 192.168.2.0 /24

Router(dhcp-config)#default-router 192.168.2.1

Router(dhcp-config)#dns-server 8.8.8.8

Router(dhcp-config)#exit

Static Routing for default Gateway

Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

Configuring NAT Outside:

Router(config)#interface gigabitEthernet 0/0

Router(config-if)#ip nat outside

Router(config-if)#exit

Configuring NAT inside:

Router(config)#interface gigabitEthernet 0/1

Router(config-if)#ip nat inside

Router(config-if)#exit

Creating Access list:

Router(config)#ip access-list standard 1

Router(config-std-nacl)#permit any

Router(config-std-nacl)#exit

Overloading IP NAT inside source to the interface gigabitEthernet 0/0:

Router(config)#ip nat inside source list 1 interface gigabitEthernet 0/0 overload

Router(config-if)#exit

 

https://www.youtube.com/channel/UCmZZ2BNGXQH1HPS3uIVnr7A?sub_confirmation=1

 

 

Cisco #Router_Configuration #IT_Support_People In this video I've demonstrated step by step process how to connect Cisco 2851 Router and Cisco 3560 Switch to ISP Home router and access internet. I also described connection details and configuration of Cisco router using Putty and console cable. IT

Hello All,

 

I have a CISCO 2800 router and I would like to configure for internet access.

 

Can someone help me whether the below configuration is correct? Thanks

 

ip domain name MGM
ip name-server 103.8.46.5
ip name-server 103.8.45.5

MGM(config)# interface Ethernet1/0
MGM(config-if)# Description MGM LAN
MGM(config-if)# ip address 10.11.11.13 255.255.255.0
MGM(config-if)# ip nat inside
MGM(config-if)# no shutdown
MGM(config-if)# exit

MGM(config)# interface FastEthernet0/0
MGM(config-if)# Description ILL Internet
MGM(config-if)# ip address 14.90.207.54 255.255.255.252
MGM(config-if)# ip nat outside
MGM(config-if)# no shutdown
MGM(config-if)# exit

MGM(config)# ip nat inside source list 1 interface FastEthernet0/0 overload
MGM(config)# ip route 0.0.0.0 0.0.0.0 14.90.207.53


MGM(config)# access-list 1 permit 10.11.11.1.0 0.0.0.255

 

I tried to ping to 10.11.11.1 Local LAN gateway. ( This is in VLAN )

Internet gateway 14.90.207.53

 

Please help me.

 

Thanks

GKJ

Hello,

 

this looks like a typo:

 

--> MGM(config)# access-list 1 permit 10.11.11.1.0 0.0.0.255

 

Make sure the access list says:

 

MGM(config)# access-list 1 permit 10.11.11.0 0.0.0.255

 

If it still doesn't work, post the full running configuration (sh run)...

Thank you so much for the reply and finding the mistake what I done.

 

One more question: The scenario is given below.

 

Internet IP : 14.99.207.54 and gateway is 14.99.207.54  My router is connected in the airport.

Airport and made Vlan for my company 

10.223.1.1 -Vlan

 

LAN IP is 10.11.11.13  gateway is 10.11.11.1

 

When I configure 10.223.1.9 in my laptop  and trying to PING  10.11.11.1 is not pinging.

 

Is this not pinging because of typo error I made?  

 

Thanks

GKJ

 

 

Hello,

 

-->  10.223.1.1 -Vlan

LAN IP is 10.11.11.13 gateway is 10.11.11.1

When I configure 10.223.1.9 in my laptop and trying to PING 10.11.11.1 is not pinging.

 

Did you configure that Vlan interface on your router ? Post the running configuration (sh run).

Yes, they have given VLAN IP for my systems in my office.

 

In between they have fortigate firewall. They are saying they have done the routing and acl in the firewall.

 

When I configure  two laptops with Vlan IP and connected through switch it is pinging.

 

But when connect the same through router it is not pinging.

 

Running configuration, I had pasted in my first post.

Hello,

 

I don't see the running configuration (sh run). Either way, where is IP address 10.223.1.1 configured, on your router ?

That is the doubt I have.

 

I have not configured 10.223.1.1 anywhere, Do I need to configure?

I really don't what I missed here.

Actually, they told me to configure LAN IP as 10.11.11.13 and gateway 10.11.11.1 in the router

Please help me what I should configure.

 

Thanks

GKJ

 

 

Hello,

 

post a schematic drawing of what you want to accomplish. If you need another Vlan, you need an SVI, and switchports configured for that Vlan.

Let me explain.

 

I have a router 2800.

My WAN is connected to 0/0 and IP is 14.99.207.54 and gateway is 14.99.207.53

And LAN IP is 10.11.11.13 and Gateway is 10.11.11.1

For my desktop I have a Vlan - 10.223.1.1 gateway.

The vendor is having a firewall and they have configured VLAN and ACL in their firewall.

Internet routing I have to configure.

After I done the routing, I am not able to ping to VLAN gateway and no internet is working.

How can I configure? Please help me.

 

Review Cisco Networking for a $25 gift card