cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

2350
Views
5
Helpful
6
Replies
Highlighted
Beginner

Configuring EIGRP on ethernet interfaces

Hello Cisco Support Community,

Is it possible to create an EIGRP lab using routers which have ethernet interfaces only? None of my routers have serial interfaces. Labs I've seen on the Internet use routers which use serial interfaces as well as ethernet.

Any advice is appreciated.

Rob

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Advisor

Configuring EIGRP on ethernet interfaces

Rob,

The configurations look fine, but the error messages seem to indicate that you *might* have your connections crossed?

5d23h: IP-EIGRP: Neighbor 170.170.2.2 not on common subnet for FastEthernet0/0 (170.170.1.1 255.255.255.0)

5d23h: IP-EIGRP: Neighbor 170.170.1.2 not on common subnet for FastEthernet0/1 (170.170.2.1 255.255.255.0)

5d23h: IP-EIGRP: Neighbor 170.170.2.2 not on common subnet for FastEthernet0/0 (170.170.1.1 255.255.255.0)

It's saying that you are trying to peer with your "Router C" on F0/0 which is showing "Router B" in your topology above. Can you switch these cables and try again or reconfigure the addressing?

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

6 REPLIES 6
Advisor

Configuring EIGRP on ethernet interfaces

Absolutely. EIGRP doesn't care what type of interface it's running on, it only matters what interfaces eigrp is configured to listen on.

HTH,

John

HTH, John *** Please rate all useful posts ***
Beginner

Configuring EIGRP on ethernet interfaces

Hi John,

Thanks for clarifying that. I have the following EIGRP set up with 3 2600s to start the lab.

Once I enable EIRGP on each router I get the messages on the routers:

5d23h: IP-EIGRP: Neighbor 170.170.2.2 not on common subnet for FastEthernet0/0 (170.170.1.1 255.255.255.0)

5d23h: IP-EIGRP: Neighbor 170.170.1.2 not on common subnet for FastEthernet0/1 (170.170.2.1 255.255.255.0)

5d23h: IP-EIGRP: Neighbor 170.170.2.2 not on common subnet for FastEthernet0/0 (170.170.1.1 255.255.255.0)

I have read on this forum and other posts that interfaces need to be on the same subnet. Obviously, when I configure the interfaces on Router A in the same subnet, one can't as there is an over lap. Hows does one get around please?

Many thanks in advance,

Rob

Configs of each router.

Router A

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router_A

!

!

ip subnet-zero

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 170.170.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 170.170.2.1 255.255.255.0

duplex auto

speed auto

!

router eigrp 10

network 170.170.0.0

auto-summary

!

ip classless

ip http server

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

end

Router B

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router_B

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 170.170.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 180.180.3.2 255.255.255.0

duplex auto

speed auto

!

router eigrp 10

network 170.170.0.0

network 180.180.0.0

auto-summary

!

ip http server

ip classless

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

!

end

Router C

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router_C

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 170.170.2.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router eigrp 10

network 170.170.0.0

auto-summary

!

ip http server

ip classless

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

end

Advisor

Configuring EIGRP on ethernet interfaces

Hi,

the config looks good.

Can you check this doc and see if it fits your topology: http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080093f09.shtml

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Configuring EIGRP on ethernet interfaces

Thank you for your response Alain and the article.

Advisor

Configuring EIGRP on ethernet interfaces

Rob,

The configurations look fine, but the error messages seem to indicate that you *might* have your connections crossed?

5d23h: IP-EIGRP: Neighbor 170.170.2.2 not on common subnet for FastEthernet0/0 (170.170.1.1 255.255.255.0)

5d23h: IP-EIGRP: Neighbor 170.170.1.2 not on common subnet for FastEthernet0/1 (170.170.2.1 255.255.255.0)

5d23h: IP-EIGRP: Neighbor 170.170.2.2 not on common subnet for FastEthernet0/0 (170.170.1.1 255.255.255.0)

It's saying that you are trying to peer with your "Router C" on F0/0 which is showing "Router B" in your topology above. Can you switch these cables and try again or reconfigure the addressing?

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

Beginner

Configuring EIGRP on ethernet interfaces

Hi John,

I changed the addressing and all seems fine now. Many thanks for your help. Now I can continue with the lab.

Regards,

Rob

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here