02-12-2010 01:02 AM - edited 03-04-2019 07:29 AM
I am currently trying to configure QoS on a 128K (I know ridicuoulsy small) satallite connection. The line has to carry critical data and when not heavily used a single Desktop Video Conference (DVC) stream.
All traffic needs to be encrypted and I am therefore using VTI Tunnels, using dialler interfaces over HWIC-4T RS530 serial in to the satalleite communications equipment,
Hardware used at both ends are 3845 ISR routers, running Advanced Enterprise 12.4(15)T IOS.
The issue I have is that I can provision traffic on the link using PPP Multilink with Interleaving, but as soon as I add a Service Policy to the line the Queues fill up and I get no data through. The Service Policy without Multilink configured appears to perfom and queue traffic as expected.
Is it possible to configured CBWFQ with a fair-queue default clas on a PPP Multilink dialer connection?
I have provided an example configuration for one end of the link (both ends are the same) and some additioanal output for ther interfaces and policy.
Any advice and assistance is very much appreciated.
Cheers
Steve
interface Dialer1
description Dialer 1 - 128K - VSAT DDR connection
bandwidth 128
ip address 10.4.0.2 255.255.255.252
ip access-group VSAT_EVENT_CONTROL in
ip access-group VSAT_EVENT_CONTROL out
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation ppp
dialer pool 1
dialer string 575001
dialer string 575002
dialer string 575003
dialer-group 1
peer default ip address 10.4.0.1
no cdp enable
ppp multilink
max-reserved-bandwidth 86
service-policy output STEVE-TEST
interface Serial0/0/0
description S0/0/0 - VSAT connection - Tunnel 50200104
bandwidth 128
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
pulse-time 1
no cdp enable
max-reserved-bandwidth 86
D-3845-01-C1-1#sh policy-map int d1
Dialer1
Service-policy output: STEVE-TEST
Class-map: STEVE-TEST1 (match-any)
78 packets, 13090 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp cs5 (40) ef (46) cs6 (48)
78 packets, 13090 bytes
5 minute rate 0 bps
Queueing
Output Queue: Conversation 41
Bandwidth remaining 20 (%)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: STEVE-TEST2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af41 (34)
Queueing
Output Queue: Conversation 42
Bandwidth remaining 4 (%)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
92 packets, 21096 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 32
(total queued/total drops/no-buffer drops) 0/0/0
!
policy-map STEVE-TEST
class STEVE-TEST1
bandwidth remaining percent 20
class STEVE-TEST2
bandwidth remaining percent 4
class class-default
fair-queue
!
class-map match-any STEVE-TEST1
match ip dscp cs5 ef cs6
class-map match-all STEVE-TEST2
match ip dscp af41
Dialer1 is up, line protocol is up (spoofing)
Hardware is Unknown
Description: Dialer 1 - 128K VSAT DDR connection
Internet address is 10.4.0.1/32
MTU 1500 bytes, BW 128 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Interface is bound to Vi1
Interface is bound to Se0/0/0
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:06:19
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: Class-based queueing
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/32 (active/max active/max total)
Reserved Conversations 2/2 (allocated/max allocated)
Available Bandwidth 110 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
430 packets input, 99752 bytes
264 packets output, 70512 bytes
Bound to:
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1500 bytes, BW 128 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 7/255
Encapsulation PPP, LCP Open, multilink Open
Open: IPCP
MLP Bundle vaccess, cloned from Dialer1
Vaccess status 0x40, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
Time to interface disconnect: idle 00:01:58
Interface is bound to Di1 (Encapsulation PPP)
Last input 00:05:43, output never, output hang never
Last clearing of "show interface" counters 00:06:20
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 107
Queueing strategy: Class-based queueing
Output queue: 118/1000/64/107 (size/max total/threshold/drops)
Conversations 2/3/32 (active/max active/max total)
Reserved Conversations 2/2 (allocated/max allocated)
Available Bandwidth 110 kilobits/sec
5 minute input rate 4000 bits/sec, 2 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
433 packets input, 99794 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
267 packets output, 70554 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Bound to:
Serial0/0/0 is up, line protocol is up
Hardware is HWIC-Serial
Description: S0/0/0 - VSAT - DIALER 1
MTU 1500 bytes, BW 128 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 5/255
Encapsulation PPP, LCP Open, multilink Open
Link is a member of Multilink bundle Virtual-Access1, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Interface is bound to Di1 (Encapsulation PPP)
CRC checking enabled
Last input 00:00:01, output 00:00:03, output hang never
Last clearing of "show interface" counters 00:06:23
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
02-23-2010 06:47 AM
You can, but you need to apply it to the physical interface.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide