cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2271
Views
0
Helpful
1
Replies

Creating Multiple PPPOE Sessions

rburkholder
Level 1
Level 1

I have a Cisco871W running 12.4(11)T. I have access to two pppoe providers. I have a configuration that, when one provider goes down, the other one comes up. I'd like to have both up at the same time. Once both are up, I'll do some PBR for sending traffic to one vs the other.

Note: The wireless configs don't show, but is the reason for the BVI1 interface.

The question, though, is how to get both dial1 and dial2 interfaces up and connected with a virtual interface at the same time.

==============

NorthCourt#sho pppoe ses

2 client sessions

Uniq ID PPPoE RemMAC Port VT VA State

SID LocMAC VA-st

N/A 3914 0030.8802.5310 Fa4 Di1 N/A PADRSNT

0015.6200.6788

N/A 1122 0030.8802.5310 Fa4 Di2 Vi1 UP

0015.6200.6788 UP

NorthCourt#

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

aaa session-id common

clock timezone AST -4

clock summer-time ADT recurring 1 Sun Apr 2:00 last Sun Oct 2:00

no ip source-route

no ip gratuitous-arps

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1 10.10.10.99

!

ip dhcp pool sdm-pool

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.254

lease 0 2

!

!

ip tcp synwait-time 10

no ip bootp server

no ip domain lookup

!

!

!

bridge irb

!

!

!

!

interface Null0

no ip unreachables

!

interface FastEthernet0

load-interval 30

no cdp enable

!

interface FastEthernet1

description Armor01

load-interval 30

no cdp enable

!

interface FastEthernet2

load-interval 30

no cdp enable

!

interface FastEthernet3

load-interval 30

no cdp enable

!

interface FastEthernet4

description dsl to providers

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

load-interval 30

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 2

pppoe-client dial-pool-number 1

no cdp enable

!

!

interface Vlan1

description Interior Network

no ip address

ip virtual-reassembly

ip route-cache flow

load-interval 30

fair-queue

bridge-group 1

!

interface Dialer1

description pppoe to isp 1

mtu 1400

bandwidth 512

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

load-interval 30

dialer pool 1

dialer-group 1

no cdp enable

ppp pap sent-username name2 password <removed>

!

interface Dialer2

description ppoe to isp 2

mtu 1400

bandwidth 512

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

load-interval 30

dialer pool 2

dialer-group 2

no cdp enable

ppp pap sent-username name2 password <removed>

!

interface BVI1

description $ES_LAN$

ip address 10.10.10.254 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

!

ip route 0.0.0.0 0.0.0.0 Dialer1 20

ip route 0.0.0.0 0.0.0.0 Dialer2 20

!

ip nat inside source route-map rmDial1 interface Dialer1 overload

ip nat inside source route-map rmDial2 interface Dialer2 overload

!

ip access-list standard aclNatInside

permit 10.10.10.0 0.0.0.255

!

!

dialer-list 1 protocol ip permit

!

!

route-map rmDial1 permit 10

match ip address aclNatInside

match interface Dialer1

!

route-map rmDial2 permit 10

match ip address aclNatInside

match interface Dialer2

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

1 Reply 1

sbilgi
Level 5
Level 5

Multiple PPPoE clients can run on a different PVCs, in which case, each client has to use a separate dialer interface and a separate dialer pool, and the PPP parameters need to be applied on the dialer interface.Refer URL

http://www.cisco.com/en/US/products/hw/routers/ps380/prod_release_note09186a008007e1fe.html

Review Cisco Networking for a $25 gift card