cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

371
Views
0
Helpful
2
Replies
Highlighted
Beginner

CSR1000v Trial Licenses Keep Invalidating Themselves

I've having an issue using the CSR1000v on ESXi 6.0, we're doing a case study requiring us to test the viability of virtualizing our datacenter infrastructure and we require 3 virtualized routers.

I have two of them that are working fine, but the last one, no matter what I do, keeps changing it's board serial number. I've attempted to statically set the UUID in the VMX file and still no luck. I'm hoping that someone else has encountered this with the CSR1000v.

We need the 60 day trial with actual viable throughput, the basic license includes 100KB/s but we need at minimum 500M and we're all out of the licenses Cisco gives because of Serial number changing and affecting the UDI of the device.

Here's what I've done so far:

1. At first I tried just taking booting the snapshot of it right after we licensed it, it showed up with the correct board serial but was still locked in at a throughput of 100kbs. After some further inspection it was showing the license as invalid and sure enough on reload it changed the board serial number.

2. I re licensed the CSR, it worked until reload, again....I'm out of licenses now :(

3. After noticing that VMWare was changing the board serials, I looked into what could be causing it and it turns out it's the "UUID.BIOS" setting in the virtual machines VMX file. No matter what I do though, statically setting it there or what have we, it still changes the board serial number after reload.

4. I loaded the original VM into Workstation, it did the same thing. I then loaded the VM into Virtualbox, with all the original settings. It worked, it still has yet to reset the serial number.

Thanks in advance,

Jim

2 REPLIES 2
VIP Mentor

Jim,

Jim,

for what it is worth, have a look at the discussion below. It seems to be normal behavior that the UUID changes upon reboot.

https://gns3.com/discussions/csr1000v-3-15s-license-issues-in

Beginner

Thanks,

Thanks,

That's what I've been looking at. I'm going to see if maybe running it in QEMU works instead of ESXi. That's the initial post that got me thinking about how to statically set the UUID and according to VMWare it's the VMX file.

Taking into consideration that it works fine in virtual box, I think it might just be a bug with ESXi.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here