cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
461
Views
0
Helpful
12
Replies
Beginner

DDNS Not Updating by Itself

Hi everyone

I have this Router connected to an ISP which give a dynamic IP

I have done the DDNS config on my router to update when it changes, the problem is that is not happening by itself, I mean I have to either turn off and on the interface or fisically unplug and plug again the ethernet cable so it loses the IP learned and takes the new one and then It does the process that comes with it

It this right? am I missing something?

 

here my config

 

ip ddns update method no-ip
 HTTP
  add http://***USER AND PASSWORD***@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
 interval maximum 0 0 5 0
!

interface GigabitEthernet0/0
 description ABA
 ip ddns update hostname ***HOSTNAME***
 ip ddns update no-ip
 ip address dhcp
 

 

any suggestion?

12 REPLIES 12
VIP Mentor

Re: DDNS Not Updating by Itself

Hello,

 

I think under the update method, you are missing 'ddns' and 'internal'

 

ip ddns update method no-ip
ddns (if you specify 'both', both the A and PTR RRs are update)
internal
HTTP
add http://***USER AND PASSWORD***@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
interval maximum 0 0 5 0
!

interface GigabitEthernet0/0
description ABA
ip ddns update hostname ***HOSTNAME***
ip ddns update no-ip
ip address dhcp

Beginner

Re: DDNS Not Updating by Itself


@Georg Pauwen wrote:

Hello,

 

I think under the update method, you are missing 'ddns' and 'internal'

 

ip ddns update method no-ip
ddns (if you specify 'both', both the A and PTR RRs are update)
internal
HTTP
add http://***USER AND PASSWORD***@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
interval maximum 0 0 5 0
!

interface GigabitEthernet0/0
description ABA
ip ddns update hostname ***HOSTNAME***
ip ddns update no-ip
ip address dhcp


Thanks for your aswers but I cant put that because Im already using HTTP method and if I try it give me this

Only one dynamic DNS update type is allowed in a method.
VIP Mentor

Re: DDNS Not Updating by Itself

Hello,

 

sorry about that, you cannot use both, you would have to disable HTTP first, but that probably wouldn't work

 

What does the rest of your configuration look like ? Do you get an IP address through DHCP ? If so, check if 'ip dhcp-client update dns' is configured.

 

Also, do you have:

 

ip dns server
ip name-server 8.8.8.8
ip name-server 8.8.4.4

 

configured ?

Beginner

Re: DDNS Not Updating by Itself

!
hostname INTERNET-UCS
!
!
ip dhcp excluded-address 192.168.10.3
!
ip dhcp pool INTERNET-UCS
   network 192.168.10.0 255.255.254.0
   default-router 192.168.10.3
   dns-server 192.168.10.3
   lease 0 8
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip ddns update method no-ip
 HTTP
  add http://***user and password***@dynupdate.no-ip.com/nic/update?hostname=<h>&myip=<a>
 interval maximum 0 0 5 0
!

interface GigabitEthernet0/0
 description ABA
 ip ddns update hostname ***hostname***
 ip ddns update no-ip
 ip address dhcp
 ip access-group 120 in
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description Internet-UCS
 ip address 192.168.10.3 255.255.254.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 10 interface GigabitEthernet0/0 overload
!
access-list 10 permit 192.168.10.0 0.0.1.255
access-list 120 remark "Block 53 External Query"
access-list 120 deny   tcp any any eq domain
access-list 120 deny   udp any any eq domain
access-list 120 permit ip any any
VIP Mentor

Re: DDNS Not Updating by Itself

Hello,

 

I don't know how the access list you have applied to the external interface affects the dynamic dns updates, remove it and check if that makes a difference...

 

interface GigabitEthernet0/0
description ABA
ip ddns update hostname ***hostname***
ip ddns update no-ip
ip address dhcp
--> no ip access-group 120 in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto

 

 

Beginner

Re: DDNS Not Updating by Itself

It does not affect

 

I recently added this ´cause some warnings about DNS querys I was getting from outside because 8.8.8.8

but before that It was the same behaviour

VIP Mentor

Re: DDNS Not Updating by Itself

Hello,

 

try and give the router a reboot (if you have not already done that) and check if that makes a difference...

Beginner

Re: DDNS Not Updating by Itself

still the same

VIP Mentor

Re: DDNS Not Updating by Itself

Hello,

 

actually, I think you are supposed to shut/no shut the interface for NO-IP to do the job.

 

You can automate this by configuring archive logging and a small EEM script. The script will run every time you change the hostname.

 

archive
 log config
  logging enable
  notify syslog
  hidekeys

 

event manager applet SHUT_NO_SHUT
event syslog pattern "hostname"
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "interface GigabitEthernet0/0"
action 4.0 cli command "shut"
action 5.0 cli command "no shut"
action 6.0 cli command "end"

Beginner

Re: DDNS Not Updating by Itself


@Georg Pauwen wrote:

Hello,

 

actually, I think you are supposed to shut/no shut the interface for NO-IP to do the job.

 

You can automate this by configuring archive logging and a small EEM script. The script will run every time you change the hostname.

 

archive
 log config
  logging enable
  notify syslog
  hidekeys

 

event manager applet SHUT_NO_SHUT
event syslog pattern "hostname"
action 1.0 cli command "enable"
action 2.0 cli command "conf t"
action 3.0 cli command "interface GigabitEthernet0/0"
action 4.0 cli command "shut"
action 5.0 cli command "no shut"
action 6.0 cli command "end"


woo to be honest I didn´t knwo you could do that!

but that makes a question to come up. If I understood the script it will execute once the logs show a change on my hostname right?  but how will that change If it does not change IP without doing the shut/no shut operation? I dont know if you get the idea of my question..

VIP Mentor

Re: DDNS Not Updating by Itself

Hello,

 

not sure if I understand your question...the script will shut/no shut the interface whenever the hostname changes. That should, at least that is how I understand the update process to work, update the DNS...

Beginner

Re: DDNS Not Updating by Itself

I just apply your solution...

I´ll come back to say if it works, thank you

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards