cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
649
Views
0
Helpful
5
Replies

Default Route Being Readvertised

nonamer15
Level 1
Level 1

I'm not sure a good title for this. I've got 2 routers directly connected to each other as below.

img.JPG

 

I've got R1 setup as a DHCP server and that's how R2 is receiving its IP information. Within that DHCP pool, I've assigned the default router as R1s ge2 IP. Afterwards, I configure RIPv2. When doing this, R2 is advertising a default route of itself to R1, which I can't figure out why it would be doing that. Below is the configuration.

R1
!
interface GigabitEthernet2
 ip address 10.1.1.1 255.255.255.0
!
ip dhcp excluded-address 10.1.1.1
ip dhcp pool 1
 network 10.1.1.0 255.255.255.0
 default-router 10.1.1.1 
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary

R2
!
interface GigabitEthernet2
 ip address dhcp
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary

 

Below are the routing tables.

R1#
Gateway of last resort is 10.1.1.4 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 10.1.1.4, 00:00:25, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, GigabitEthernet2
L        10.1.1.1/32 is directly connected, GigabitEthernet2


R2#
Gateway of last resort is 10.1.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 10.1.1.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, GigabitEthernet2
L        10.1.1.4/32 is directly connected, GigabitEthernet2

 

R2s routing table makes sense. I would not expect the default route on R1. I'm guessing because R2 is receiving that default route via DHCP and then advertising it via RIP, split horizon doesn't prevent that route from being advertised to R1 as it's different. Seems strange to me that R2 uses its IP within the default route, though.

 

I was able to prevent the above from happening with some configuration changes.

  1. Remove the 'default-router' command from the DHCP pool
  2. Add the 'default-information originate' command under the RIP configuration for R1

 

I'm still curious as to the behavior of R2, though. Thanks.

 

 

5 Replies 5

NetAcad506
Level 1
Level 1

@nonamer15 wrote:

I'm not sure a good title for this. I've got 2 routers directly connected to each other as below.

img.JPG

 

I've got R1 setup as a DHCP server and that's how R2 is receiving its IP information. Within that DHCP pool, I've assigned the default router as R1s ge2 IP. Afterwards, I configure RIPv2. When doing this, R2 is advertising a default route of itself to R1, which I can't figure out why it would be doing that. Below is the configuration.

R1
!
interface GigabitEthernet2
 ip address 10.1.1.1 255.255.255.0
!
ip dhcp excluded-address 10.1.1.1
ip dhcp pool 1
 network 10.1.1.0 255.255.255.0
 default-router 10.1.1.1 
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary

R2
!
interface GigabitEthernet2
 ip address dhcp
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary

 

Below are the routing tables.

R1#
Gateway of last resort is 10.1.1.4 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 10.1.1.4, 00:00:25, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, GigabitEthernet2
L        10.1.1.1/32 is directly connected, GigabitEthernet2


R2#
Gateway of last resort is 10.1.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 10.1.1.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, GigabitEthernet2
L        10.1.1.4/32 is directly connected, GigabitEthernet2

 

R2s routing table makes sense. I would not expect the default route on R1. I'm guessing because R2 is receiving that default route via DHCP and then advertising it via RIP, split horizon doesn't prevent that route from being advertised to R1 as it's different. Seems strange to me that R2 uses its IP within the default route, though.

 

I was able to prevent the above from happening with some configuration changes.

  1. Remove the 'default-router' command from the DHCP pool
  2. Add the 'default-information originate' command under the RIP configuration for R1

 

I'm still curious as to the behavior of R2, though. Thanks.

 

 


Hi! I just duplicated your config, but got different results:

hostname DHCP
ip dhcp excluded-address 10.1.1.1
ip dhcp pool 1
 network 10.1.1.0 255.255.255.0
 default-router 10.1.1.1
interface FastEthernet0/1
 ip address 10.1.1.1 255.255.255.0
 duplex auto
 speed auto
router rip
 version 2
 network 10.0.0.0
 no auto-summary

hostname CLIENT
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
router rip
 version 2
 network 10.0.0.0
 no auto-summary

ABOUT ROUTING TABLES:

DHCP#sho ip route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/1
DHCP#

CLIENT#sho ip route

Gateway of last resort is 10.1.1.1 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/1
S*   0.0.0.0/0 [254/0] via 10.1.1.1
CLIENT#


sivam siva
Level 3
Level 3

HI

Post full R2 config

nonamer15
Level 1
Level 1

@NetAcad506

I tried again and am still getting the same results. I'm using Cisco Modeling Labs instead of actual hardware. I wouldn't think that should matter, though.

 

@sivam siva

Below are the full configs for both routers.

R1
!
version 16.5
service timestamps debug datetime localtime
service timestamps log datetime localtime
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
platform console serial
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
!
no ip domain lookup
ip dhcp excluded-address 10.1.1.1
!
ip dhcp pool 1
 network 10.1.1.0 255.255.255.0
 default-router 10.1.1.1       
!
subscriber templating
! 
multilink bundle-name authenticated
!
license udi pid CSR1000V sn 9KJ5BOOKE9I
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
redundancy
!
interface GigabitEthernet1
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet2
 ip address 10.1.1.1 255.255.255.0
 negotiation auto
 no mop enabled
 no mop sysid
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
threat-visibility
!
virtual-service csr_mgmt
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login    
!
end

R2
!
version 16.5
service timestamps debug datetime localtime
service timestamps log datetime localtime
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
platform console serial
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
no ip domain lookup
!
subscriber templating
!
multilink bundle-name authenticated
!
license udi pid CSR1000V sn 9IBB3JPLW73
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
redundancy
!
interface GigabitEthernet1
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet2
 ip address dhcp
 negotiation auto
 no mop enabled
 no mop sysid
!
router rip
 version 2
 network 10.0.0.0
 no auto-summary
!
threat-visibility
!
virtual-service csr_mgmt
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
control-plane
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Hi

R* indicate that default-information originate command configured under R2 RIP , but i couldn't find that in your post

Try to execute "No default-information originate" under R2 Router rip.

nonamer15
Level 1
Level 1

I don't have default-information originate on either on R1 or R2. I issued no default-information originate under the RIP configuration for both routers, but still no change.

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router rip
R2(config-router)#no default-information originate
R2(config-router)#end
R2#

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#no default-information originate
R1(config-router)#end
R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 10.1.1.2 to network 0.0.0.0

R*    0.0.0.0/0 [120/1] via 10.1.1.2, 00:00:11, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, GigabitEthernet2
L        10.1.1.1/32 is directly connected, GigabitEthernet2
R1#

I'm not sure why this is happening.

R2#
*Aug 26 18:23:08: RIP: sending v2 update to 224.0.0.9 via GigabitEthernet2 (10.1.1.2)
*Aug 26 18:23:08: RIP: build update entries
*Aug 26 18:23:08:       0.0.0.0/0 via 0.0.0.0, metric 1, tag 0
R2#

R1#
*Aug 26 18:23:29: RIP: sending v2 update to 224.0.0.9 via GigabitEthernet2 (10.1.1.1)
*Aug 26 18:23:29: RIP: build update entries - suppressing null update
R1#
*Aug 26 18:23:35: RIP: received v2 update from 10.1.1.2 on GigabitEthernet2
*Aug 26 18:23:35:      0.0.0.0/0 via 0.0.0.0 in 1 hops
R1#

R1#sh ip rip database
0.0.0.0/0    auto-summary
0.0.0.0/0
    [1] via 10.1.1.2, 00:00:28, GigabitEthernet2
10.0.0.0/8    auto-summary
10.1.1.0/24    directly connected, GigabitEthernet2
R1#

R2#sh ip rip database
0.0.0.0/0    auto-summary
0.0.0.0/0    redistributed
    [1] via 0.0.0.0, 
10.0.0.0/8    auto-summary
10.1.1.0/24    directly connected, GigabitEthernet2
R2#
Review Cisco Networking for a $25 gift card