05-26-2019 06:48 PM - edited 05-26-2019 06:49 PM
i am trying to make a dialin server using a cisco 2650xm and an nm-16am. ive configured it based on https://www.cisco.com/c/en/us/support/docs/interfaces-modules/2600-3600-series-16-port-analog-modem-network-module/24393-nm-xam-dialin.html but when i connect to this router by the client, the call is dropped during the dialing process. am i missing anything or have i done somthing incorrect? router version is 12.4(25d)
05-27-2019 12:32 AM - edited 05-27-2019 12:36 AM
Hello Ali6359,
for configuration to work correctly you need to refer the correct line numbers
You can check this with
show line
If you want you can post output of show line and relevant configuration files.
There is a note in the document that you have provided that advises about the need for proper connection to ground of the router.
>>Be absolutely sure to use a properly-grounded power source for Cisco 2600 and 3600 routers with NM-AM modules; otherwise, the NM-AM modem calls have a buzzing sound that manifests itself as poor or failed connections. Refer to the document Installing the Grounding Lug on Cisco 2600 Series and Cisco 3600 Series Routers for more information.
Edit:
You also need to have true analog phone lines available. I don't think a back to back connection can work as all the intelligence for calling a phone number is in the PSTN switches.
Hope to help
Giuseppe
05-27-2019 07:42 AM - edited 05-27-2019 07:47 AM
C2600XM#show line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
* 0 CTY - - - - - 0 1 0/0 -
33 TTY 115200/115200- DialIn - - - 0 0 0/0 -
34 TTY 115200/115200- DialIn - - - 0 0 0/0 -
35 TTY 115200/115200- DialIn - - - 0 0 0/0 -
36 TTY 115200/115200- DialIn - - - 0 0 0/0 -
37 TTY 115200/115200- DialIn - - - 0 0 0/0 -
38 TTY 115200/115200- DialIn - - - 0 0 0/0 -
39 TTY 115200/115200- DialIn - - - 0 0 0/0 -
40 TTY 115200/115200- DialIn - - - 0 0 0/0 -
41 TTY 115200/115200- DialIn - - - 0 0 0/0 -
42 TTY 115200/115200- DialIn - - - 0 0 0/0 -
43 TTY 115200/115200- DialIn - - - 0 0 0/0 -
44 TTY 115200/115200- DialIn - - - 0 0 0/0 -
45 TTY 115200/115200- DialIn - - - 0 0 0/0 -
46 TTY 115200/115200- DialIn - - - 0 0 0/0 -
47 TTY 115200/115200- DialIn - - - 0 0 0/0 -
48 TTY 115200/115200- DialIn - - - 0 0 0/0 -
65 AUX 9600/9600 - - - - - 0 0 0/0 -
66 VTY - - - - - 0 0 0/0 -
67 VTY - - - - - 0 0 0/0 -
68 VTY - - - - - 0 0 0/0 -
69 VTY - - - - - 0 0 0/0 -
70 VTY - - - - - 0 0 0/0 -
Line(s) not in async mode -or- with no hardware support:
1-32, 49-64
for config:
C2600XM#sh conf
Using 1236 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C2600XM
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
modem country smart_acf australia
ip cef
!
!
!
!
no ip domain lookup
ip domain name cisco.com
async-bootp dns-server 5.5.5.1 5.5.5.2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ali password 0 1234
!
!
controller E1 0/0
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Group-Async1
ip unnumbered Loopback0
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
async mode dedicated
peer default ip address pool DIALIN
ppp authentication chap pap
!
ip local pool DIALIN 10.1.1.1 10.1.1.19
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.138
!
!
ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line 33 48
modem Dialin
transport input all
autoselect ppp
line aux 0
line vty 0 4
login
!
!
end
i have this unit properly grounded, its connected to a PABX and one of the connections from the pabx goes to the client pc. i listened to the audio of the dialing process using a phone connected to the client modem and there is no noise at all. it sounds clear and dosent have any problems. just seems to drop the connection when trying to register the network to the client.
05-27-2019 08:32 AM
Hello Ali6359,
under interface Group-Async 1
interface Group-Async 1
group range 33 48
A command is needed to link the Group-Async logical interface to the physical lines.
Hope to help
Giuseppe
05-27-2019 09:25 AM
that fixed the issue. the dialup connection now registers successfully and seems all good but, i have no internet connection at the client. ipconfig shows no default gateway. what could be the issue?
05-27-2019 11:00 AM
Hello Ali,
the configuration example that you have followed was intended to provide only remote access to a network not to give access to public Internet.
There is no trace of any NAT command.
I would suggest the following:
change loop0 ip address to
int loop0
ip address 10.1.1.1 255.255.255.0
in this way the loopback address is in the same IP subnet of the IP address pool used by the RAS server.
You would need also a NAT configuration as all the IP addresses are private in RFC 1918.
You can give a try to:
int Group-Async 1
ip nat inside
interface fas0/0
ip nat outside
access-list 1 permit 10.1.1.0 0.0.0.15
ip nat inside source list 1 interface fas0/0 overload
However, I'm not sure the first interface can accept NAT commands
Hope to help
Giuseppe
05-27-2019 11:19 PM
using 10.1.1.1 does not assign an ip address at the client at all and the connection is dropped. ive also tried changing the ip of the lo0 to 192.168.0.12 255.255.255.0 to try and this time it dials and connects but still no internet access
05-28-2019 12:37 AM
Hello Ali6359,
I have given a look at IOS Dial command reference.
It is possible to use a DHCP server instead of a simple pool
peer default ip address {ip-address | dhcp | pool [pool-name-list]}
dhcp |
Retrieves an IP address from the DHCP server.
see https://www.cisco.com/c/en/us/td/docs/ios/12_2/dial/command/reference/fdial_r/drfmupp.html
You can configure your router as a DHCP server. In DHCP scope / pool configuration you can provide additional info like a default gateway.
Hope to help Giuseppe
|
05-28-2019 01:34 AM
back to the problem but this time worse with DHCP, now the connection fails totaly.
05-28-2019 01:53 AM
Hello Ali6359,
post your current configuration and the output of
debug ppp negotiation
This debug is very useful to understand why a PPP session fails.
Hope to help
Giuseppe
05-28-2019 01:57 AM
C2600XM#sh conf
Using 1383 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C2600XM
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
modem country smart_acf australia
ip cef
!
!
!
!
no ip domain lookup
ip domain name cisco.com
async-bootp dns-server 5.5.5.1 5.5.5.2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ali password 0 1234
!
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Group-Async1
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
async mode dedicated
peer default ip address dhcp
ppp authentication chap pap
group-range 33 48
!
ip local pool DIALIN 10.1.1.1 10.1.1.19
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.138
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 10.1.1.0 0.0.0.15
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line 33 48
modem Dialin
transport input all
autoselect ppp
line aux 0
line vty 0 4
login
!
!
end
C2600XM#
C2600XM#debug ppp negotiation
PPP protocol negotiation debugging is on
05-28-2019 02:13 AM
Hello Ali6359,
first of all to see output of debug commands you need
terminal monitor
on your telnet/SSH session
The second point is that you haven't configured your router to be a DHCP server.
see the following document as a reference:
https://www.cisco.com/c/en/us/td/docs/ios/12_2/ip/configuration/guide/fipr_c/1cfdhcp.html
You need to configure an ip dhcp pool you cannot re-use the existing pool that is only for IPCP with PPP.
You need something like:
ip dhcp pool TESTPOOL
network 172.16.1.0 /24
default-router 172.16.1.100 172.16.1.101 ! this is the option to specify default gateway
lease 30
!
I am sorry I have not been clear enough in my previous post.
Hope to help
Giuseppe
06-06-2019 05:37 AM - edited 06-06-2019 05:47 AM
ive decided to get rid of my NM-16AM and instead, replace it with a WIC-1AM, as there is only 1 client connecting. ive configured the 2600xm and modem using this video https://youtu.be/ED2I6uBjxiU . it connects but i dont have internet access. how do i set up the internet connections using my wic1am?
config:
Router#sh conf
Using 1251 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication ppp default if-needed local
!
aaa session-id common
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ali password 0 1234
!
!
controller E1 0/1
!
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.123 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Async1
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
ip tcp header-compression
async mode dedicated
peer default ip address 172.16.10.2
ppp authentication pap chap
routing dynamic
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.138
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 10.1.1.0 0.0.0.15
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line 1
modem Dialin
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
!
!
end
Router#
06-06-2019 06:03 AM
Hello Ali6359,
compare your NAT configuration :
ip nat inside source list 1 interface FastEthernet0/0 overload
!
>>>access-list 1 permit 10.1.1.0 0.0.0.15
with the configuration you have under Async interface:
interface Async1
ip unnumbered Loopback0
ip nat inside
encapsulation ppp
ip tcp header-compression
async mode dedicated
>>>> peer default ip address 172.16.10.2
ppp authentication pap chap
routing dynamic
!
Use the following ACL
access-list 2 permit host 172.16.10.2
! to define what should be NATTed
! then
no ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source list 2 interface FastEthernet0/0 overload
Try from the remote user to ping something reachable via the Fas0/0 interface and check
with
show ip nat translation
If you see NAT occurring on the router.
Hope to help
Giuseppe
06-10-2019 11:21 PM
can you post the config with the fixes? i messed up the config on the router and i am confused to what is going on.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide