cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
389
Views
2
Helpful
3
Replies
LBaroufNo1
Beginner

Help with 857W router

Hello,

I got myself a Cisco 857W router. I have configured it to initiate a connection on ATM0, and it connects, I can ping from the console websites as an example. I have set a DHCP and NATing. But it seems that the clients can't be routed to the internet. Not sure what I'm doing wrong.

Not sure if it makes it more complexe, but FastEthernet0 is connected to another router. But the problem is the same if I connect a computer to it, instead of the router. Ultimatly, I'd like to use my other router for the Wifi portion (I know, I know, it's a 857W that I have, but yet it's the other one that will be used for the wireless only).

Building configuration...

Current configuration : 2120 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$AWf.$Bvpoe21JARraJlzR0nvqH/
enable password ********
!
no aaa new-model
!
!
dot11 syslog
no ip routing
no ip dhcp use vrf connected
ip dhcp excluded-address 8.8.8.8
ip dhcp excluded-address 8.8.4.4
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool vlan1
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 8.8.8.8
!
!
no ip cef
!
!
!
username ****** privilege 15 password 0 ********
!
!
archive
log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
ip virtual-reassembly
no ip route-cache
no atm ilmi-keepalive
pvc 0/35
  pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
ip tcp adjust-mss 1452
shutdown
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname <username>
ppp chap password 0 <password>
ppp pap sent-username <username> password 0 <password>
ppp ipcp dns request
ppp ipcp route default
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip nat inside source list 100 interface Dialer0 overload
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password <password>
login
!
scheduler max-task-time 5000
end


Any help will be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

issue command

ip routing

add this also

ip route 0.0.0.0 0.0.0.0 dialer 0

Also

Int Vlan 1

no shut

*** Do Rate Helpful Posts***

Jawad

View solution in original post

3 REPLIES 3
Jeff Van Houten
Contributor

If you're not going to use the wireless, get rid of the bridging and do a no shut on vlan1.

Sent from Cisco Technical Support iPad App

Hi,

issue command

ip routing

add this also

ip route 0.0.0.0 0.0.0.0 dialer 0

Also

Int Vlan 1

no shut

*** Do Rate Helpful Posts***

Jawad

View solution in original post

Thanks, it does work for clients other than the router. I assigned a static IP to the router for it to work and all is good. I just wonder why it wouldn't get an IP by DHCP if it has a DHCP client? Strange to me, it work in the end.

Cheers and thank you!